Software Centre - automatically add app icon to launcher

Bug #761851 reported by Christian Giordano on 2011-04-15
54
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
Matthew Paul Thomas
Unity
Fix Released
High
Bilal Akhtar
unity-2d
Medium
Unassigned
software-center (Ubuntu)
Medium
Gary Lasker
unity (Ubuntu)
High
Bilal Akhtar
unity-2d (Ubuntu)
Medium
Florian Boucault

Bug Description

Binary package hint: software-center

It seems quite a common case where after clicking "install" the user is prompted first with the user password and then with the "add to laucher" option dialog. I was wondering if the second dialog could be avoided providing a way to add it to launcher while it's downloading/installing (ie. check box which the user can modify but might not).

---------------------------------
Desired solution:

When a application is installed from the Software Centre it's icon should be automatically pinned to the Launcher. The option in the software centre to "Add [app name] to the launcher?" after installing a application should be removed.

Related branches

tags: added: design
Matthew Paul Thomas (mpt) wrote :

The item should just be added to the launcher, and then you can remove it if you want.
https://wiki.ubuntu.com/SoftwareCenter#launching

Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Medium
status: New → Triaged
assignee: Matthew Paul Thomas (mpt) → Bilal Akhtar (bilalakhtar)
Gary Lasker (gary-lasker) wrote :

I added a task for the Unity side (corresponding to Bilal's linked branch lp:~bilalakhtar/unity/software-center-integration-for-o). Could somebody please set the importance, and also specify bilalakhtar as the assignee for the Unity task? Thanks!

Gary

Changed in unity:
status: New → Confirmed
Changed in software-center (Ubuntu):
assignee: Bilal Akhtar (bilalakhtar) → Gary Lasker (gary-lasker)
status: Triaged → In Progress
Gary Lasker (gary-lasker) wrote :

I've implemented the basic flow as described in mpt's spec (https://wiki.ubuntu.com/SoftwareCenter#launching) on the Software Center side, and this will be released with the next development release of Software Center in Precise. Specifically, I removed the slide-in panel that offers to add a newly-installed application to the Unity launcher, and instead we simply add the newly installed application to the launcher automatically by default. I've also added the new checkmark menu item "View->New Applications in Launcher”, and this can be used to disable this functionality.

Note that this development implementation still uses the current Unity launcher integration capabilities, and so the icon animation and install progress features as described in items 1 through 5 in https://wiki.ubuntu.com/SoftwareCenter#launching will not yet occur. Rather, the application is added to the launcher at the moment the application install completes, with the launcher item "wiggle" to indicate that it has been added there (essentially, this is item 6 in mpt's specification).

The additional animation and progress display features in the launcher will come when the Unity side work in Bilal's branch lp:~bilalakhtar/unity/software-center-integration-for-o is landed in Unity.

Thanks all!

Omer Akram (om26er) on 2011-12-01
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Bilal Akhtar (bilalakhtar)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.3

---------------
software-center (5.1.3) precise; urgency=low

  [ Robert Roth ]
  * Show For version x string instead of for this version when the
    app version is unknown (LP: #889080)

  [ Michael Vogt ]
  * lp:~mvo/software-center/system-wide-license-key-fixes:
    - add support for installing system-wide license keys
      via aptdaemon
  * lp:~mvo/software-center/appdetailsview-cleanup:
    - lots of cleanup for the details view code, merges appdetailsview
      and appdetailsview_gtk, increases unit test coverage
  * debian/control:
    - update dependency from python-gobject to python-gi

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/launcher-integration-for-p:
    - implement automatic adding of all newly installed applications to
      the Unity launcher per the latest specification, this can be
      disabled via menu item "View->Add Applications in Launcher"
      (LP: #761851, LP: #756599, LP: #756701, LP: #773769)
  * test/graph/gen-test-coverage-data.sh,
    test/graph/plot-test-coverage.py:
    - create a graph to track unit test coverage

  [ Kiwinote ]
  * lp:~kiwinote/software-center/fix-icon-updating:
    - fix _update_app_icon() regression
 -- Michael Vogt <email address hidden> Thu, 01 Dec 2011 16:03:34 +0100

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Changed in software-center (Ubuntu):
status: Fix Released → In Progress
Gary Lasker (gary-lasker) wrote :

I'm resetting the software-center task to In Progress because there will be one more update needed on the software-center side when the Unity branch is ready to land. Specifically, rather than queuing up all add-to-launcher requests and firing them when the installation has completed (because it is not until that time that we can determine the installed desktop file and icon locations), we will simply fire the add to launcher request to Unity right at the start of the install, per the specification.

Gary Lasker (gary-lasker) wrote :

Omer, thanks for updating the importance and assignee, you rock! :)

John Lea (johnlea) on 2011-12-01
tags: added: udp
Changed in ayatana-design:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → High
status: New → Fix Committed
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
assignee: nobody → Bilal Akhtar (bilalakhtar)
Gary Lasker (gary-lasker) wrote :

Hi Bilal! Please be sure to use the attached branch lp:~gary-lasker/software-center/launcher-integration-lp761851 when you are developing/finishing your launcher integration code. This branch has the changes that I mentioned in comment #3 as being needed for when the Unity side of the integration is ready to land.

The primary difference between this branch and trunk is that in this branch we fire the dbus call to the Unity launcher service immediately at the start of the application install, whereas in trunk we queue it up because we can't fire it until install is complete so that we can know the correct installed locations for the desktop file and the application icon.

Note that, as you and I have discussed previously, on the Unity side you will need to monitor aptdaemon's events on the dbus in order to display the install progress in the launcher, as well as to detect when a transaction has completed, or if it has failed or been canceled. Once the installation has completed, you can determine the installed locations for the application desktop file and icon (for reference, in the software-center branch you can find the code we used for this in the file softwarecenter/utils.py; refer to the methods get_file_path_from_iconname and convert_desktop_file_to_installed_location()).

As always, thank you for your work on this! And please be sure to ping me if you have any questions or if there's anything at all I can do to help.

John Lea (johnlea) on 2011-12-08
description: updated
John Lea (johnlea) on 2011-12-12
summary: - add to launcher request after started installing
+ Software Centre - automatically add app icon to launcher
Agus Riyadi (riyadi27) on 2012-01-07
Changed in software-center (Ubuntu):
status: In Progress → New
Changed in ayatana-design:
status: Fix Committed → New
Omer Akram (om26er) wrote :

could you please not change the bug status without a comment.

Changed in ayatana-design:
status: New → Fix Committed
Changed in software-center (Ubuntu):
status: New → In Progress
John Lea (johnlea) wrote :

@riyadi27; and could you no change the status in ayatana-design at all, this should only be done by the design team. thanks!

Bilal Akhtar (bilalakhtar) wrote :

I've updated my branch and the merge request here:

https://code.launchpad.net/~bilalakhtar/unity/software-center-integration-for-o/+merge/71905

Sorry for all the delays, this time things are moving much faster. Most of the tougher parts of the code have landed already, and I can anticipate the rest to land by Alpha 2.

Now that we have Bilal's branch in lp:unity I see two remaining tasks:

 1) landing lp:~gary-lasker/software-center/launcher-integration-lp761851 Remove
 2) Adding support for the same feature to unity-2d

Who will pick up on this?

Bilal Akhtar (bilalakhtar) wrote :

As Mikkel has already mentioned, my branch has landed into lp:unity which contains everthing except the animation and the wiggle (which I'll add after my exams or something).

The branch lp:~gary-lasker/software-center/launcher-integration-lp761851 needs to now go into lp:software-center . I'm sure Michael or Gary can do that.

Michal Hruby (mhr3) on 2012-01-27
Changed in unity:
status: In Progress → Fix Committed
milestone: none → 5.2.0
Gary Lasker (gary-lasker) wrote :

Hello Bilal and Mikkel! Indeed, we are ready to merge lp:~gary-lasker/software-center/launcher-integration-lp761851 and plan to release this at the same time that 5.2.0 goes out. We'll do our best to stay coordinated on it. Mikkel and didrocks are both aware that we want to release these as close to the same time as possible, so we should be in good shape. We'll be paying attention on Thursday! :)

I want to say thanks again Bilal for your great work on this!! I can't wait to see this feature finally in action in the world (and I look forward to the last pieces of functionality that you are working on). It's gonna be very cool.

Didier Roche (didrocks) on 2012-02-01
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.8

---------------
software-center (5.1.8) precise; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/update.py:
    - trivial fix to skip unreadable app-install-data files
  * lp:~mvo/software-center/device-profiles:
    - implement the hardware-requirements display in
      the detailsview
  * lp:~mvo/software-center/arb-partner-channels:
    - add support for extras.ubuntu.com and archive.canonical.com
      channel detection and adding via software-center-agent
  * data/software-center.menu.in:
    - do not show "X-Publishing" in education because the
      software-center-agent will send "X-Publishing;Education" for
      compatibility with the old clients
  * lp:~mvo/software-center/fix-cachedir-for-public-api:
    - add missing cachedir argument
  * lp:~mvo/software-center/region-support:
    - add support for a region tag and display a warning to
      the user if an application is not suitable for their
      region

  [ Brendan Donegan ]
  * lp:~brendan-donegan/software-center/test_utils_get_nice_date_string:
    - add a test function in test_utils.py which covers all of
      get_nice_date_string

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/launcher-integration-lp761851:
    - update to the Unity launcher integration implementation to
      support the revamped functionality on the Unity side (LP: #761851)
  * lp:~gary-lasker/software-center/recommends-ui-lobby:
    - initial recommends UI implementation, limited to non-personalized
      recommends currently
  * lp:~gary-lasker/software-center/appdetailsview-button-focus-fix:
    - make sure the action button in the applications details view
      always gets the initial focus (LP: #925613)
 -- Michael Vogt <email address hidden> Fri, 03 Feb 2012 18:34:43 +0100

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
Changed in unity-2d (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
Changed in unity-2d:
assignee: Florian Boucault (fboucault) → Gerry Boland (gerboland)
milestone: none → 5.4
Gerry Boland (gerboland) on 2012-02-14
Changed in unity-2d:
milestone: 5.4 → 5.6
Changed in unity-2d:
importance: Undecided → Medium
Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
Bilal Akhtar (bilalakhtar) wrote :

Recent Unity changes broke SC integration with the launcher, so I've fixed it in the linked branch.

Changed in unity:
status: Fix Released → In Progress
Changed in unity (Ubuntu):
status: Fix Released → In Progress
Omer Akram (om26er) on 2012-02-21
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: 5.2.0 → 5.6.0
Omer Akram (om26er) wrote :

okay, this issue was fixed in the past now we just have a regression that is being tracked in bug 932280

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Released
milestone: 5.6.0 → none
Bilal Akhtar (bilalakhtar) wrote :

The regression is being tracked in bug #932280. Meanwhile, I've completed second phase too, so everything specified in the spec is complete now. Second phase merge request: https://code.launchpad.net/~bilalakhtar/unity/sc-integration-phase2/+merge/95795

Didier Roche (didrocks) on 2012-03-05
Changed in unity-2d:
milestone: 5.6 → 5.8
Gerry Boland (gerboland) on 2012-03-18
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → nobody
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
milestone: 5.10.0 → 5.12
Gerry Boland (gerboland) on 2012-04-12
tags: added: delta-with-3d
Changed in unity-2d:
milestone: 5.12 → none
Albert Astals Cid (aacid) wrote :

I've marked the fixes as released for Unity-2d since trying with Unity-2d 5.8 the behaviour of adding the program tile to the launcher on install is already there (It has a bug in which the icon wrongly has a ? instead of the real icon) but the main functionality is there

Changed in unity-2d:
status: Confirmed → Fix Released
Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers