Private PPA sources that are added for purchased items should not be displayed

Bug #748459 reported by Jack Zhang on 2011-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker
Natty
Medium
Gary Lasker

Bug Description

Binary package hint: software-center

In the Ubuntu Software Center, there's a section under "Get Software" that says Vendetta Online, how do I delete it?

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.8
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic-pae 2.6.35.11
Uname: Linux 2.6.35-28-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Apr 2 13:23:04 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Jack Zhang (cgjz123) wrote :
Gary Lasker (gary-lasker) wrote :

Hi Jack. Thanks for your report. That section represents the new repository that was added to your software sources when you purchased the (free) app Vendetta Online. This item is actually displayed there on purpose and is by design. In Software Center, any new software source that you add (PPA, purchased item) will always be displayed as its own item underneath the Get Software item.

If you would like to remove that item, you would first need to uninstall Vendetta Online, and then remove/disable the corresponding software source from your system. If that is agreeable, here are the steps to do it:

1. Open Software Center, select the Vendetta Online item and in the list select "Vendetta Online".
2. Click the "Remove" button to uninstall.
3. Once it has completed the uninstall, in Software Center choose menu item "Edit > Software Sources...".
2. In the Software Sources dialog that is displayed, choose the "Other Sources" tab
3. Locate the entry that corresponds to Vendetta Online and uncheck the checkbox to disable it.
4. Close the dialog and wait a moment while Software Center updates its database.
5. The Vendetta Online item should be removed.

I hope this helps. Please post here if you have any questions, etc. Thanks!
Gary

Changed in software-center (Ubuntu):
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

"In Software Center, any new software source that you add (PPA, purchased item) will always be displayed as its own item underneath the Get Software item."

Hm, that shouldn't be happening. PPAs are supposed to show up as individual sources, but purchased items are not. They're supposed to be aggregated under "For Purchase". <https://wiki.ubuntu.com/SoftwareCenter#channels>

Changed in software-center (Ubuntu):
status: Invalid → New
Gary Lasker (gary-lasker) wrote :

Hey mpt! Just to be clear, those actually are PPAs that are being displayed for purchased items. Each time an item is purchased, a new private PPA is added that provides access to the purchased item. We are simply displaying these as we display all PPAs, private or public.

That said, I do agree that it's likely confusing for most users to have these sources appear, and in fact now that we have many items for purchase these commercial PPAs can really litter the viewswitcher panel if folks buy more than a few items. Also, it doesn't really serve any useful purpose to show these PPAs since access to the purchased items for remove and reinstall is available via the "For Purchase" node.

I actually have a very old branch that hides these PPAs. It's a super-simple change actually. We just chose not to merge it up to this point, but I am thinking that we really should for the Natty release. I'll attach the branch.

Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
summary: - Extra Section in USC.
+ Private PPA sources that are added for purchased items should not be
+ displayed
Changed in software-center (Ubuntu):
milestone: none → ubuntu-11.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26.7

---------------
software-center (3.1.26.7) natty; urgency=low

  [ Michael Vogt ]
  * utils/submit_review.py:
    - add missing gettext call
  * softwarecenter/view/widgets/reviews.py:
    - fix i18n for strings in class data

  [ Gary Lasker ]
  * softwarecenter/backend/channel.py:
    - don't display private PPA sources for purchased
      items (LP: #748459)
 -- Michael Vogt <email address hidden> Mon, 18 Apr 2011 18:15:38 +0200

Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers