Icons not displayed for paid apps with a . in their package name

Bug #745942 reported by Brian Thomason on 2011-03-30
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Brian Thomason
Maverick
Low
Unassigned

Bug Description

Binary package hint: software-center

Icons are not displayed for the gstreamer Fluendo codecs for sale in the Software Center. MVO was kind enough to investigate and figured out it is a bug in Software Center relating to packages with a "." in their name.

TEST CASE for SRU:
1. use maverick software-center
2. launch and select the "For Purchase" item in the left nav pane
3. check the Fluendo codec packs (Fluendo Complete Playback Pack, Fluendo Windows Media Pack) in the list view and verify that each displays only the generic stock icon
4. install software-center version 3.0.9 from maverick-proposed
5. clear (or move aside if you prefer) your local software-center cache by typing the following into a terminal:
    cd ~/.cache
    rm -r software-center
6. reopen software-center
7. verify that the Fluendo codec packs now have non-generic icons

Changed in software-center (Ubuntu):
assignee: nobody → Brian Thomason (brian-thomason)
status: New → Confirmed
Robert Roth (evfool) wrote :

In bug #761838 you commented that MVO has fixed this problem. Should this bug then be set to Fix committed or Fix Released? I see the icons for all for-purchase apps in my Software Center install from Natty.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Brian Thomason (brian-thomason) wrote :

Hi Robert,

This is fixed in Natty, but I still need to SRU it for Maverick. (I appreciate the indirect reminder!) Could you mark it as such. (I don't have the powers)

Thanks!

Robert Roth (evfool) wrote :

I don't have the right to do that neither, so we'll have to wait until a software-center maintainer opens a distro task for maverick. I'll leave this as Incomplete for now, because marking it as fix released would hide it by default from searches, and I guess that wouldn't be the best thing to do until the maverick distro-task is not opened.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu Maverick):
assignee: nobody → Robert Roth (evfool)
status: New → In Progress
Robert Roth (evfool) on 2011-06-06
Changed in software-center (Ubuntu Maverick):
assignee: Robert Roth (evfool) → nobody
status: In Progress → Confirmed
Changed in software-center (Ubuntu):
status: Incomplete → Fix Released
Brian Thomason (brian-thomason) wrote :

Thanks!

Michael Vogt (mvo) on 2011-06-16
Changed in software-center (Ubuntu Maverick):
status: Confirmed → In Progress
importance: Undecided → Low
Michael Vogt (mvo) on 2011-06-16
description: updated

Accepted software-center into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified this fix in software-center version 3.0.9 in maverick-proposed per the stated test procedure, and the icons now appear correctly. Thanks!

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.0.9

---------------
software-center (3.0.9) maverick-proposed; urgency=low

  [ Gary Lasker ]
  * softwarecenter/db/update.py,
    test/test_appview.py,
    test/test_database.py:
    - track cataloged_time for items not in axi (e.g. for-purchase apps)
      so that they will show up in What's New, add/modify unit tests
      per the changes (LP: #684077)
    - fix icon display that have a "." in it (LP: #745942)
  * softwarecenter/db/update.py,
    softwarecenter/view/appdetailsview_gtk.py,
    test/test_downloader.py:
    - fix screenshot issues for apps for purchase and update unit
      test (LP: #791932)

  [ Olivier Tilloy ]
  * softwarecenter/apt/apthistory.py:
    - fix startup crash if the history file is corrupted (LP: #725186)
 -- Gary Lasker <email address hidden> Wed, 15 Jun 2011 22:35:43 -0400

Changed in software-center (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers