a11y: Some menu items like "Deauthorize" and "Cancel" are without accelerators

Bug #744655 reported by Lucian Adrian Grijincu on 2011-03-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
software-center (Ubuntu)
Medium
Andrew Hayzen

Bug Description

Binary package hint: software-center

See comments #4 and #5, low-hanging fruits for cleanup in the menu for anyone interessted in some s-c work.

Related branches

tags: added: bitesize
tags: added: a11y
Alex Eftimie (alexeftimie) wrote :

Attached a patch fixing this strings.

Patch looks good, but the ellipsis looks broken (is it from http://launchpadlibrarian.net/?)

- <property name="label" translatable="yes">Reinstall Previous Purchases…</property>
+ <property name="label" translatable="yes">_Reinstall Previous Purchases…</property>

- <property name="label" translatable="yes">Deauthorize Computer…</property>
+ <property name="label" translatable="yes">_Deauthorize Computer…</property>

Do the
 - self.button_apply = gtk.Button(_("Apply Changes"))
+ self.button_apply = gtk.Button(_("_Apply Changes"))

- self.button_cancel = gtk.Button(_("Cancel"))
+ self.button_cancel = gtk.Button(_("_Cancel"))

buttons have set_use_underline() already set?

tags: added: patch
Alex Eftimie (alexeftimie) wrote :

@Lucian: for me (chromium, and local), the ellipsis look ok in the patch.

I have tested it before submiting and buttons show the underline, without requiring set_use_underline().

Changed in software-center (Ubuntu):
assignee: nobody → Bjørn Erik Bismo (bismo)
Matthew Paul Thomas (mpt) wrote :

Whether the ellipses look broken depends on whether you are viewing the patch using UTF-8 encoding. This confusion could be avoided by using the character reference "&#8230;" instead (at the expense of possibly confusing translators).

What is the string "Get _private launchpad repositories" for? It isn't mentioned in the specification anywhere. If it's a menu item or a button label, it is incorrectly capitalized.

<https://wiki.ubuntu.com/SoftwareCenter#Menus> shows that the access key for "Reinstall Purchases…" should be "P", not "R", because "R" is for "Remove".

Please drop the changes to the other files (__init__.py, appdetailsview_gtk.py, and deauthorize_dialog.py). The default button in a dialog should be activated by the Enter key, and any Cancel button by the Esc key. They should not have other keys as well, because that slows people down.

Michael Vogt (mvo) on 2012-05-25
summary: - a11y: "Deauthorize" and "Cancel" without accelerators
+ a11y: Some menu items like "Deauthorize" and "Cancel" without
+ accelerators
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: Bjørn Erik Bismo (bismo) → nobody

Hey Bjørn, I removed you from the assignee for now. But you are free to reassign it to yourself if you intend to work on this issue :)

It looks like there are some more inconsistencies for the accelerators with the spec, this should be addressed for 12.10 but it looks rather straightforward.

summary: - a11y: Some menu items like "Deauthorize" and "Cancel" without
+ a11y: Some menu items like "Deauthorize" and "Cancel" are without
accelerators
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.10
description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
milestone: none → quantal-8-administration
Michael Vogt (mvo) wrote :

Adding the ca-escalted tag as this is targeted for 12.10 and has not seen any action so it needs to be evaluated on the next ca-escalated bug review.

tags: added: ca-escalated
Michael Vogt (mvo) wrote :

Closing the upstream task but keeping the ubuntu task

Changed in software-center:
status: New → Invalid
Andrew Hayzen (ahayzen) on 2012-09-25
Changed in software-center (Ubuntu):
assignee: nobody → Andrew Hayzen (andrew-hayzen)
Andrew Hayzen (ahayzen) wrote :

Hi

I have submitted a branch which I think resolves the issues stated here. This is my first branch on a project that isn't my own, so have I done everything correct? Should I propose for merging etc? Have I actually resolved all of the issues stated here?

Many thanks,

Andy

Changed in software-center (Ubuntu):
status: Triaged → In Progress
Michael Vogt (mvo) on 2012-10-02
Changed in hundredpapercuts:
status: New → In Progress
no longer affects: software-center
Changed in hundredpapercuts:
importance: Undecided → Medium
Michael Vogt (mvo) on 2012-10-19
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Michael Vogt (mvo) on 2012-10-19
Changed in hundredpapercuts:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.5.0

---------------
software-center (5.5.0) raring; urgency=low

  [ Andrew Hayzen ]
  * lp:~andrew-hayzen/software-center/accelerator-fix-lp744655:
    - fixes missing accelerator for a11y (LP: #744655)

software-center (5.4.1.3) UNRELEASED; urgency=low

  * lp:~mvo/software-center/fix-for-unusual-deb-lp1067634:
    - fix crash in deb packages without a description (LP: #1067634)
  * lp:~mvo/software-center/lp1009967:
    - fix the "top rated" display to match the spec by also showing
      the already installed items (LP: #1009967)
  * lp:~mvo/software-center/recoverable-errors-lp1051829:
    - send a custom duplicate signature so that the recoverable errors
      on transaction failures are broken down by error_code instead
      of all put into the same bucket (LP: #1051829)
 -- Michael Vogt <email address hidden> Mon, 05 Nov 2012 13:56:26 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
milestone: quantal-8-administration → raring-round-4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers