[assistive technology] software-center: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.

Bug #743020 reported by Kiwinote on 2011-03-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: software-center

When loading details views, I quite frequently get the message "software-center: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.". Once this has happened twice/thrice software-center quits/crashes.

To reproduce this issue, I browse to eg the accessories category, double click on the first item, click on 'accessories' in the pathbar, double click on the second item, etc.

It may or may not be a coincidence, but I have never been able to reproduce this issue whilst using our ReviewLoaderJsonAsync (ie run SOFTWARE_CENTER_GIO_REVIEWS=. PYTHONPATH=. ./software-center --this mode only works in trunk right atm). I have only ever been able to reproduce this whilst using our default ReviewLoaderThreadedRNRClient.

I have no idea whether this is a s-c issue, an x issue or whatever.

Kiwinote (kiwinote) on 2011-03-26
Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Chris Halse Rogers (raof) wrote :

Hm, odd. That error message probably means that software-centre's X connection has been closed - it's trying to write to a socket that no longer works.

That's not a common failure mode for X applications. I can't seem to reproduce it, but failing anything else, running software-centre under “xtrace” would print all the X protocol traffic that's occurring and the point at which it starts to fail.

Kiwinote (kiwinote) wrote :

Hi Chris! This is what may seem to be the relevant part of the xtrace output. If you need anything further back, just let me know and I'll attach a more complete log.

<lots of stuff>
000:>:4605: Event MotionNotify(6) detail=Normal(0x00) time=0x006d6670 root=0x0000014e event=0x0840008a child=None(0x00000000) root-x=814 root-y=268 event-x=412 event-y=150 state=0 same-screen=true(0x01)
001:<:0009: 24: Request(20): GetProperty delete=false(0x00) window=0x0000014e property=0x1d7("AT_SPI_IOR") type=0x1f("STRING") long-offset=0x00000000 long-length=0x00002000
000:>:4605: Event MotionNotify(6) detail=Normal(0x00) time=0x006d6678 root=0x0000014e event=0x0840008a child=None(0x00000000) root-x=814 root-y=267 event-x=412 event-y=149 state=0 same-screen=true(0x01)
001:>:0009:644: Reply to GetProperty: type=0x1f("STRING") bytes-after=0x00000000 data='IOR:010000001f00000049444c3a4163636573736962696c6974792f52656769737472793a312e300000030000000054424f500000000101020005000000554e4958000000000a0000006c6f63616c686f7374000000280000002f746d702f6f726269742d7067672f6c696e632d3835632d302d326637643730646434386463310000000000caaedfba5400000001010200280000002f746d702f6f726269742d7067672f6c696e632d3835632d302d3266376437306464343864633100000000001c000000000000004aeea4304440e8a8c02b2828282828280800000002c65c6801000000480000000100000002000000050000001c000000000000004aeea4304440e8a8c02b2828282828280800000002c65c6801000000140000000100000001000105000000000901010000000000'
001:<:000a: 24: Request(20): GetProperty delete=false(0x00) window=0x0000014e property=0x1d7("AT_SPI_IOR") type=0x1f("STRING") long-offset=0x00000000 long-length=0x00002000
001:>:000a:644: Reply to GetProperty: type=0x1f("STRING") bytes-after=0x00000000 data='IOR:010000001f00000049444c3a4163636573736962696c6974792f52656769737472793a312e300000030000000054424f500000000101020005000000554e4958000000000a0000006c6f63616c686f7374000000280000002f746d702f6f726269742d7067672f6c696e632d3835632d302d326637643730646434386463310000000000caaedfba5400000001010200280000002f746d702f6f726269742d7067672f6c696e632d3835632d302d3266376437306464343864633100000000001c000000000000004aeea4304440e8a8c02b2828282828280800000002c65c6801000000480000000100000002000000050000001c000000000000004aeea4304440e8a8c02b2828282828280800000002c65c6801000000140000000100000001000105000000000901010000000000'
software-center: Fatal IO error 11 (Resource temporarily unavailable) on X server :9.
000:>:4605: Event MotionNotify(6) detail=Normal(0x00) time=0x006d6680 root=0x0000014e event=0x0840008a child=None(0x00000000) root-x=814 root-y=266 event-x=412 event-y=148 state=0 same-screen=true(0x01)
<few more motion_notify events>

Kiwinote (kiwinote) on 2011-03-31
description: updated
Chris Halse Rogers (raof) wrote :

No, there's nothing obvious there. Perhaps the full log will be more useful.

Kiwinote (kiwinote) wrote :
Michael Vogt (mvo) wrote :

I wonder if its a sideeffect of us using the multirpcoessing module. Maybe (sometimes) its reading from the xorg socket and confuses the read gtk parent.

Michael Vogt (mvo) wrote :

Do you have "assistive technology" enabled in your system? I seem to only be able to trigger this problem when its enabled.

Michael Terry (mterry) wrote :

I do (and have hit this bug a few times).

Michael Vogt (mvo) on 2011-04-06
summary: - software-center: Fatal IO error 11 (Resource temporarily unavailable) on
- X server :0.
+ [assistive technology] software-center: Fatal IO error 11 (Resource
+ temporarily unavailable) on X server :0.
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26.1

---------------
software-center (3.1.26.1) natty; urgency=low

  [ Matthew McGowan ]
  * softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/widgets/reviews.py:
    - tweak color of review stars in details view and the
      review dialog to match listview color (LP: #753620)

  [ Gary Lasker ]
  * softwarecenter/view/basepane.py:
    - fix crash if the edit menu is activated while viewing
      the pending view or the history pane (LP: #754153)

  [ Michael Vogt ]
  * softwarecenter/apt/apthistory.py:
    - fix showing newly installed apps in the history (thanks to
      Geliy Sokolov) LP: #612183)
  * softwarecenter/db/reviews.py:
    - use a joinable queue in the multiprocessing code and ensure
      task_done/join is used (LP: #743020)
 -- Michael Vogt <email address hidden> Fri, 08 Apr 2011 13:13:49 +0200

Changed in software-center (Ubuntu):
status: Incomplete → Fix Released
Michael Vogt (mvo) on 2011-04-11
Changed in software-center (Ubuntu):
status: Fix Released → In Progress
Michael Vogt (mvo) wrote :

This is actually not yet fixed, it looks like the issue is httplib2 and multiprocessing do not play well (for some reason). When remvoing all the code that actually talks to the API and just doing a httplib2.Http().request(uri) call in the multiprocessing code I get similar crashes.

Michael Vogt (mvo) wrote :

A new version that moves from multiprocessing to a glib.spawn_async() approach with a helper instead of the old multiprocesing code is now uploaded.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26.2

---------------
software-center (3.1.26.2) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/update.py:
    - do not crash if /var/lib/apt-xapian-index/cataloged_times.p can
      not be read (LP: #636049)
  * merged lp:~mvo/software-center/get-reviews-subprocess (LP: #743020):
    - don't use multiprocessing anymore, instead glib.spawn_async()
      a helper app, this finally fixes the crashes with accessibility
      turned on (LP: #743020)
    - update rnrclient_pristine.py to the latest upstream version
      that supports origin and distroseries as arguments
    - add support for getting all the origins of the DB, this is
      needed for the new rnrclient_pristine.py functionatlity
    - ship get_reviews_helper.py, get_review_stats_helper.py for
      the glib.spawn_async() change
    - this also makes the reviews fully work in the guest session again

  [ Gary Lasker ]
  * softwarecenter/db/reviews.py:
    - update review loader to check for JoinableQueue rather than
      Queue so that we re-enable the ReviewLoaderThreadedRNRClient
      (LP: #754639)
  * utils/submit_review.py:
    - remove two strings marked for translation that are never
      actually shown in the ui, also add translators note for
      combobox entries (LP: #750421)
  * refresh .pot file

  [ Aaron Peachey ]
  * softwarecenter/view/widgets/reviews.py:
    - advise user that app needs to be installed in order to review,
      even if reviews exist (LP: #754879)
 -- Michael Vogt <email address hidden> Mon, 11 Apr 2011 23:02:12 +0200

Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments