software-center crashed with AttributeError in get_review_stats(): 'NoneType' object has no attribute 'pkgname'

Bug #742635 reported by Data on 2011-03-25
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

Software-center just crashed while I was using another program (nautilus).
This is on latest Natty daily live session (unity)

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.24.2
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Fri Mar 25 18:10:11 2011
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110325)
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in get_review_stats(): 'NoneType' object has no attribute 'pkgname'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Data (ubuntuaddress) wrote :
Data (ubuntuaddress) on 2011-03-25
visibility: private → public
Jon (shakataganai) wrote :

I had this same crash. In my case it was on a fresh reboot. I logged in, didn't touch the machine... crash screen pop'd up. I had the software-center open before reboot, so I'm not sure if it was trying to relaunch it automagically or something.

Eric Stanley (eastky33) wrote :

That is what happened with me, I was letting the update run while i was asleep, when I came back the next morning I typed my password in and there it was....

Fabio Marconi (fabiomarconi) wrote :

For me it crash because i restarted the router

Changed in software-center (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Gary Lasker (gary-lasker) wrote :

Looks like this can happen on network state change events. I have a fix in the attached branch.

Thanks for the report!

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.24.3

---------------
software-center (3.1.24.3) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/appdetailsview_gtk.py:
    - fix crash that can happen on a network state change
      event (LP: #742635)

  [ Michael Vogt ]
  * softwarecenter/view/widgets/weblivedialog.py:
    - merged lp:~weblive-dev/software-center/weblive-loadbalancing-fix
      bugfix to fix server selection bug, thanks to Stephane Graber
  * tests/Makefile:
    - fix in clean target to remove some test leftover data
 -- Michael Vogt <email address hidden> Mon, 28 Mar 2011 09:34:41 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers