Reviews functionality broken behind a proxy

Bug #742564 reported by Alan Pope 🍺🐧🐱 🦄 on 2011-03-25
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
piston-mini-client (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
software-center (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Binary package hint: software-center

Open USC, search for tomboy, docky, 7zip or any other application that has reviews.
Click on any one of those results.
Observe screenshot, details about application, but reviews are absent.

"Checking for reviews"

Sits there for a while. Then changes to "Got an opinion?" and offers me the erroneous chance to be the first to review the app.

If I attempt to leave a review, then I get the chance to login with single sign on. However once entering my credentials I get left with "One moment please" and "Signing in" which never completes.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.24.2
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Fri Mar 25 15:45:57 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to natty on 2011-02-22 (31 days ago)

Related branches

summary: - reviews not visible behind a proxy
+ Reviews functionality broken behind a proxy
Rémi Rérolle (remi.rerolle) wrote :

I confirm the exact same behaviour.

Sadly this is one of the many Ubuntu features which are broken behind a proxy.

Petr Hlozek (ok2cqr) wrote :

I must confirm this problem. Software center itself works fine but never show reviews behind proxy.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

It turns out that this is a limitation of piston-mini-client that is used for the ratings&reviews feature.

Changed in software-center (Ubuntu):
importance: Undecided → High
Changed in piston-mini-client (Ubuntu Oneiric):
status: New → In Progress
importance: Undecided → High
Michael Vogt (mvo) wrote :

This will also need a new dependency to piston-mini-client (python-socksipy).

Michael Vogt (mvo) wrote :

No need for python-socksipy, the required socks.py module is part of the httplib2 upstream release.

Changed in software-center (Ubuntu Oneiric):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.7

---------------
software-center (4.1.23.7) oneiric; urgency=low

  [ Gary Lasker ]
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - fix UnicodeDecodeError in _show_transaction_failed_dialog
      (LP: #858193)
  * softwarecenter/backend/installbackend.py,
    softwarecenter/ui/gtk3/aptd_gtk3.py,
    softwarecenter/ui/gtk3/dialogs/__init__.py:
    - implement the error() method of InstallBackendUI to display the
      required error dialog in the event of a transaction error
      (LP: #860137)
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - add unicode handling for the transaction error dialog
  * softwarecenter/utils.py:
    - let the utf8() method handle None as an input value
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix UnicodeDecodeError in set_value() (LP: #846600)
  * softwarecenter/db/debfile.py:
    - fix UnicodeDecodeError in warning() (LP: #845298)
  * softwarecenter/ui/gtk3/app.py:
    - fix intermittent crash at shutdown (LP: #728973)
  * softwarecenter/ui/gtk3/panes/availablepane.py,
    softwarecenter/ui/gtk3/session/navhistory.py,
    softwarecenter/ui/gtk3/session/viewmanager.py:
    - navigate back to the application details view on
      a purchase cancellation or a purchase error (LP: #859790)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix empty installed view after clearing search (LP: #860810)
    - fix rendering glitch when searching with OneConf
      active (LP: #860818)
  * softwarecenter/utils.py:
    - fix crash in save_person_to_config() (LP: #858403)
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - fix UnicodeDecodeError in _whom_when_markup()

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/searchentry.py:
    - merge header fix
  * softwarecenter/ui/gtk3/app.py, softwarecenter/utils.py:
    - add support for proxy setup from gsettings (LP: #742564)

  [ Juhana Jauhiainen ]
  * Added For Software developers link to Help menu. (LP #722366)

  [ Didier Roche ]
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - disable search when viewing oneconfviews

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/panes/viewswitcher.py:
    - if we're in the 'in progress' view and all the transactions finish, then
      navigate back (LP: #831524)
 -- Michael Vogt <email address hidden> Wed, 28 Sep 2011 18:02:08 +0200

Changed in software-center (Ubuntu Oneiric):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package piston-mini-client - 0.5+bzr45-0ubuntu1

---------------
piston-mini-client (0.5+bzr45-0ubuntu1) oneiric; urgency=low

  * new bzr snapshot of the pending release:
    - add support for the {http,https}_proxy environment (LP: #742564)
    - improve debug output
    - improve documentation
    - tiny and backward compatible API clenaup for as_serializable
 -- Michael Vogt <email address hidden> Tue, 27 Sep 2011 17:28:59 +0200

Changed in piston-mini-client (Ubuntu Oneiric):
status: In Progress → Fix Released
Andrew (andrew-rw-robinson) wrote :

I see this is marked as fixed, but I am not seeing that the proxy is working on the current oneiric (version 5.0.2). Is this a known issue?

The images are working, and the package descriptions, but no reviews.

I'm also seeing this issue still. Versions I have of the packages mentioned above are:

software-center 5.0.2ubuntu0.1
python-piston-mini-client 0.6+bzr48-0ubuntu1

Just in case (from reading other related bugs) my proxy does NOT need authentication.

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Michael Vogt (mvo) wrote :

Hey Andrew and George,

How is your proxy configured? I.e. what is the output of the following commands:
$ gsettings get org.gnome.system.proxy.http enabled ; gsettings get org.gnome.system.proxy.http host ; gsettings get org.gnome.system.proxy.http port
and
$ echo $http_proxy

Thanks,
 Michael

Michael Vogt (mvo) on 2012-03-16
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Andrew (andrew-rw-robinson) wrote :

gsettings get org.gnome.system.proxy.http enabled ; gsettings get org.gnome.system.proxy.http host ; gsettings get org.gnome.system.proxy.http port
false
'localhost'
3128

Setting the enabled to true via the command-line worked. The question is then why is the proxy enabled set to false when the proxy settings in the control panel set, but there is no "enabled" setting in the UI?

Michael Vogt (mvo) wrote :

Hey Andrew, thanks for this additional data. It turns out that gnome has silently deprecated "enabled" without
removing it. This means that all apps that rely on this setting are broken currently :/ I updated software-center
now to look at the "host" value instead. If something is set there the proxy will be used. This will be part of
the next upload.

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.6 KiB)

This bug was fixed in the package software-center - 5.1.13

---------------
software-center (5.1.13) precise; urgency=low

  [ Anthony Lenton ]
  * lp:~elachuni/software-center/pep8-test-part5,
    lp:~elachuni/software-center/pep8-test-part6,
    lp:~elachuni/software-center/pep8-test-part7,
    lp:~elachuni/software-center/pep8-test-part8,
    lp:~elachuni/software-center/pep8-test-part9,
    lp:~elachuni/software-center/pep8-test-part10,
    lp:~elachuni/software-center/pep8-test-part11,
    lp:~elachuni/software-center/pep8-test-part12,
    lp:~elachuni/software-center/pep8-test-part13,
    lp:~elachuni/software-center/pep8-test-part14,
    lp:~elachuni/software-center/pep8-test-part15,
    lp:~elachuni/software-center/pep8-test-part16,
    lp:~elachuni/software-center/pep8-test-part17,
    lp:~elachuni/software-center/pep8-test-part18,
    lp:~elachuni/software-center/pep8-test-part19,
    lp:~elachuni/software-center/pep8-test-part20,
    lp:~elachuni/software-center/pep8-test-part21,
    lp:~elachuni/software-center/pep8-test-part22:
    - many, many, many pep8 fixes
  * lp:~elachuni/software-center/unify-ussoc-envvar:
    - fix USSOC_SERVICE_URL env variable

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug953812: (LP: #953812)
    - Translate review sorting criteria
    - Fix the Recommendation spinner text translations

  [ Michael Vogt ]
  * lp:~mvo/software-center/small-sso-fixes:
    - fix the clear_credentials() call if a token is no
      longer valid
  * lp:~mvo/software-center/lp955005:
    - don't display ratings for the case where an app
      cannot be found (LP: #955005)
  * lp:~mvo/software-center/opengl-driver-blacklist:
    - add support for video driver blacklisting
  * lp:~mvo/software-center/lp856559:
    - fix case where the search term is not always
      cleared in the search entry (LP: #856559)
  * lp:~mvo/software-center/misc-fixes:
    - when a package can not be authenticated, do not fail
      (hard) but instead offer to "repair" the situation using
      a "reload" and try the install again (LP: #876278)
    - do not crash in if os.makedirs has a race condition
      (LP: #956680)
    - fix the proxy handling with 12.04 as the "enabled" property
      is deprecated now. it will also not mess with the proxy
      environment on non-gnome systems (LP: #742564)
  * lp:~mvo/software-center/lp780812:
    - ensure that the distroseries is updated in the sources
      deb line when updating a purchased item (LP: #780812)
  * lp:~mvo/software-center/recommendations-opt-out:
    - fix double-results when opting-in and back out of of
      the recommendations service repeatedly
  * lp:~mvo/software-center/tos-dialog:
    - display a terms-of-service dialog before the first purchase
  * lp:~mvo/software-center/lp957599:
    - add a new unit test test_spawn_helper.py
  * lp:~mvo/software-center/track-db-open:
    - improve db logging

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-lp955048:
    - String fix for the "Recommended For You" panel. LP: #955048
  * lp:~gary-lasker/software-center/fix-lp856559:
    - Clears the search entry field before doing a reinstall
      previous purchases (LP: #85655...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers