ERROR - "failed to parse" when opening installed application details

Bug #739908 reported by Patrick Wright on 2011-03-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker
Natty
High
Gary Lasker

Bug Description

Binary package hint: software-center

Steps:
1. Install Test Drive
2. Go to Installed Software
3. Locate Test Drive and press enter to display the details

* An error is reported
2011-03-21 19:16:20,038 - softwarecenter.db.reviews - ERROR - failed to parse '<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://reviews.staging.ubuntu.com/reviews/api/1.0/reviews/filter/en/ubuntu/natty/any/testdrive-gtk%3bTest+Drive+an+Ubuntu+ISO/page/1/">here</a>.</p>
<hr>
<address>Apache/2.2.14 (Ubuntu) Server at reviews.staging.ubuntu.com Port 80</address>
</body></html>
'

When an automated Mago test runs, it loses it's contexts when the error is reported.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.23.3
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Mar 21 19:18:49 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to natty on 2011-03-21 (0 days ago)

Patrick Wright (patrickmwright) wrote :
description: updated
Changed in software-center (Ubuntu Natty):
importance: Undecided → High
summary: - ERROR - failed to parse when opening installed application details
+ ERROR - "failed to parse" when opening installed application details
Martin Pitt (pitti) on 2011-03-25
Changed in software-center (Ubuntu Natty):
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

This was an issue with the staging server for ratings and reviews that we had been using with Software Center. The problem is fixed in Software Center version 3.1.24.4, where we updated to point to the production server:

software-center (3.1.24.4) natty; urgency=low

  * merged some small fixes for the backend server of weblive
    from lp:~weblive-dev/software-center/weblive-backend-fixes,
    thanks to Stephane Graber
  * softwarecenter/db/update.py:
    - if no icon_data is transmited from software-center-agent, just use
      the stock item
  * softwarecenter/distro/Ubuntu.py:
    - point to the ratings&reviews production server

 -- Michael Vogt <email address hidden> Wed, 30 Mar 2011 13:59:13 +0200

Changed in software-center (Ubuntu Natty):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers