Feature Freeze Exception for weblive support in software-center

Bug #736227 reported by Stéphane Graber on 2011-03-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: software-center

Current software-center supports a "Test drive" mode using WebLive when:
 - qtnx is installed
 - "--with-weblive" is passed to the sofware-center command

As Edubuntu has been pushing WebLive almost since Ubuntu 10.10 released, we'd like to have that weblive integration by default in Edubuntu.
For this reason, we already ship "qtnx" by default on Edubuntu's DVD, we now just need to drop the "--with-weblive" requirement.

So this Feature Freeze exception would be to update the software-center to only check if "qtnx" is installed and turn on the weblive feature if it's the case.

This will make the WebLive integration turned on by default for Edubuntu 11.04 and won't affect any of the other flavors as only Edubuntu is shipped "qtnx" by default (qtnx is in universe).

This will also allow regular Ubuntu users to use that same feature by simply installed "qtnx" from universe on their 11.04 system.

Jonathan Carter (jonathan) wrote :

This would indeed be great for inclusion in Edubuntu 11.04, please consider a FFe for this.

Is there a patch available and what testing have you done to ensure this doesn't cause regression in other flavors?

Stéphane Graber (stgraber) wrote :

You can easily test the behavior in all derivatives by:
1) Ensuring you don't have qtnx installed
2) Starting the current software-center with: --with-weblive

The current code requires both "--with-weblive" and "qtnx" to be installed, we want to remove the first requirement and just need "qtnx" to be installed.

Scott Kitterman (kitterman) wrote :

Should qtnx be blacklisted on the other seeds to make sure this doesn't happen?

Stéphane Graber (stgraber) wrote :

If you REALLY want to make sure it'll never get in Kubuntu/Xubuntu (it's in universe so it can't be included on an Ubuntu CD), you can but it's really not necessary as software-center doesn't depend/recommend/suggest it.

It's just a feature that'd appear if the package happens to be installed but not something that'll happen in any case by default outside of Edubuntu where we explicitly seed "qtnx" so we have the feature.

OK. Probably overkill. (Kubuntu is build from Main, so it's not an issue
there either).

Is there a patch?

Scott K

Stéphane Graber (stgraber) wrote :

Attached is the change I'd suggest to mvo for merging in the software-center branch.

It removes the --with-weblive option and the associated environment variable and update the check to only look for qtnx.

Stéphane Graber (stgraber) wrote :
Stéphane Graber (stgraber) wrote :

Copy/Paste of IRC discussion with mvo regarding the weblive change:

17:19 <stgraber> yeah ;) Turn on weblive for Edubuntu by default (only check for qtnx and not require --with-weblive) and try to get a spinner or something that gives some
                 feedback to the user
17:22 <stgraber> not sure if you prefer it to check for Edubuntu + qtnx, or if it's fine enabling it for anyone who has qtnx installed (and just drop --with-weblive then) ?
17:27 <mvo> hm, I'm sitting on the fence on this one
17:27 * mvo scratches head
17:32 <stgraber> well, except Edubuntu users, it's pretty unlikely that anyone would have qtnx installed ;)
17:33 <mvo> yeah exactly
17:33 <mvo> not sure I need to get this past feature freeze
17:34 <stgraber> I'm fine doing some weird checks to see if that's Edubuntu, but when users notice that we have the feature in Edubuntu, they might want to get it on their Ubuntu system without installing some edubuntu package ;)
17:36 <stgraber> I can probably get a feature freeze exception to remove the --with-weblive and turn weblive on only if qtnx is installed if that'd help
17:37 <mvo> if you could do the paperwork, that would rock
17:37 <mvo> just asking skate might be enough :)
17:37 <mvo> if she is fine, then I'm all for it

Scott Kitterman (kitterman) wrote :

Ack. Approved. Please go ahead and get this in before Beta 1.

Changed in software-center (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.24

---------------
software-center (3.1.24) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/thumbnail.py:
    - add missing logger definition to fix name error on
      a thumbnail download error
  * softwarecenter/utils.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/softwarepane.py:
    - update Unity launcher integration implementation per
      revised approach (see LP: #670403)
  * test/test_unity_launcher_integration.py,
    test/data/<many>:
    - update unit tests per the revised approach

  [ Michael Vogt ]
  * merged lp:~mmcg069/software-center/rtl-work, many thanks
    to Matthew McGowan
  * merged lp:~mmcg069/software-center/desc-tweaks
  * merged lp:~weblive-dev/software-center/weblive-by-default, thanks
    to Stephane Graber (LP: #736227)
  * softwarecenter/view/widgets/thumbnail.py:
    - fix show/hide issue in download_and_display()
  * softwarecenter/db/reviews.py, softwarecenter/models/appstore.py:
    - deal with empty appname in the review-stats to follow the
      latest server changes
  * merged lp:~mmcg069/software-center/reviews-msg-tweaks, many thanks
    to to Matthew McGowan
  * show launcher like location for commandline only apps, thanks
    to Matthew McGowan
  * when scanning for commandline binaries take alterantives into
    account as well

  [ Kiwinote ]
  * data/new.menu.in,
    softwarecenter/view/appview.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/catview_gtk.py:
    - only display available items in what's new (LP: #739276)
    - don't display installed items in what's new (LP: #627114)
  * softwarecenter/db/database.py:
    - don't crash when we have no axi values (LP: #737870)
  * softwarecenter/gwibber_helper.py:
    - don't crash on startup due to anything sqlite related (LP: #737220)
  * softwarecenter/log.py:
    - don't crash on startup when logfile is not writeable (LP: #688682)
  * softwarecenter/view/appdetailsview_gtk.py:
    - correctly update statusbar after cancelling a dependency dialog
  * softwarecenter/view/catview_gtk:
    - don't crash when we have no what's new carousel (LP: #736046)
  * softwarecenter/view/softwarepane.py:
    - connect 'transaction-stopped' to on_transaction_stopped rather than o_t_f
  * softwarecenter/view/widgets/reviews.py:
    - fallback to package_name if review_data contains no app_name
 -- Michael Vogt <email address hidden> Tue, 22 Mar 2011 16:03:58 +0100

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers