software-center crashed with RuntimeError in on_window_main_delete_event(): called outside of a mainloop

Bug #728973 reported by emperor on 2011-03-04
270
This bug affects 55 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Binary package hint: software-center

Crashed when starting it an quickly closing it again

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.21
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Fri Mar 4 11:25:14 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with RuntimeError in on_window_main_delete_event(): called outside of a mainloop
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/app.py", line 453, in on_window_main_delete_event
     gtk.main_quit()
 RuntimeError: called outside of a mainloop
UpgradeStatus: Upgraded to natty on 2011-02-22 (9 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

emperor (emperor2000) wrote :
tags: removed: need-duplicate-check
visibility: private → public

Happened to me to, exactly the same: start software center, and while it's still loading some stuff, close it.

Changed in software-center (Ubuntu):
status: New → Confirmed
sp1d3r (miguelomonroyb) wrote :

It affects me too, exactly the same: start software center, and while it's still loading some stuff, I close it.

Shahar Or (mightyiam) wrote :

This happened when I opened a .deb file from within archive manager.

bonimba (altrobonimba) wrote :

Same description as #2 and #3.

JrZabott (jrzabott) wrote :

It hapṕened after i upgrade the 11.04 to 11.10, i'm experiencing a lot of error since then.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.23.7

---------------
software-center (4.1.23.7) oneiric; urgency=low

  [ Gary Lasker ]
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - fix UnicodeDecodeError in _show_transaction_failed_dialog
      (LP: #858193)
  * softwarecenter/backend/installbackend.py,
    softwarecenter/ui/gtk3/aptd_gtk3.py,
    softwarecenter/ui/gtk3/dialogs/__init__.py:
    - implement the error() method of InstallBackendUI to display the
      required error dialog in the event of a transaction error
      (LP: #860137)
  * softwarecenter/backend/installbackend_impl/aptd.py:
    - add unicode handling for the transaction error dialog
  * softwarecenter/utils.py:
    - let the utf8() method handle None as an input value
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix UnicodeDecodeError in set_value() (LP: #846600)
  * softwarecenter/db/debfile.py:
    - fix UnicodeDecodeError in warning() (LP: #845298)
  * softwarecenter/ui/gtk3/app.py:
    - fix intermittent crash at shutdown (LP: #728973)
  * softwarecenter/ui/gtk3/panes/availablepane.py,
    softwarecenter/ui/gtk3/session/navhistory.py,
    softwarecenter/ui/gtk3/session/viewmanager.py:
    - navigate back to the application details view on
      a purchase cancellation or a purchase error (LP: #859790)
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - fix empty installed view after clearing search (LP: #860810)
    - fix rendering glitch when searching with OneConf
      active (LP: #860818)
  * softwarecenter/utils.py:
    - fix crash in save_person_to_config() (LP: #858403)
  * softwarecenter/ui/gtk3/widgets/reviews.py:
    - fix UnicodeDecodeError in _whom_when_markup()

  [ Michael Vogt ]
  * softwarecenter/ui/gtk3/widgets/searchentry.py:
    - merge header fix
  * softwarecenter/ui/gtk3/app.py, softwarecenter/utils.py:
    - add support for proxy setup from gsettings (LP: #742564)

  [ Juhana Jauhiainen ]
  * Added For Software developers link to Help menu. (LP #722366)

  [ Didier Roche ]
  * softwarecenter/ui/gtk3/panes/installedpane.py:
    - disable search when viewing oneconfviews

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/panes/viewswitcher.py:
    - if we're in the 'in progress' view and all the transactions finish, then
      navigate back (LP: #831524)
 -- Michael Vogt <email address hidden> Wed, 28 Sep 2011 18:02:08 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Steffen Röcker (sroecker) wrote :

Not fixed in natty software-center 4.0.5.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers