software-center crashed with GError in _get_icon(): Failed to load icon

Bug #719662 reported by Paul White on 2011-02-15
106
This bug affects 16 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Binary package hint: software-center

Just installed 3.1.18 and software-center crashed shortly after starting - crash dialog and offer to report problem. The message said that software-center had closed unexpectedly but it was still open and usable.

After several log outs and log ins the problem now seems to only happen when I click on the recommendations link on the front screen. Reporting this as a new bug and not adding to #716111 as requested by Gary Lasker.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.18
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
Date: Tue Feb 15 22:15:53 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110212)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with GError in _get_icon(): Failed to load icon
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Paul White (paulw2u) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

Thanks Paul, this is indeed a different crash and the new report is very helpful. I'm preparing a fix now.

Gary Lasker (gary-lasker) wrote :

Ok, this one is fixed and the fix should will be available in the next dev release of software-center. Thanks again!

Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Gary Lasker (gary-lasker) wrote :

Seems like bug 719861 might be the root cause of our recent icon issues with software-center. If anyone who is currently experiencing this bug could please answer these two questions it should verify that this is indeed the root cause:

  1. Are you running a fresh install of Natty? (seems so, looking at apport info from dupes here and from bug 716111, seems like daily builds since 20110209 have the problem).
  2. If you running the following command in a terminal, then restart, does the problem disappear?:

       sudo apt-get install libgdk-pixbuf2.0-0 --reinstall

Please let us know your result if you are able to try this. And thanks!

Meanwhile, the next dev version of software-center should be out soon and will prevent this crash. The good news is that software-center will be much more robust from this point on for the case where icons cannot be found. Certainly, it should never crash in this case.

Thanks again all!

Gary Lasker (gary-lasker) wrote :

Looks like bug 719861 (see my comment 4) is now fix-released. Cool!

RonParent (ronap) wrote :

I immediately checked for more updates after submitting this bug report. All those updates installed without problem - the problem appears to be fixed!

Gary Lasker (gary-lasker) wrote :

Thanks Ron! Sounds like we are in good shape now. If anyone is still having problems, please drop a note here. Thanks!

RonParent (ronap) wrote :

Well, back again. Problem still as described by original poster. Ubuntu Software Center now opens fine but crash reports showed when I clicked on Internet. Software center doesn't crash but there is no display of Internet icons. Icons do appear in response to search. Otherwise stable.

Gary Lasker (gary-lasker) wrote :

Hi Ron, could you please type the following into a terminal and then restart your computer, and let us know if it fixes the crashes when you go to the Internet section?

  sudo apt-get install libgdk-pixbuf2.0-0 --reinstall

Thanks for your help!

RonParent (ronap) wrote :

No crashes - everything looks good now. Thanks

Gary Lasker (gary-lasker) wrote :

Hi Ron, thanks for reporting back. Your test verifies that bug 719861 is indeed the root cause of the icon problems we've seen reported in Software Center lately. The fixes released for Software Center will prevent these problems if a similar issue appears in the future.

Thank you again for your help!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.19

---------------
software-center (3.1.19) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/enums.py,
    softwarecenter/utils.py,
    softwarecenter/backend/channel.py,
    softwarecenter/models/viewswitcherlist.py,
    softwarecenter/view/pendingview.py:
    - another icon crash fix (LP: #719662)
  * softwarecenter/backend/aptd.py,
    softwarecenter/models/appstore.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py,
    softwarecenter/enums.py:
    - include additional details about the transaction when
      firing a transaction-started signal, wire to handlers
  * softwarecenter/view/widgets/actionbar.py:
    - tweak spacings for action bar
  * softwarecenter/db/application.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/channelpane.py,
    softwarecenter/view/installedpane.py,
    softwarecenter/view/softwarepane.py,
    softwarecenter/enums.py:
    - implement the software-center side of unity launcher
      integration per the specification (LP: #670403)
    - temporarily hide the launcher integration feature pending
      implementation on the Unity side
  * test/test_downloader.py:
    - update unit test for SimpleFileDownloader changes

  [ Aaron Peachey ]
  * utils/submit_review.py,
    softwarecenter/db/reviews.py,
    softwarecenter/view/appdetailsview_gtk.py:
    - provide user feedback when submitting review usefulness
    - handle case where usefulness submission fails
  * softwarecenter/view/appdetailsview_gtk.py:
    - display own reviews according to the spec
  * utils/submit_review.py:
    - fix bug that showed gwibber success message when gwibber
      checkbox was not selected

  [ Michael Vogt ]
  * softwarecenter/view/appdetailsview_gtk.py:
    - add transparent-bg-hint gdata theme engine hint to the
      progress bar
  * softwarecenter/db/reviews.py,
    softwarecenter/view/appdetailsview_gtk.py:
    - cleanup by unifing Review objects from rnrclient and
      the detailsview
  * softwarecenter/view/appdetailsview_gtk.py:
    - show "none yet", "loading" in the review details
  * softwarecenter/db/reviews.py, softwarecenter/view/appdetailsview_gtk.py:
    - log into the right logger with the right priority
  * softwarecenter/view/catview_gtk.py:
    - remove debug output
  * softwarecenter/db/reviews.py, test/test_reviews.py:
    - sort reviews by version/usefulness/date

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/lobby-tweaks:
    - better layout of the welcome lobby screen
  * lp:~mmcg069/software-center/catviewgtk-code-reorg:
    - move widgets out into softwarecenter/view/widgets

  [ Kiwinote ]
  * softwarecenter/view/widgets/buttons.py:
    - make CategoryButton accessible
  * softwarecenter/view/widgets/carousel.py:
    - minor accessibility tweaks
  * softwarecenter/view/widgets/mkit.py:
    - make Button emit 'clicked' on pressing enter key
 -- Michael Vogt <email address hidden> Fri, 18 Feb 2011 11:53:19 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers