software-center crashed with ValueError in __init__(): Need either appname or pkgname or request

Bug #717645 reported by asabjorn on 2011-02-12
334
This bug affects 87 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Per comment #16, this bug is still occuring in Precise, Software Center version 5.2.

I was clicking around in software-center while installing an application and it crashed.
Edit from Erik B. Andersen:I wasn't installing anything, but searching, and I caused this. It may have been a resultless search that caused it, but I am not sure.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.17.1
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic i686
Architecture: i386
Date: Sat Feb 12 02:56:11 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with ValueError in __init__(): Need either appname or pkgname or request
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

asabjorn (andreas-saebjoernsen) wrote :
tags: removed: need-duplicate-check
visibility: private → public
description: updated
tags: added: amd64

I'm having the same issue, even after updating to the new mesa, and libgl1, package....

Giovanni Mellini (merlos) wrote :

just opened Software Center, tried to search for vpn keyword and the bug windows pop-out.
I can continue to use Software Center as usual

Gary Lasker (gary-lasker) wrote :

Confirmed based on number of dupes and me-toos.

Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: bugpattern-needed
tags: added: bugpattern-written
removed: bugpattern-needed
Kiwinote (kiwinote) on 2011-08-07
summary: - I was clicking aroudn in software-center while installing an application
- (rails) and it crashed. software-center crashed with ValueError in
- __init__(): Need either appname or pkgname or request
+ software-center crashed with ValueError in __init__(): Need either
+ appname or pkgname or request
tags: added: iso-testing
Laudeci Oliveira (laudeci) wrote :

this bug is affecting me, look at the screenshot how it looks like when searching for a pacakge.

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Can you still reproduce this issue on 11.10 or 12.04 ? The latest dupes I got are from previous versions and
the code got updated to no longer do the same call as the old code.

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Michael Vogt (mvo) wrote :

@Laudeci Oliveira (laudeci):
Your screenshot indicates its version 5.0+, could you plase attach your crash file (in /var/crash) or paste the backtrace to this report? do you have a way to reproduce the bug?

Muharem Hrnjadovic (al-maisan) wrote :

Just started the software-center and searched for skype. It crashed with the following stack trace

2012-04-08 22:50:39,881 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-04-08 22:50:39,887 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-04-08 22:50:40,157 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/ui/gtk3/widgets/cellrenderers.py", line 385, in do_render
    is_rtl)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/widgets/cellrenderers.py", line 160, in _render_summary
    layout.set_markup(self.model.get_markup(app), -1)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/models/appstore2.py", line 185, in get_markup
    app = self.db.get_application(doc)
  File "/usr/share/software-center/softwarecenter/db/database.py", line 401, in get_application
    return Application(appname, pkgname, iconname)
  File "/usr/share/software-center/softwarecenter/db/application.py", line 52, in __init__
    raise ValueError("Need either appname or pkgname or request")
ValueError: Need either appname or pkgname or request

Muharem Hrnjadovic (al-maisan) wrote :

$ apt-cache show software-center
Package: software-center
Priority: optional
Section: gnome
Installed-Size: 4256
Maintainer: Michael Vogt <email address hidden>
Architecture: all
Version: 5.1.14.1

I was installing a list of 4 applications (gnome shell 3.4ubuntu02 was one of them) and I realised I installed gnome do but I wannted synapse. I unpinned gnome do and when I searched synapse it chrashed. I don't know hat app was installing at that moment. I see from the rest that the searching might be the problem. Hope the extra info helps.

Otto Kekäläinen (otto) wrote :

Running 12.04 with all updates 2012-04-18 and this error comes up while just browsing and searching for apps. The error comes up multiple times and is really annoying.

The software center itself does not crash, but an apport window pops up saying software center crashed with errors, but it is impossible to cut-and-paste from the window, so I can't post here the errors. Also apport refuses to open a new bug, since this bug already exists.

Gary Lasker (gary-lasker) wrote :

Thank you very much Muharem, Andrei and Otto, for taking the time and trouble to report back on this issue. Clearly it is still occuring in Precise, so I have reset the status to Confirmed.

Thank you again, your help is much appreciated!

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
Michael Vogt (mvo) wrote :

It would be great if you could attach the logs from /home/egon/.cache/software-center/software-center.log if you hit this as it seems like aport is a bit over enthusiastic about preventing more reports. The backtrace in #8 and in the original report are sufficiently different so I would love to see more backtraces to get a better idea what is going on.

Michael Vogt (mvo) on 2012-04-19
Changed in software-center (Ubuntu):
milestone: none → precise-updates
Michael Vogt (mvo) wrote :

I tried various way to reproduce this without much success so far. Any hints how to reproduce are welcome.

Michael Vogt (mvo) wrote :

I pushed a branch that makes them go away, but I can not say I'm overly happy about it because I would really prefer to find the root cause instead.

David Pitkin (dpitkin) on 2012-04-19
tags: added: ca-escalated

Running the most up-to-date release of Precise (updated on 2012-04-24 00UT) this bug appeared on Software Center 5.2 while I was clicking on the Science and Engineering item on the left menu. Nothing happens but the crash. Sometimes the application draws/render the main panel but no icons of applications are shown. Note: I was using the Brazilian Portuguese translation, so I do not know if could be a encoding character problem since it is UTF-8.

David Pitkin (dpitkin) on 2012-06-04
tags: removed: ca-escalated
description: updated
Filiprino (filiprino) wrote :

Hi,
I'm using Ubuntu 12.10 and this problem showed up when I clicked on "show X technical elements" to show more packages (my Ubuntu is in spanish so it may be something different in english).

Hiren Gandhi (hirenngandhi) wrote :

encountered this bug after upgrading from ubuntu gnome 13.10 to ubuntu gnome 14.04 beta 2. Was trying to install the precise skype package that I downloaded from the skype website and while in the process of installing i get the crash report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers