software-center crashed with TypeError in exists()

Bug #716245 reported by John Walsh on 2011-02-10
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

adobe flash player extension crashed during installation

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Thu Feb 10 04:09:42 2011
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center apt:adobe-flashplugin?channel=$distro-partner
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', 'apt:adobe-flashplugin?channel=$distro-partner']
SourcePackage: software-center
Title: software-center crashed with TypeError in exists()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

John Walsh (psm6061) wrote :

This crash has the same stack trace characteristics as bug #639934. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

affects: ubuntu → software-center (Ubuntu)
tags: removed: need-duplicate-check
tags: added: regression-retracer
Kiwinote (kiwinote) on 2011-02-10
visibility: private → public
Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → Low
status: New → Fix Committed
Gary Lasker (gary-lasker) wrote :

Fix merged to trunk. Thanks kiwinote!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.18

---------------
software-center (3.1.18) natty; urgency=low

  [ Michael Vogt ]
  * added "Was this review useful" feature (currently hidden
    pending rollout of server support)
  * added "Offline cache for reviews" feature
    (needs latest python-piston-mini-client to work)
  * debian/control:
    - depend on latest python-piston-mini-client

  [ Kiwinote ]
  * softwarecenter/distro/Ubuntu.py:
    - we can't download an icon for a featured application if the cache is not
      ready (LP: #711857, LP: #717337)
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't crash if app_details has no desktop_file (LP: #716245)
  * softwarecenter/view/purchaseview.py:
    - open external links in default browser (LP: #640520)
  * softwarecenter/view/softwarepane.py:
    - play nicely if we click on an app before the cache is ready (LP: #691321)
    - minor grammar tweak for Dylan McCall (LP: #717410)

  [ Gary Lasker ]
  * softwarecenter/enums.py,
    softwarecenter/utils.py,
    softwarecenter/models/viewswitcherlist.py,
    softwarecenter/view/pendingview.py:
    - generalize get_icon_from_iconname method, wire it up
    - fix crash if an icon can't be found (LP: #716111)
    - try a different, subjectively better-suited icon for the history item
      (one that is also included in gnome-icon-theme)
 -- Michael Vogt <email address hidden> Tue, 15 Feb 2011 17:39:02 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers