software-center crashed with GError in _get_icon(): Failed to load icon

Bug #716111 reported by ninjadd on 2011-02-09
440
This bug affects 73 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker

Bug Description

Binary package hint: software-center

Tried to launch Software Center from the new menu and it wouldn't load. Tried two times before prompted to report error.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.17.1
ProcVersionSignature: Ubuntu 2.6.38-2.29-generic-pae 2.6.38-rc3
Uname: Linux 2.6.38-2-generic-pae i686
Architecture: i386
Date: Wed Feb 9 13:11:01 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with GError in _get_icon(): Failed to load icon
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

ninjadd (ninjadd) wrote :
tags: removed: need-duplicate-check
Kiwinote (kiwinote) on 2011-02-10
visibility: private → public
scott anderson (lwarranty) wrote :

Fresh install daily build 2/10 - including updates during install, changed no packages additions or config changes, single monitor, clean install. Crashed, ran update manager - only partial upgrade possible "binding to get places into the launcher - shared library" grayed out...

scott anderson (lwarranty) wrote :

Ran partial upgrade - same issue...

scott anderson (lwarranty) wrote :

Dunnow why - installed ubuntu restricted extra's and it works... both Unbuntu Software Center and Update Manager?

Paul White (paulw2u) wrote :

Cannot start software-center by any means.

Omer Akram (om26er) wrote :

certainly not a software center bug. Today I started the Live CD and a few other apps were not being started either and also you cannot change the icon theme from the default gnome one. So I believe there is a problem with gnome-setting-daemon and such. this bug is just a cause of that. though SC should not fail to start?

Jeff Stone (stone1343) wrote :

I had the same crash trying to install Dropbox on a Natty AMD64 daily build from 2011-02-12

Sander Jonkers (jonkers) wrote :

Same crash trying to start Sofware Center on Natty daily build 2011-02-13, running from USB stick, with low resolution.

Gary Lasker (gary-lasker) wrote :

Quite a few folks hitting this one.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
tags: added: bugpattern-needed
Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
status: Confirmed → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Gary Lasker (gary-lasker) wrote :

Thanks everyone for your reports. A fix for this issue has been committed and will be available with the next development release of software-center.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.18

---------------
software-center (3.1.18) natty; urgency=low

  [ Michael Vogt ]
  * added "Was this review useful" feature (currently hidden
    pending rollout of server support)
  * added "Offline cache for reviews" feature
    (needs latest python-piston-mini-client to work)
  * debian/control:
    - depend on latest python-piston-mini-client

  [ Kiwinote ]
  * softwarecenter/distro/Ubuntu.py:
    - we can't download an icon for a featured application if the cache is not
      ready (LP: #711857, LP: #717337)
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't crash if app_details has no desktop_file (LP: #716245)
  * softwarecenter/view/purchaseview.py:
    - open external links in default browser (LP: #640520)
  * softwarecenter/view/softwarepane.py:
    - play nicely if we click on an app before the cache is ready (LP: #691321)
    - minor grammar tweak for Dylan McCall (LP: #717410)

  [ Gary Lasker ]
  * softwarecenter/enums.py,
    softwarecenter/utils.py,
    softwarecenter/models/viewswitcherlist.py,
    softwarecenter/view/pendingview.py:
    - generalize get_icon_from_iconname method, wire it up
    - fix crash if an icon can't be found (LP: #716111)
    - try a different, subjectively better-suited icon for the history item
      (one that is also included in gnome-icon-theme)
 -- Michael Vogt <email address hidden> Tue, 15 Feb 2011 17:39:02 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Bartmann (bartmix) wrote :

Hi, wen is the new software-center (3.1.18) available?

On the mirror there is only the 3.1.17.

Gary Lasker (gary-lasker) wrote :

Hi Bartmann, it takes generally a couple of hours for a package to appear in the main archives at archive.ubuntu.com, and then there will be some additional delay before it makes its way to the mirror you are using (that delay depends upon the mirror).

You can check the latest state of things using the following commands in the terminal:

  sudo apt-get update
  apt-cache policy software-center

The latter will tell your currently installed version as well as the currently available version at your archive mirror.

In any case, I would in think a few hours you may see it?

Paul White (paulw2u) wrote :

I have installed 3.1.18 and software-center still crashes. A message telling that it has closed unexpectedly appears and prompts me to send a bug report. software-center doesn't close though and appears to be usable.

Gary Lasker (gary-lasker) wrote :

Hi Paul. That is likely a different issue actually (since with this error software-center doesn't even start at all). If you see the crash dialog again please go ahead and submit the bug report using the dialog as that will provide us the debugging info we will need to figure out what that issue is. In particular, it would be good to know if you are encountering some secondary side-effect of this fix somehow.

Thanks very much for your help!
Gary

Gary Lasker (gary-lasker) wrote :

Hey again Paul, thanks, I got your new report (bug 719662). Indeed, it's a different code path and so needs a separate fix. Thanks for filing that!

To post a comment you must log in.