software-center crashed with KeyError in _reviews_timeout_watcher(): <softwarecenter.db.application.Application object at 0x97ec04c>

Bug #709548 reported by Rick Flynn on 2011-01-28
86
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

I simply opened Ubuntu software center and started to install "Wmitime" and got the error message.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.14
ProcVersionSignature: Ubuntu 2.6.38-1.27-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Fri Jan 28 18:22:27 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Xubuntu 10.10 "Maverick Meerkat" - Release i386 (20101008.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with KeyError in _reviews_timeout_watcher(): <softwarecenter.db.application.Application object at 0x97ec04c>
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/db/reviews.py", line 228, in _reviews_timeout_watcher
     if not self._new_reviews[app].empty():
 KeyError: <softwarecenter.db.application.Application object at 0x97ec04c>
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Rick Flynn (flynn1959) wrote :
tags: removed: need-duplicate-check
Rick Flynn (flynn1959) on 2011-01-28
visibility: private → public
Kiwinote (kiwinote) wrote :

Saw this one briefly earlier today.

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce this here, the problem is that _reviews_timeout_watcher() maybe running multiple times for the same app (if the user navigated away from the details page and then back to it while a download is still in progress). Then the first watcher submits the callback and deletes the entry "del self._new_reviews[app]" so that the second watcher fails.

Michael Vogt (mvo) on 2011-02-01
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.15

---------------
software-center (3.1.15) natty; urgency=low

  [ Kiwinote ]
  * softwarecenter/apt/aptcache.py:
    - don't crash if pkg not in cache (deb files)
  * softwarecenter/utils.py,
    utils/submit_review.py:
    - play slightly nicer with locales (LP: #709671)
  * softwarecenter/view/appdetailsview_gtk:
    - correctly hide addons/reviews from interface when we have an error
  * utils/submit_review.py:
    - allow us to review when spell check isn't available (LP: #709155)

  [ Michael Vogt ]
  * softwarecenter/db/reviews.py:
    - fix race in review downloaded watcher (LP: #709548)
  * test/test_utils.py:
    - add test for get_language()
  * softwarecenter/backend/zeitgeist_simple.py:
    - don't raise a exception if zeitgeist is not available (LP: #709718)
  * softwarecenter/app.py:
    - fix sso login creation on reinstall-previous purchase (LP: #709856)
  * softwarecenter/view/widgets/reviews.py:
    - change ratings star color (LP: #711030)
  * tests/*:
    - fix test invocation at build time and fix test failures
 -- Michael Vogt <email address hidden> Tue, 01 Feb 2011 11:34:30 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers