Ubuntu

software-center crashed with DBusException in call_blocking()

Reported by Kangarooo Jānis on 2011-01-20
234
This bug affects 38 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

This Bug is a roll-up for many DBusExceptions crashes.

Original Bug Description:

Binary package hint: software-center

While update & opened softw centre got this crash but it didnt closed. its still open
Last lines in terminal
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.35-24-generic
.: 6: Can't open /scripts/casper-functions

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.7
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Uname: Linux 2.6.35-24-generic i686
Architecture: i386
Date: Thu Jan 20 03:28:26 2011
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with DBusException in call_blocking()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Kangarooo Jānis (kangarooo) wrote :
description: updated
tags: removed: need-duplicate-check
visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Laura Czajkowski (czajkowski) wrote :

This is happen on Precise when I launch the software center

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Kiwinote (kiwinote) on 2012-05-01
tags: removed: maverick
Dave Morley (davmor2) on 2012-05-18
tags: added: ca-escalated
David Pitkin (dpitkin) on 2012-05-21
description: updated
description: updated
Dave Morley (davmor2) on 2012-05-21
tags: removed: ca-escalated
David Pitkin (dpitkin) on 2012-05-21
description: updated
Michael Vogt (mvo) wrote :

It looks like its duplicating some bugs that have similar but different tracebacks, so we need to carefully look at the tracebacks of the dupes to see if they are all the same or just similar, e.g. the last dupe has:
org.freedesktop.DBus.Error.TimedOut: Activation of org.debian.apt timed out

Changed in software-center (Ubuntu):
importance: Undecided → Medium
Changed in software-center (Ubuntu):
importance: Medium → High
CSRedRat (csredrat) wrote :

I'm have this error after update.

Dave Morley (davmor2) on 2012-09-03
tags: added: ca-escalated
Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Roberto Alsina (ralsina) on 2013-01-22
Changed in software-center (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
John Winterton (jwinterton) wrote :

Haven't had this lately, so why is it still active?

Because people like me still have it under quantal. (I get this every time I open the software centre, so I have to use the terminal to get new software.)

John Winterton (jwinterton) wrote :

As a better work around than that, try the Synaptic package manager.

Rodney Dawes (dobey) on 2014-01-29
Changed in software-center (Ubuntu):
assignee: Rodney Dawes (dobey) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers