software centre shows wrong installed version no. for firefox

Bug #695026 reported by Geetam Chawla on 2010-12-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

Binary package hint: software-center

im using ubuntu 10.10
version of software centre is 3.0.4
when i typed firefox in the software centre i expected it to show the option to upgrade firefox since i was using firefox 3.6.10
when i clicked on more info it showed the version no. to be 3.6.13,the latest version,i launched firefox,clicked on help->about
it showed version 3.6.10

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.4
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Tue Dec 28 19:41:59 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcEnviron:
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: software-center

Geetam Chawla (gc95271) wrote :
Victor Vargas (kamus) wrote :

Not able to reproduce it here with release 3.0.7, Please could you upgrade your software-center version to the latest available under Ubuntu Maverick and check if this issue is still affecting you? Thanks

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Kiwinote (kiwinote) wrote :

Hi Geetam! Thanks for your bug report. I have fixed the issue regarding software-center displaying the wrong version number for installed packages in the branch linked - the fix should be available in the next development release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.10

---------------
software-center (3.1.10) natty; urgency=low

  [ Michael Vogt ]
  * include full AUTHORS info into the about dialog,
    based on the lp:~adnane002/software-center/fix.632770
    branch (LP: #632770)
  * data/ui/SoftwareCenter.ui:
    - add translator_credits (LP: #632770), thanks to
      Adnane Belmadiaf
  * merged lp:~aaronp/software-center/fix-699898, many thanks
    to Aaron Peachey (LP: #699898)

  [ Kiwinote ]
  * softwarecenter/app.py:
    - don't crash on pressing backspace in the history pane (LP: #696639)
  * softwarecenter/backend/aptd.py:
    - play nicely after cancelling policykit dialog
  * softwarecenter/db/application.py:
    - display correct version number for installed packages (LP: #695026)
  * softwarecenter/distro/*.py:
    - fix broken translations (LP: #703610)

  [ Gary Lasker ]
  * softwarecenter/models/appstore.py,
    softwarecenter/backend/aptd.py,
    softwarecenter/models/appstore.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py:
    - restore progress bar feedback when installing/removing software
      from within the applist view (LP: #701589)
    - clean up unused code
  * softwarecenter/backend/aptd.py:
    - attach the aptdaemon progress-changed listener earlier in the
      transaction to allow for more instant progress feedback in the UI
 -- Michael Vogt <email address hidden> Mon, 17 Jan 2011 13:46:48 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released

sorry dude for replying so late (didnt checked my email account for like 1
month)
thanks for fixing the bug[?]

On Tue, Jan 4, 2011 at 10:42 PM, Kiwinote <email address hidden> wrote:

> Hi Geetam! Thanks for your bug report. I have fixed the issue regarding
> software-center displaying the wrong version number for installed
> packages in the branch linked - the fix should be available in the next
> development release. Please continue to report any bugs you may find in
> software-center. Thanks again for your help!
>
> ** Changed in: software-center (Ubuntu)
> Status: Incomplete => Fix Committed
>
> ** Changed in: software-center (Ubuntu)
> Assignee: (unassigned) => Kiwinote (kiwinote)
>
> ** Branch linked: lp:~kiwinote/software-center/tweaks
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/695026
>
> Title:
> software centre shows wrong installed version no. for firefox
>
> Status in “software-center” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: software-center
>
> im using ubuntu 10.10
> version of software centre is 3.0.4
> when i typed firefox in the software centre i expected it to show the
> option to upgrade firefox since i was using firefox 3.6.10
> when i clicked on more info it showed the version no. to be 3.6.13,the
> latest version,i launched firefox,clicked on help->about
> it showed version 3.6.10
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: software-center 3.0.4
> ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
> Uname: Linux 2.6.35-22-generic i686
> Architecture: i386
> Date: Tue Dec 28 19:41:59 2010
> ExecutablePath: /usr/share/software-center/software-center
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386
> (20101007)
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcEnviron:
> LANG=en_IN
> SHELL=/bin/bash
> SourcePackage: software-center
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/695026/+subscribe
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers