software-center crashed with ZeroDivisionError in _update_pagesel()

Bug #694836 reported by Victor Vargas on 2010-12-27
366
This bug affects 41 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Aaron Peachey
Natty
High
Aaron Peachey

Bug Description

Binary package hint: software-center

I just open software-center and then appear apport saying that is crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.9
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
Date: Mon Dec 27 18:06:30 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101227)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=es_CL.UTF-8:es:en_GB:en
 LANG=es_CL.UTF-8
 LC_MESSAGES=es_AR.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with ZeroDivisionError in _update_pagesel()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Victor Vargas (kamus) wrote :
tags: removed: need-duplicate-check
visibility: private → public
tags: added: iso-testing
Kate Stewart (kate.stewart) wrote :

Based on the number of duplicate reports, seeing the same thing, I'm marking this confirmed, and high priority.

Changed in software-center (Ubuntu Natty):
importance: Undecided → High
status: New → Confirmed
milestone: none → natty-alpha-3
Aaron Peachey (aaronp) wrote :

I've linked a branch which should stop the crash for now. It's temporary only at the moment, I can't reproduce this issue. Can any of the bug reporters give info about what they were doing when the crash happened? Specifically, anything to do with resizing the window whilst in lobby view (with the Features and What'sNew sections)

Aaron Peachey (aaronp) on 2011-02-03
Changed in software-center (Ubuntu Natty):
assignee: nobody → Aaron Peachey (aaronp)
Michael Vogt (mvo) wrote :

Thanks Aaron!

Changed in software-center (Ubuntu Natty):
status: Confirmed → Fix Committed
tags: added: bugpattern-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.16

---------------
software-center (3.1.16) natty; urgency=low

  [ Michael Vogt ]
  * merged lp:~mmcg069/software-center/reviews-and-netstatus
    many thanks to Matthew McGowan
  * test/test_appdetails_view.py:
    - add appdetails netstatus tests
  * merged lp:~aaronp/software-center/fix-694836, many thanks
    (LP: #694836)
  * softwarecenter/view/softwarepane.py:
    - add helper to init atk names so that mago can pick them up
  * tests/Makefile, test/mago/test_with_mago.py:
    - use new style mago for search tests and enable in auto-tests

  [ Gary Lasker ]
  * softwarecenter/distro/Ubuntu.py,
    softwarecenter/models/appstore.py:
    - fix crash if attempting to download a remote icon before
      the cache is ready (LP: #688991)
  * softwarecenter/models/appstore.py:
    - fix intermittent AttributeError in on_get_value (LP: #712170)
    - fix attribute error when building a custom list (LP: #712888)
  * test/test_custom_lists.py:
    - add unit test for custom lists

  [ Aaron Peachey ]
  * view/appdetailsview_gtk.py:
     - change label to click to write a review if user already has
       a review for that package LP: #709738
     - alter review look if it belongs to current user LP: #710396

  [ Matthew McGowan ]
  * lp:~mmcg069/software-center/tiny-back-forward-tweak:
    - a small tweak to make the arrow in the back-forward button pick
      a better size across a wider range of gtk themes.
 -- Michael Vogt <email address hidden> Tue, 08 Feb 2011 11:58:53 +0100

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Aaron Peachey (aaronp) wrote :

The fix released for this bug will just stop the error/crash but does not address the cause of the issue, which is currently unknown. Original bug reporters - please report back to advise what behaviour you are seeing now that this fix is in so we can get more hints to address the actual problem. Thanks!

Larry Reid (lcreid) wrote :

I'm still using 3.1.15 of software centre but I haven't seen the bug since Saturday. It was pretty consistent before. I installed a number of updates on Saturday and Sunday so maybe one of them fixed the problem (or hid it).

To post a comment you must log in.