Screenshots are confused with applications

Bug #691594 reported by Matthew Paul Thomas on 2010-12-17
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

User testing of Ubuntu Software Center consistently shows that some people think they can launch an application by clicking the screenshot.

This problem has previously been observed by people testing on-screen help. <https://wiki.ubuntu.com/UbuntuHelp/UsingScreenshots> I thought I could get around it in USC 3.0 by showing only a small clickable thumbnail, but that isn't working. So, we need to try something else.

In usability testing of Ubuntu 12.04 beta, one of the 15 testers still clicked on the screenshot. "I can't open it. It's a bit weird."

<https://wiki.ubuntu.com/SoftwareCenter#gallery>: "To emphasize that it is a gallery, the gallery should include thumbnails of each item even if there is only one. The currently displayed media, and each thumbnail, should each appear inside an inset border, with the border of the focused item highlighted."

Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Confirmed
importance: Undecided → High
Matthew McGowan (mmcg069) wrote :

I've made some changes which have landed in trunk recently:

 - As suggested by mpt, a magnifying glass icon onhover (though the stock icon is not the best)
 - A fading tooltip which clearly explains clicking will open the larger version of the screenshot

Perhaps these tweaks improve things a bit?

Gary Lasker (gary-lasker) wrote :

mpt, when you get a chance please check out Matthew's screenshot changes in the details view and let us know what you think. To me it seems like this ought to do the trick, but I suppose some user testing might be needed to make sure that we've really taken care of this.

Thanks!

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Gary Lasker (gary-lasker) wrote :

I will close this for now. If it turns out this is still an issue in user testing, let's re-open.

Changed in software-center (Ubuntu):
status: Incomplete → Fix Released
description: updated
Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
Matthew Paul Thomas (mpt) wrote :

Still a problem in Ubuntu 12.04. Specification updated. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=660&rev1=659>

description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers