Pressing Install does nothing in Software Center.

Bug #688823 reported by Newfie on 2010-12-11
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

Using Software Center 3.1.6

If I press "Install" on any item I wish to install, the button gets greyed out for a few moments, then returns to being clickable. No software is installed and it gives no messages.

Terminal output:

2010-12-10 21:18:19,751 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 99, 'open')'
2010-12-10 21:18:19,749 - root - WARNING - failed to add sca db Couldn't stat '/home/michael/.cache/software-center/software-center-agent.db' (No such file or directory)
2010-12-10 21:18:39,170 - softwarecenter.app - INFO - software-center-agent finished with status 1
2010-12-10 21:19:28,727 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.6/dbus/proxies.py', 400, '_introspect_error_handler')'
2010-12-10 21:19:28,726 - dbus.proxies - ERROR - Introspect error on :1.52:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.56" (uid=1000 pid=2551 comm="/usr/bin/python) interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.52" (uid=0 pid=1810 comm="/usr/bin/python))
2010-12-10 21:20:12,670 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 99, 'open')'
2010-12-10 21:20:12,670 - root - WARNING - failed to add sca db Couldn't stat '/home/michael/.cache/software-center/software-center-agent.db' (No such file or directory)
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/view/installedpane.py", line 125, in on_db_reopen
    self.refresh_apps()
  File "/usr/share/software-center/softwarecenter/utils.py", line 100, in wrapper
    f(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/view/installedpane.py", line 110, in refresh_apps
    filter=self.apps_filter)
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 196, in __init__
    self._perform_search()
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 229, in _perform_search
    self.nr_apps, self.nr_pkgs = self._get_estimate_nr_apps_and_nr_pkgs(enquire, q, xfilter)
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 202, in _get_estimate_nr_apps_and_nr_pkgs
    tmp_matches = enquire.get_mset(0, len(self.db), None, xfilter)
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 1601, in __call__
    pkgname = doc.get_value(XAPIAN_VALUE_PKGNAME) or doc.get_value(self.db._axi_values["pkgname"])
KeyError: 'pkgname'
2010-12-10 21:22:05,906 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.6/dbus/connection.py', 218, 'maybe_handle_message')'
2010-12-10 21:22:05,905 - dbus.connection - ERROR - Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/backend/aptd.py", line 523, in on_transactions_changed
    trans = client.get_transaction(current)
  File "/usr/lib/python2.6/dist-packages/defer/utils.py", line 107, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 155, in _convert_dbus_exception
    raise get_native_exception(error)
DBusException: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
2010-12-10 21:22:05,918 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.6/dbus/connection.py', 218, 'maybe_handle_message')'
2010-12-10 21:22:05,918 - dbus.connection - ERROR - Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/view/pendingview.py", line 97, in on_transactions_changed
    trans = aptdaemon.client.get_transaction(tid)
  File "/usr/lib/python2.6/dist-packages/defer/utils.py", line 107, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 155, in _convert_dbus_exception
    raise get_native_exception(error)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.58 was not provided by any .service files
2010-12-10 21:22:05,934 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.6/dbus/connection.py', 218, 'maybe_handle_message')'
2010-12-10 21:22:05,934 - dbus.connection - ERROR - Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/backend/aptd.py", line 523, in on_transactions_changed
    trans = client.get_transaction(current)
  File "/usr/lib/python2.6/dist-packages/defer/utils.py", line 107, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 155, in _convert_dbus_exception
    raise get_native_exception(error)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.58 was not provided by any .service files
2010-12-10 21:22:05,959 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.6/dbus/connection.py', 218, 'maybe_handle_message')'
2010-12-10 21:22:05,958 - dbus.connection - ERROR - Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/share/software-center/softwarecenter/view/pendingview.py", line 97, in on_transactions_changed
    trans = aptdaemon.client.get_transaction(tid)
  File "/usr/lib/python2.6/dist-packages/defer/utils.py", line 107, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 155, in _convert_dbus_exception
    raise get_native_exception(error)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.58 was not provided by any .service files
2010-12-10 21:22:07,050 - softwarecenter.backend - WARNING - daemon dies, ignoring: <AptTransaction object at 0xa521f7c (aptdaemon+client+AptTransaction at 0xa0c0860)> exit-failed
///////End

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.6
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
Date: Fri Dec 10 21:13:15 2010
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101206)
PackageArchitecture: all
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: software-center

Newfie (mn-newfie) wrote :
description: updated
kurt belgrave (trinikrono) wrote :

can you please run
software-center --debug
and post up your results
Cheers

Changed in software-center (Ubuntu):
status: New → Incomplete
kurt belgrave (trinikrono) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Newfie (mn-newfie) wrote :

Hey there, sorry about the huge delay :)

I reported this quite a long time ago. I have a new installation of Natty (fully up to date) and no longer have this problem. If you still want me to post the debug output, let me know. Though as I said, it seems to be fixed.

Gary Lasker (gary-lasker) wrote :

Hey Newfie, thanks very much for reporting back. I'm glad to hear the problem has been resolved for you. No need to post debug output then, sounds like everything's fine so I'll close this out out.

Thanks again Newfie and thank you Kurt for your help!

Changed in software-center (Ubuntu):
status: Incomplete → Invalid
teo1978 (teo8976) wrote :

Seven fucking years later, I'm observing the same issue

Changed in software-center (Ubuntu):
status: Invalid → Confirmed
teo1978 (teo8976) wrote :

on 16.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers