software-center didn't launch

Bug #684887 reported by Wajih Letaief on 2010-12-03
242
This bug affects 33 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
cholards

Bug Description

Binary package hint: software-center

on Natty Narwhal (ALPHA-1), software-center didn't launch.

When i try to launch it via console, i get this message :

2010-12-03 19:18:01,073 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 96, 'open')'
2010-12-03 19:18:01,073 - root - WARNING - failed to add sca db Couldn't stat '/root/.cache/software-center/software-center-agent.db' (Aucun fichier ou dossier de ce type)
Traceback (most recent call last):
  File "/usr/bin/software-center", line 109, in <module>
    app = SoftwareCenterApp(datadir, xapian_base_path, options, args)
  File "/usr/share/software-center/softwarecenter/app.py", line 209, in __init__
    self.navhistory_forward_action)
  File "/usr/share/software-center/softwarecenter/view/availablepane.py", line 100, in __init__
    self._build_ui()
  File "/usr/share/software-center/softwarecenter/view/availablepane.py", line 111, in _build_ui
    self.apps_filter)
  File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line 256, in __init__
    self.build(desktopdir)
  File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line 497, in build
    self._build_homepage_view()
  File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line 327, in _build_homepage_view
    self._append_featured_and_new()
  File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line 412, in _append_featured_and_new
    nonapps_visible=AppStore.NONAPPS_ALWAYS_VISIBLE)
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 180, in __init__
    q.get_description() for q in search_query])):
AttributeError: 'Query' object has no attribute 'get_description'

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.3
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
Architecture: i386
Date: Fri Dec 3 19:20:05 2010
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SourcePackage: software-center

Wajih Letaief (mawale) wrote :
zeruke (oninekoze) on 2010-12-04
Changed in software-center (Ubuntu):
status: New → Confirmed
zeruke (oninekoze) wrote :

a little extra info is that when trying to do a full backtrace with gdb there is an error stating

"/usr/bin/software-center": not in executable format: File format not recognized

because of saying that i went to check and see if it was set to executable

Kiwinote (kiwinote) wrote :

Hi everyone! Thanks for the bug reports. It would seem that the xapian.Query(..).get_description() function is no longer available on natty. I have linked a branch that theoretically should fix this issue, but as I aren't running natty myself yet, I can't test it. Would someone running natty be able to test the change as follows:
- edit /usr/share/software-center/softwarecenter/view/appview.py to replace 'q.get_description()' in line 180 with 'str(q)'
- now launch software-center, and it *should* hopefully work
Please let me know the outcome. Thanks!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → High
status: Confirmed → Fix Committed
zeruke (oninekoze) wrote :

Kiwinote changing the appview.py how you said worked

thanks Kiwinote : it works ;)

2010/12/4 zeruke <email address hidden>

> Kiwinote changing the appview.py how you said worked
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/684887
>
> Title:
> software-center didn't launch
>
> Status in “software-center” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: software-center
>
> on Natty Narwhal (ALPHA-1), software-center didn't launch.
>
> When i try to launch it via console, i get this message :
>
> 2010-12-03 19:18:01,073 - softwarecenter.fixme - WARNING - logs to the root
> logger: '('/usr/share/software-center/softwarecenter/db/database.py', 96,
> 'open')'
> 2010-12-03 19:18:01,073 - root - WARNING - failed to add sca db Couldn't
> stat '/root/.cache/software-center/software-center-agent.db' (Aucun fichier
> ou dossier de ce type)
> Traceback (most recent call last):
> File "/usr/bin/software-center", line 109, in <module>
> app = SoftwareCenterApp(datadir, xapian_base_path, options, args)
> File "/usr/share/software-center/softwarecenter/app.py", line 209, in
> __init__
> self.navhistory_forward_action)
> File "/usr/share/software-center/softwarecenter/view/availablepane.py",
> line 100, in __init__
> self._build_ui()
> File "/usr/share/software-center/softwarecenter/view/availablepane.py",
> line 111, in _build_ui
> self.apps_filter)
> File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line
> 256, in __init__
> self.build(desktopdir)
> File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line
> 497, in build
> self._build_homepage_view()
> File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line
> 327, in _build_homepage_view
> self._append_featured_and_new()
> File "/usr/share/software-center/softwarecenter/view/catview_gtk.py", line
> 412, in _append_featured_and_new
> nonapps_visible=AppStore.NONAPPS_ALWAYS_VISIBLE)
> File "/usr/share/software-center/softwarecenter/view/appview.py", line
> 180, in __init__
> q.get_description() for q in search_query])):
> AttributeError: 'Query' object has no attribute 'get_description'
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: software-center 3.1.3
> ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
> Uname: Linux 2.6.37-7-generic i686
> Architecture: i386
> Date: Fri Dec 3 19:20:05 2010
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
> PackageArchitecture: all
> ProcEnviron:
> PATH=(custom, no user)
> LANG=fr_FR.utf8
> SHELL=/bin/bash
> SourcePackage: software-center
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/684887/+subscribe
>

Wajih Letaief (mawale) wrote :

Thanks Kiwinote

it fixes the bug

now it works

fuz (fuzetsu) wrote :

Yup, works for me as well.

mnemonix (kan2003) wrote :

отлично работает

timus tunes (timustunes) wrote :

Confirmed... works for me too.

tags: added: iso-testing
col reilly (lupinehorror) wrote :

yup...worked here too...thanks Kiwinote

NT Man (mikhail-v-gavrilov) wrote :

How i can get this update?
After commands sudo apt-get update && sudo apt-get upgrade, software-center didn't want launch again.

Worked for me too, with Natty

Is the fix an update? How can i get it?

Oh, see. No update released yet, but the fix works for me too.

Omer Akram (om26er) wrote :

you see the status is 'fix committed' when its fix released then you will have the fix in update.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.4

---------------
software-center (3.1.4) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/database.py:
    - add section and origin query parser prefixes, thanks to
      Matthew McGowan!
  * merged lp:~mvo/software-center/experimental-fastlist and
    lp:~kiwinote/software-center/experimental-fastlist, this should
    speed up the list rendering quite a lot
  * merged lp:~kelemeng/software-center/bug685467, many thanks!
    (LP: #685467)
  * softwarecenter/backend/aptd.py:
    - ported to the aptdaemon 0.40 API
  * debian/control:
    - depend on aptdaemon 0.40

  [ Kiwinote ]
  * softwarecenter/backend/channel.py:
    - only show installed packages in the 'for purchase' channel of the
      installed pane (LP: #684356)
  * softwarecenter/utils.py:
    - don't return a http proxy string if it contains no host (LP: #675186)
      thanks to Marius Gedminas
  * softwarecenter/view/appview.py:
    - don't crash in natty due to seemingly deprecated xapian.query attribute
      get_description (LP: #684887)
  * softwarecenter/view/channelpane.py:
    - don't explicitly show all pkgs for the partner channel, this is no
      longer needed because all apps now have app-install-data desktop files
  * softwarecenter/view/widgets/searchentry.py:
    - reverse the 'clear' icon for rtl as requested in (LP: #666519)
  * softwarecenter/app.py:
    - do not crash when showing a already installed package and the apt
      cache is not loaded yet

  [ Matthew Paul Thomas ]
  * data/ui/SoftwareCenter.ui:
    - improved text for software catalog update window (LP: #678355)
 -- Michael Vogt <email address hidden> Tue, 07 Dec 2010 15:02:40 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
assignee: Kiwinote (kiwinote) → cholards (adelaiyekolade)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers