Software-center does not show screenshots

Bug #675186 reported by Nichita Uțiu on 2010-11-14
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

Binary package hint: software-center

The screenshots next to text are displayed, but when I try to enlarge them I get a window with the ubuntu logo and nothing else.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.5
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sun Nov 14 16:02:19 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Nichita Uțiu (nikita.utiu) wrote :
Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. A quick look at the code would seem to indicate that we display this generic/blank image when we get a 403/404 error from the screenshots server (which is not immediately obvious from the ui). It is interesting to note that two people reported this issue within 12 hours of each other, but that we have not seen this issue before. This would seem to indicate that it may have been that the server was temporarily unreachable. Are you two able to check if this is a persisting issue, or if it was indeed just a temporary issue? There could well be a deeper cause, so please let us know your findings. Thanks again for your help!

Alex Engelmann (alex-engelmann) wrote :

For me it happens all the time, 24/7 so I doubt it's the image server. Basically, if I want an an app screenshot I can settle for the preview or go google it, because they don't work at all.

Nichita Uțiu (nikita.utiu) wrote :

I have the same problem, all the time. I can only see the screenshots in synaptic.

tags: added: screenshots software-center
Kiwinote (kiwinote) wrote :

Hi! I have just managed to reliably reproduce this issue when using a proxy. Could any of you confirm whether you are using a network proxy by chance? Thanks.

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Alex Engelmann (alex-engelmann) wrote :

I occasionally use my university's proxy to access journal databases, but mostly I just connect to cable internet through a router without a proxy.

Marius Gedminas (mgedmin) wrote :

I don't use a proxy. This issue happens all the time for me, and, besides, the small versions of the images are displayed just fine, and I'd expect them to come from the same server.

Sniffing port 80 traffic, I see HTTP requests for /thumbnail-with-version/... (two requests per screenshot: HEAD and then GET, which seems wasteful, but that's not the point of this issue) and no other traffic.

Marius Gedminas (mgedmin) wrote :

Thanks to bzr branch lp:ubuntu/software-version, I think I found the bug.

./view/appdetailsview_webkit.py, lines 306-307:

    def on_screenshot_thumbnail_clicked(self):
        url = self.distro.SCREENSHOT_LARGE_URL % self.app.pkgname

SCREENSHOT_LARGE_URL is "http://screenshots.ubuntu.com/screenshot-with-version/%(pkgname)s/%(version)s" and interpolating just the package name, instead of a dictionary with all the data, results in a

    TypeError: format requires a mapping

I think the right fix is to change that function to

    def on_screenshot_thumbnail_clicked(self):
        url = self.app.screenshot

but I cannot test it myself, since apparently I got natty's version which build-depends on python-scour which doesn't exist in maverick ...

Kiwinote (kiwinote) wrote :

Ok, thanks for the updates. It looks like the best way to solve this is to port the image dialog (ie the popup window) to use the same image downloading code as the thumbnail viewer is using. I should have some time for this in a weeks time.

Marius Gedminas (mgedmin) wrote :

Hey, this is Python! I can edit files in /usr/share/software-center/softwarecenter/ to debug the issue, no building needed.

I was wrong: on_screenshot_thumbnail_clicked() doesn't appear to be used at all. I'm getting an IOError from urllib at view/widgets/imagedialog.py line 152:

Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/view/widgets/imagedialog.py", line 147, in _fetch
    self._progress)
  File "/usr/lib/python2.6/urllib.py", line 93, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)
  File "/usr/lib/python2.6/urllib.py", line 239, in retrieve
    fp = self.open(url, data)
  File "/usr/lib/python2.6/urllib.py", line 207, in open
    return getattr(self, name)(url)
  File "/usr/lib/python2.6/urllib.py", line 346, in open_http
    h.endheaders()
  File "/usr/lib/python2.6/httplib.py", line 908, in endheaders
    self._send_output()
  File "/usr/lib/python2.6/httplib.py", line 780, in _send_output
    self.send(msg)
  File "/usr/lib/python2.6/httplib.py", line 739, in send
    self.connect()
  File "/usr/lib/python2.6/httplib.py", line 720, in connect
    self.timeout)
  File "/usr/lib/python2.6/socket.py", line 547, in create_connection
    for res in getaddrinfo(host, port, 0, SOCK_STREAM):
IOError: [Errno socket error] [Errno -2] Name or service not known

The url is http://screenshots.ubuntu.com/screenshot-with-version/liferea/1.6.3-1ubuntu4 and can be opened successfully in a web browser. I'm confused as to why this happens, since

    $ python
    >>> import urllib
    >>> location = tempfile.NamedTemporaryFile()
    >>> urllib.urlretrieve(url, location.name)
    ('/tmp/tmphXaKEv', <httplib.HTTPMessage instance at 0x9f3078c>)

works fine.

Marius Gedminas (mgedmin) wrote :

I do have a SOCKS proxy configured (localhost, port 1080) in gconf, but it is disabled:

     $ gconftool -R /system/http_proxy
      use_authentication = false
      authentication_password =
      authentication_user =
      ignore_hosts = [localhost,127.0.0.0/8,*.local,zope3]
      use_http_proxy = true
      port = 8080
      use_same_proxy = false
      host =

I'm surprised to see use_http_proxy is true, since the UI doesn't say anything about it -- see attached screenshot of gnome-network-properties.

Looks like the bug is in get_http_proxy_string_from_gconf(), since it returns something rather nonsensical for this gconf data:

    >>> get_http_proxy_string_from_gconf()
    'http://:8080/'

Marius Gedminas (mgedmin) wrote :

FWIW switching to manual proxy configuration and then back to direct internet connection in gnome-network-settings fixed my gconf data and now software center displays screenshots properly.

Kiwinote (kiwinote) wrote :

Hi Marius! Thanks a lot for those past few comments. I've fixed the get_http_proxy_string_from_gconf() function such that it doesn't return a string if we have no host. This solves the issues for me. Thanks a lot for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.4

---------------
software-center (3.1.4) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/database.py:
    - add section and origin query parser prefixes, thanks to
      Matthew McGowan!
  * merged lp:~mvo/software-center/experimental-fastlist and
    lp:~kiwinote/software-center/experimental-fastlist, this should
    speed up the list rendering quite a lot
  * merged lp:~kelemeng/software-center/bug685467, many thanks!
    (LP: #685467)
  * softwarecenter/backend/aptd.py:
    - ported to the aptdaemon 0.40 API
  * debian/control:
    - depend on aptdaemon 0.40

  [ Kiwinote ]
  * softwarecenter/backend/channel.py:
    - only show installed packages in the 'for purchase' channel of the
      installed pane (LP: #684356)
  * softwarecenter/utils.py:
    - don't return a http proxy string if it contains no host (LP: #675186)
      thanks to Marius Gedminas
  * softwarecenter/view/appview.py:
    - don't crash in natty due to seemingly deprecated xapian.query attribute
      get_description (LP: #684887)
  * softwarecenter/view/channelpane.py:
    - don't explicitly show all pkgs for the partner channel, this is no
      longer needed because all apps now have app-install-data desktop files
  * softwarecenter/view/widgets/searchentry.py:
    - reverse the 'clear' icon for rtl as requested in (LP: #666519)
  * softwarecenter/app.py:
    - do not crash when showing a already installed package and the apt
      cache is not loaded yet

  [ Matthew Paul Thomas ]
  * data/ui/SoftwareCenter.ui:
    - improved text for software catalog update window (LP: #678355)
 -- Michael Vogt <email address hidden> Tue, 07 Dec 2010 15:02:40 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
MrPok (wiebenik) wrote :

Just to be sure... the original bug poster stated "The screenshots next to text are displayed, but when ... *enlarge* them.." .
Post #3 and #4 seem to confirm this.

However, I am unable to see *any* screenshots in Software Center. For each piece of software that I look into via "More Info", I just see "No screenshot" next to the text. (So not even a thumbnail version of the screenshot!)

I have already checked several packages that have screenshots on http://screenshots.debian.net/packages, and in Software Center all of them give the "No screenshot".

When I click "Get Screenshot" in Synaptic, I do get the thumbnail and after clicking on that the full-sized screenshot.

Can anyone confirm?

(I am using Software Center version 3.0.7, the standard in Ubuntu 10.10 Maverick Meerkat.)

Tioz (tiozinoz) wrote :

Same issue here for me as original poster. Using Ubuntu 10.10 and my version of Software Center is 3.0.8.

I know it is a while since this was originally raised but as a new user, the comments generated so far don't seem provide a solution, not at least one I can interpret.

Any clarification will be appreciated.

I'm on 11.04 which has version 4 of the software center. This bug is still there, at least sometimes or on some packages. It was fixed for a while, then broken, then fixed.

Michal Smereczynski (michal-s) wrote :

Xubuntu 11.04, Ubunu Software Center 4.0.4, and the same thing. No screenshots...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers