In the detailed view the "Install" button doesn't change to "Remove" once the package is installed

Bug #674585 reported by Jean-Baptiste Lallement on 2010-11-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

1. Launch SC
2. Select a package
3. Double-click on the row or click on 'More' to access the detailed information
4. Click on 'Install'
5. Provide password if required
6. Watch the package being installed

Result:
After installation the button remains 'Install' and if you click on it, it triggers an error the application being already installed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.0
ProcVersionSignature: Ubuntu 2.6.37-2.10-generic 2.6.37-rc1
Uname: Linux 2.6.37-2-generic i686
Architecture: i386
Date: Fri Nov 12 17:19:03 2010
EcryptfsInUse: Yes
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: software-center

Jean-Baptiste Lallement (jibel) wrote :
tags: added: mago
summary: - In the detailed view "Install" button doesn't change "Remove" once the
- package is installed
+ In the detailed view the "Install" button doesn't change to "Remove"
+ once the package is installed
Kiwinote (kiwinote) wrote :

Hi! Thanks for the bug report. This should currently be fixed in trunk.

Changed in software-center (Ubuntu):
status: New → Fix Committed
Kiwinote (kiwinote) wrote :

fix released in s-c 3.1.1

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers