packages from canonical partner do not show up if "use this source" is clicked

Bug #666956 reported by Michael Vogt on 2010-10-26
114
This bug affects 19 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: software-center

For packages from canonical partner clicking on "use this source" has no visible effect. The reason is that
the "reload" that is done after the repository is added expects a file in sources.list.d - but the partner repo
is available in the main sources.list and will just be enabled there.

Test case:
1. use a fresh maverick sources.list (and make a copy of this for later)
2. open software-center and click on "partner" channel
3. click on any item and go to the details view there
4. click on "use this source"
5. verify that it flickers but has no further effect

6. install software-center from maverick-proposed
7. repear steps 1-5 (including restoring sources.list)
8. verify that clicking on "use this source" make the app description appear

Michael Vogt (mvo) on 2010-10-26
Changed in software-center (Ubuntu Natty):
status: New → In Progress
Changed in software-center (Ubuntu Maverick):
status: New → Fix Committed
Michael Vogt (mvo) on 2010-10-26
Changed in software-center (Ubuntu Natty):
status: In Progress → Fix Committed

Accepted software-center into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I tested per the procedure in the description and have verified that this bug has been fixed in the version of Software Center (3.0.6) in -proposed.

tags: added: verification-done
removed: verification-needed
Dmitry Shachnev (mitya57) wrote :

I didn't have any partner repository at all. When I tried to run "xdg-open apt:acroread?channel=maverick-partner", apturl created an entry in sources.list.d/maverick=partner.list. Packages of this list are visible via synaptic, but they *are not displayed* in Software Center (in "Partner" category). Is this a bug in software-center or in apturl?

Here's the file /etc/apt/sources.list.d/maverick=partner.list:
# channel for the karmic (10.10) partner channel
#
#:description:This channel contains the partner software for maverick
deb http://archive.canonical.com/ubuntu maverick partner

Also, "karmic (10.10)" seems strange.

Dmitry Shachnev (mitya57) wrote :

I was mistaken - Software center displayed these when I logged out and then logined back.

Kiwinote (kiwinote) wrote :

It would seem that bug 673991 is a consequence of the fix for this.

Martin Pitt (pitti) wrote :

Flagging as v-failed until bug 673991 gets investigated. If that is not a regression, this can be set back to v-done. Also, please fix in natty first.

tags: added: verification-failed
removed: verification-done
Gary Lasker (gary-lasker) wrote :

I am able to confirm bug 673991 and indeed it's a side-effect of the fix for this bug (thanks kiwinote!). We have a fix in progress for that one for natty and a branch for maverick as well.

Gary Lasker (gary-lasker) wrote :

Current state of things is that the fix for bug 673991 has been released for natty. I nominated that bug for maverick as well and there is an accompanying branch.

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Gary Lasker (gary-lasker) wrote :

This bug was fixed in the package software-center - 3.0.7

---------------
software-center (3.0.7) maverick-proposed; urgency=low

  [ Gary Lasker ]
  * softwarecenter/backend/aptd.py:
    - fix crash during reload (LP: #673991)
 -- Michael Vogt <email address hidden> Thu, 02 Dec 2010 20:37:29 +0100

Changed in software-center (Ubuntu Maverick):
status: Fix Committed → Fix Released
StephanBeal (sgbeal) wrote :

If this was fixed in 3.0.7 then it's broken again in 3.0.8. i'm seeing this now on a machine i back-revved from 11.04.

However... as a last-ditch effort i ran 'apt-get update' ... upgrade after leaving the Software Center and flash got installed. i did a lot of tinkering/trying, so i can't say what finally forced it to install.

Amos Blanton (lightnin9) wrote :

Seeing this in fresh install of Oneiric. To reproduce:
Search for skype.
Select use this source.
Authenticate (failed once, but shouldn't matter)
Select more info on skype because install still not an option.
Software center says it can't find skype.
workaround: apt-get update in terminal. Close / reopen software center.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers