software-center tries to open a GUI on version upgrade

Bug #665659 reported by Daniel Richard G. on 2010-10-23
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

LATEST VERSION TESTED: 3.1.26.1

Binary package hint: software-center

I saw the following, when upgrading software-center while SSH'ed in remotely:

Setting up software-center (3.0.5) ...
X11 connection rejected because of wrong authentication.
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)

My DISPLAY variable is set, but XAUTHORITY is not (since the apt-get(8) invocation is running as root via sudo).

The software-center upgrade script(s) should not be making any use of X11 whatsoever, whether DISPLAY is set or not.

Micah Gersten (micahg) wrote :

Just got this today as well:
Setting up software-center (3.1.26.1) ...
No protocol specified
/usr/lib/pymodules/python2.7/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
Updating software catalog...this may take a moment.
Software catalog update was successful.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: maverick natty
summary: - X11 authentication warnings on upgrade
+ software-center tries to open a GUI on version upgrade
dino99 (9d9) wrote :

natty have reached EOL now ; closing that report. Feel free to report against a newer version if needed, with ubuntu-bug

Changed in software-center (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers