The Software Center contains no information about minimum requirements

Bug #665249 reported by Nicholas Christian Langkjær Ipsen on 2010-10-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
software-center (Ubuntu)
High
Michael Vogt

Bug Description

software-center 3.0.4, Ubuntu 10.10

Ubuntu Software Center contains no information about minimum hardware requirements for the listed applications.
This is not usually a problem, since most of the software is free, and can easily be uninstalled if ones computer can't handle. However, with the introduction of commercial software, one can be in a situation where the software one has purchased will not run properly on one's hardware.

For instance, I recently purchased the game Brukkon. An excellent game, I'm sure, but it is unplayable on my netbook, and I had no way to know that my netbook wasn't powerful enough.
I also own a desktop machine, so I can enjoy the game there, but some people may only own a netbook, or an old laptop, or maybe there will soon be games in the Software Center with much higher hardware requirements.

For this reason, I suggest that it should be a requirement for all commercial software that wants to get into the Software Center to list its minimum hardware requirements in the description.

Client specification: https://wiki.ubuntu.com/SoftwareCenter#hardware

Confirming (though it probably will be set to a reasonably important wishlist item)

Changed in software-center (Ubuntu):
status: New → Confirmed

This is not a papercut, but a feature request. I'd move it if I knew how.

To solve this, it would take each program maintainer in the software center to test and publish system requirements, which would take months at best. As for commercial software, I would agree, but this doesn't affect basically anyone right now (with a total of 2 commercial programs available).

I'd say that it's better to get it done now exactly because there aren't
many applications in the store yet. Makes it way easier to do.

From the wiki:

A new feature is not a paper cut; a paper cut is a problem with an existing piece of functionality, not a new piece of functionality. If a bug involves adding something to an interface (e.g. a new button), it's probably a new feature and not a paper cut.

Changed in hundredpapercuts:
status: New → Invalid
Vish (vish) on 2010-11-10
Changed in software-center (Ubuntu):
importance: Undecided → Wishlist
Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Wishlist → High
Matthew Paul Thomas (mpt) wrote :

Thanks for the suggestion, Nicholas. We'd like to implement this for 12.04.

Probably this will involve:
- implementing debtags in Launchpad (bug 57418)
- devising a debtags schema for hardware requirements (e.g. "requires-hardware::gl-level1")
- designing and implementing a Web interface in myapps.developer.ubuntu.com for specifying those requirements
- implementing an API for software-center-agent to transmit a commercial package's debtags to USC
- designing and implementing how USC (in minor cases) warns about, or (in major cases) doesn't offer, applications with requirements your machine doesn't meet
- designing and implementing what happens when the requirements change for the next version of an application you have installed.

Thank you very much for responding Matthew. I'm glad to see that this issue
will finally be solved, especially with the recent influx of commercial
software.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Matthew Paul Thomas (mpt) wrote :

I've completed a specification for how to present the requirements in USC. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=596&rev1=595>

Changed in software-center (Ubuntu):
status: In Progress → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
description: updated
Michael Vogt (mvo) wrote :

The hardware requirements (for apps that support setting them) is updated now.

Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
assignee: nobody → Michael Vogt (mvo)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers