software-center crashed with DBusException in call_blocking()

Bug #657494 reported by Daniel Clem on 2010-10-09
166
This bug affects 27 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Binary package hint: software-center

I tried installing Google chrome and it just does not do anything when I press install.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.2
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sat Oct 9 23:05:17 2010
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate i386 (20100928)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /tmp/google-chrome-stable_current_i386.deb
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/tmp/google-chrome-stable_current_i386.deb']
SourcePackage: software-center
Title: software-center crashed with DBusException in call_blocking()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Daniel Clem (clem11388) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Victor Vargas (kamus) wrote :

Daniel, Please could you check if this behaviour is still occurring in latest release of software-center included in Ubuntu Maverick? Thanks!

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Daniel Clem (clem11388) wrote :

I got an email asking me to check if this bug is still affecting me after the latest updates, but I can't check it for 2 reasons, It was happening when I was using a Ubuntu Live USB stick and downloading and updating to the lastest patches would fill up the space on the stick so I never can update it, and even if I could, I kept that USB stick in my wallet and I recently lost my wallet!! really ticked me off actually cause those came in handy sometimes for diagnostic purposes or making a Dead computer come back to life.

Reinhard Tartler (siretart) wrote :

as seen in the duplicate bug #720604, this issue is still present in current natty

Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
tags: added: bugpattern-needed
tags: added: bugpattern-written
removed: bugpattern-needed
Senol Ozkan (snlzkn-gmail) wrote :

I have natty running with Unity. When I selected software-center from the Unity applications list nothing happened. Then I wrote software-center and it said it was not installed :S I installed it and I ran it. It opened up but when I typed in phpmyadmin, it crashed before showing any results.

Senol Ozkan (snlzkn-gmail) wrote :

Now whenever I try to run it it crashes immediately. In the terminal it gives these messages, repeatedly

 File "/usr/share/software-center/softwarecenter/models/appstore.py", line 428, in on_get_value
    app = Application(appname, pkgname)
  File "/usr/share/software-center/softwarecenter/db/application.py", line 47, in __init__
    raise ValueError("Need either appname or pkgname or request")
ValueError: Need either appname or pkgname or request
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 562, in do_render
    direction)
  File "/usr/share/software-center/softwarecenter/view/appview.py", line 336, in _render_icon
    xo = (self.pixbuf_width - self.pixbuf.get_width())/2
AttributeError: 'NoneType' object has no attribute 'get_width'

Tony Mugan (tmugan) wrote :

I tried to install the latest 64-bit deb from Google for Chrome browser and got an error popup which I did not record (sorry) that was complaining about the package structure I think.
The package did not install correctly.

Then I tried again and got the same error logged above.

Then I tried to launch software-center with root privileges to see if there were any errors visible in the terminal.
software-center reported that it needed to repair something which I acknowledged and then Chrome was installed. (said something about dependencies).

Not sure if it is of any use but the terminal showed this for that last run with sudo privileges.

me@pcname:~/Downloads$ sudo software-center
2011-03-26 08:30:04,431 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 154, 'open')'
2011-03-26 08:30:04,431 - root - WARNING - failed to add sca db Couldn't stat '/root/.cache/software-center/software-center-agent.db' (No such file or directory)
/usr/share/software-center/softwarecenter/app.py:1119: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  self.window_main.show_all()
2011-03-26 08:30:04,734 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/pymodules/python2.7/zeitgeist/client.py', 367, 'reconnect_monitors')'
2011-03-26 08:30:04,734 - zeitgeist.client - INFO - Reconnected to Zeitgeist engine...
/usr/share/software-center/softwarecenter/SimpleGtkbuilderApp.py:50: Warning: g_object_set_qdata: assertion `G_IS_OBJECT (object)' failed
  gtk.main()
2011-03-26 08:30:06,836 - softwarecenter.backend.scagent - WARNING - error in query_info 'Operation not supported'
2011-03-26 08:30:06,836 - softwarecenter.db.update - WARNING - error: Operation not supported
2011-03-26 08:30:07,160 - softwarecenter.app - INFO - software-center-agent finished with status 1
2011-03-26 08:30:19,109 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/db/database.py', 154, 'open')'
2011-03-26 08:30:19,109 - root - WARNING - failed to add sca db Couldn't stat '/root/.cache/software-center/software-center-agent.db' (No such file or directory)

Tony Mugan (tmugan) wrote :
Download full text (11.5 KiB)

Ok, I have manged to reproduce on another machine.

When trying to install the 64 bit deb for Chrome, software-center pops up a dialog with the following info...

The package is of bad quality

The installation of a package which violates the quality standards isn't allowed. This could cause serious problems on your computer. Please contact the person or organisation who provided this package file and include the details beneath.

Details

Lintian check results for /home/tony/Downloads/google-chrome-stable_current_amd64.deb:
W: google-chrome-stable: extended-description-line-too-long

E: google-chrome-stable: file-in-etc-not-marked-as-conffile /etc/cron.daily/google-chrome

Can't call method "data" on an undefined value at /usr/share/lintian/checks/deb-format line 63.

internal error: cannot run deb_format check on package google-chrome-stable

warning: skipping check of binary package google-chrome-stable

md5sum: ./opt/google/chrome/chrome-sandbox: No such file or directory

md5sum: ./opt/google/chrome/chrome.pak: No such file or directory

md5sum: ./opt/google/chrome/default-app-block: No such file or directory

md5sum: ./opt/google/chrome/google-chrome: No such file or directory

md5sum: ./opt/google/chrome/google-chrome.desktop: No such file or directory

md5sum: ./opt/google/chrome/libffmpegsumo.so: No such file or directory

md5sum: ./opt/google/chrome/libpdf.so: No such file or directory

md5sum: ./opt/google/chrome/libppGoogleNaClPluginChrome.so: No such file or directory

md5sum: ./opt/google/chrome/locales/am.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/ar.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/bg.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/bn.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/ca.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/cs.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/da.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/de.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/el.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/en-GB.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/en-US.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/es-419.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/es.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/et.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/fa.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/fi.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/fil.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/fr.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/gu.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/he.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/hi.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/hr.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/hu.pak: No such file or directory

md5sum: ./opt/google/chrome/locales/id.pak: No s...

Tony Mugan (tmugan) wrote :

After the error above I close software-center and run the following command line

tony@mugant-natty:~/Downloads$ sudo dpkg -i google-chrome-stable_current_amd64.deb
Selecting previously deselected package google-chrome-stable.
(Reading database ... 133523 files and directories currently installed.)
Unpacking google-chrome-stable (from google-chrome-stable_current_amd64.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:
 google-chrome-stable depends on libcurl3; however:
  Package libcurl3 is not installed.
dpkg: error processing google-chrome-stable (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...
Errors were encountered while processing:
 google-chrome-stable

Tony Mugan (tmugan) wrote :

Finally to rectify I rerun software center with root privileges

sudo software-center

This tells me

"Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?"

"Once Update Manager has finished the repairs, you can close it and return to the store."

(Note that it is not actually Update Manager that is running. The text may be worth fixing also.)
I then hit the repair button and it says "Repairing broken deps".

Chrome is still not installed at this point (Ithink, too late to confirm now) but I can rerun my command line and it is installed correctly without error...

tony@mugant-natty:~/Downloads$ sudo dpkg -i google-chrome-stable_current_amd64.deb
(Reading database ... 133790 files and directories currently installed.)
Preparing to replace google-chrome-stable 10.0.648.204-r79063 (using google-chrome-stable_current_amd64.deb) ...
Unpacking replacement google-chrome-stable ...
Setting up google-chrome-stable (10.0.648.204-r79063) ...
Processing triggers for man-db ...
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
debconf: falling back to frontend: Readline
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.en_US.utf8.cache...
Processing triggers for python-support ...

Scott Moser (smoser) wrote :

I'm seeing this bug in awstrial. Is there a way to avoid it? Basically, we provision an unprivileged user (no sudo access). By default the software center icon is on the launcher. People will click this icon, and see a crash notification, it is a very bad first impression of Ubuntu.

tags: added: awstrial
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.26.3

---------------
software-center (3.1.26.3) natty; urgency=low

  [ Michael Vogt ]
  * softwarecenter/db/reviews.py:
    - do not crash on multiple origins for the same version
      (LP: #756415)
  * softwarecenter/db/application.py:
    - ensure docid is updated on database reopen() (LP: #757054)
  * softwarecenter/models/appstore.py:
    - refresh docids in active searches if the database is reopend
      (LP: #710920)
  * softwarecenter/backend/aptd.py:
    - do not run update-apt-xapian-index in --update mode to avoid
      in-place database modfications (LP: #507836)
  * test/test_load_icons.py:
    - add test for the icon loader
  * merged lp:~glatzor/software-center/force-bad-quality, this
    fixes the missing ability to override the lintian warning
    (LP: #712377)
  * don't show reviews if we can't determine the origin
  * fix crash when enabling new components (LP: #636429)
  * fix missing details when a channel or a component just got added

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - temporarily disable the deauth option until we have support
      for remove repository in aptdaemon (see LP: #723911)
  * softwarecenter/backend/aptd.py :
    - fix empty error dialog for the case where aptdaemon returns
      an error code with no value (LP: #747172)
    - fix intermittent crash when updating the a-x-i (LP: #657494)
  * softwarecenter/models/viewswitcherlist.py:
    - mark string "In Progress..." for translation, many thanks to
      Hendrik Knackstedt and Florian Greinus for finding this
      (LP: #759240)
  * softwarecenter/view/catview_gtk.py:
    - fix broken translation string (LP: #758656)
  * refresh .pot file
  * softwarecenter/db/update.py:
    - fix crash when reinstalling previous purchases (LP: #760353)
 -- Michael Vogt <email address hidden> Thu, 14 Apr 2011 19:59:42 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers