Software centre won't close and uses 100% of one CPU

Bug #656381 reported by Vadim Peretokin on 2010-10-07
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

I added the ppa from here: http://owaislone.org/blog/2010/sep/update-gmailwatcher/ then went to software centre to install a package. Installed the extras package, couldn't install the main one because even though the button was clickable, it gave me an error that the package is already installed.

Tried using File-Close to close it - it still has not closed and is using 100% of one CPU.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.4
ProcVersionSignature: Ubuntu 2.6.35-power+18.24~lucid-generic 2.6.35.3
Uname: Linux 2.6.35-power+18-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Oct 7 12:13:25 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_CA.utf8
 SHELL=/bin/bash
SourcePackage: software-center

Vadim Peretokin (vperetokin) wrote :
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Omer Akram (om26er) wrote :

these type of corner cases are usually very difficult to reproduce or debug. so a few steps are really necessary.

Vadim Peretokin (vperetokin) wrote :

To be honest the quality of the centre degraded so much that it's even hard to get it back to a clear state to reproduce the issue. I tried removing the PPA, installing the .deb - it worked then. Added the PPA so I could install other things from the that PPA - they were not showing up at all, and the PPA was not showing up in the listing at all. I've filed it as a separate report (https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/656972) with a screencast demonstrating the issues.

Launchpad Janitor (janitor) wrote :

[Expired for software-center (Ubuntu) because there has been no activity for 60 days.]

Changed in software-center (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers