apturls launched via alt+F2 do not work

Bug #653889 reported by ChrisLees on 2010-10-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote
Maverick
Undecided
Unassigned
Natty
Low
Kiwinote

Bug Description

Binary package hint: software-center

When an Apt URL is clicked or entered into Alt-F2's Run dialog, Software Center opens to handle the link. However, Software Center displays the following message:

Not Found
There isn't a software package called "" in your current software sources.

Ubuntu Maverick 10.10

software-center:
  Installed: 3.0.4

What I expected to happen: Software Center displays the package information and offers to install it (or Synaptic does the same thing)

What actually happened is described above.

To reproduce this bug:

Press Alt-F2 in Gnome and type: "apt:gimp". Press Enter.

Omer Akram (om26er) wrote :

apt:gwibber worked but apt:gimp did not strange

Kiwinote (kiwinote) wrote :

Hi Chris! Thanks for this bug report - I didn't actually know that we could launch apturls from alt+F2. I'll take a look into this slightly later on. Thanks a lot for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → Low
status: New → Confirmed
Kiwinote (kiwinote) wrote :

Hi Chris! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked. It turns out that launching 'apt:gimp' via alt+F2 sends software-center the argument 'apt:///gimp'. We currently only support 'apt:gimp' and 'apt://gimp', but now I have also added 'apt:///gimp'. Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
summary: - apt urls do not work
+ apturls launched via alt+F2 do not work

Accepted software-center into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) wrote :

I confirm now it works fine.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.0.5

---------------
software-center (3.0.5) maverick-proposed; urgency=low

  [ Andrea Cimitan ]
  * fix rendering with Ambiance theme (LP: #635208)

  [ Kiwinote ]
  * softwarecenter/app.py:
    - support launching apturls via alt+F2 in gnome (LP: #653889)
  * softwarecenter/db/update.py:
    - use 'X-GNOME-FullName' rather than 'Name', when available (LP: #651260)
      (test case: software-center cheese empathy evolution gwibber)
  * softwarecenter/view/appview.py:
    - unblock pkg if transaction is cancelled (LP: #652903)
      (test case: launch s-c with a list view, choose a pkg, click install,
       cancel auth, click install again, install should work as normal)
  * softwarecenter/view/availablepane.py:
    - don't show 'hide 1 technical item' in featured category (LP: #651236)
      (test case: browse to featured category (by clicking 'all'))
    - don't show 'hide technical items' in system category, as we don't
      have any apps to show (LP: #636854)
      (test case: browse to 'System' category)
  * softwarecenter/view/historypane.py:
    - correctly split pkgnames for pkg transactions dated before 28-ish July
      (LP: #651241)
      (test case: view transaction in history pane dated pre 28 July)
  * softwarecenter/view/viewswitcher.py:
    - emit 'transactions-changed' signal after connecting to the backend so
      that we display any pending transactions (LP: #652927)
      (see bug report for test case)

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - use keyserver.ubuntu.com on port 80 by default to avoid problems
      on machines that filter the port 11371
  * softwarecenter/backend/restfulclient.py, softwarecenter/enums.py:
    - use plain http for the "what-is-available" API call
  * send user default language for "/apps" and "/subscription" requests
    now that the server is ready for this
 -- Michael Vogt <email address hidden> Wed, 13 Oct 2010 16:13:10 +0200

Changed in software-center (Ubuntu Maverick):
status: Fix Committed → Fix Released
Kiwinote (kiwinote) on 2010-10-20
Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers