software-center crashed with IOError in _open()

Bug #652151 reported by Colin Mills on 2010-09-30
440
This bug affects 77 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Maverick
High
Michael Vogt

Bug Description

Binary package hint: software-center

I am unable to open the Ubuntu Software Centre. I get the following message:-
"Sorry, Ubuntu Software Centre closed unexpectedly"

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 3.0.3
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 30 16:44:05 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release Candidate amd64 (20100928)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /tmp/streamtuner2-2.0.8.deb
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/tmp/streamtuner2-2.0.8.deb']
SourcePackage: software-center
Title: software-center crashed with IOError in _open()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Colin Mills (cm006a5077) wrote :
tags: removed: need-duplicate-check
tags: added: bugpattern-needed
visibility: private → public
Screatch (screatch) wrote :

This is what worked for me.
sudo chown -R yourusername:yourusername .cache .config
Must be executed in your home directory.

After this, Ubuntu software center seems to load properly.

jarondl (jarondl) wrote :

Thanks Screatch, worked for me too.

Michael Vogt (mvo) wrote :

Some clues here:
https://bugs.edge.launchpad.net/ubuntu/+source/software-center/+bug/652531/comments/4

Looks like ~/.cache/software-center got created as root.root somewhoe.

Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
milestone: none → ubuntu-10.10
Michael Vogt (mvo) wrote :

The ~/.cache/software-center directory gets created as root by "update-software-center" *if* the user upgrades via sudo (and sudo keeps $HOME). The problem is in the softwarecenter/paths.py that creates the cache directory if it does not exist.

updates via update-manager are not affected!

Changed in software-center (Ubuntu Maverick):
assignee: nobody → Michael Vogt (mvo)
status: Confirmed → In Progress
Jelle De Loecker (skerit) wrote :

Not quite true: I upgraded using "sudo update-manager -d" and still had this problem.
Running the chown command mentioned above fixed it.

Thanks Screatch, worked for me too.

Kristian Rink (kawazu) wrote :

@Michael Vogt: Thanks, the chown - solution does indeed fix things.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.0.4

---------------
software-center (3.0.4) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/appview.py:
    - fix intermittent crash in _set_cursor (LP: #617004)

  [ Michael Vogt ]
  * Create the log directory not on the import paths.py. Otherwise
    if the user upgrades using a sudo based tool (like apt-get) he
    may end up with a root owned log (LP: #652151)
  * softwarecenter/paths.py
    - ensure we don't create directories in /home when running as
      root
    - When detecting a not writable cache dir, try to remove it
      so that it gets re-created later with the right permissions.
      That will undo the damage in bug LP: #652151
 -- Michael Vogt <email address hidden> Fri, 01 Oct 2010 10:40:08 +0200

Changed in software-center (Ubuntu Maverick):
status: In Progress → Fix Released
To post a comment you must log in.