using an apturl source that also enables a PPA pops up an "Untrusted Packages" message when installing from the PPA

Bug #645120 reported by Oliver Grawert on 2010-09-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Maverick
High
Michael Vogt

Bug Description

Binary package hint: software-center

After enabling a PPA via apturl (which works fine for the ti-omap4-ppa now) when i try to install a package from this PPA the following message pops up:

Requires installation of untrusted packages
The action would require the installation of packages from not authenticated sources.
...
the details window shows: libtitiler-memmgr0 titiler-memmgr-tests

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.22.4
ProcVersionSignature: Ubuntu 2.6.35-903.12-omap4 2.6.35.3
Uname: Linux 2.6.35-903-omap4 armv7l
Architecture: armel
Date: Wed Sep 22 13:15:28 2010
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Oliver Grawert (ogra) wrote :
Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
importance: Undecided → High
Changed in software-center (Ubuntu Maverick):
milestone: none → ubuntu-10.10
Michael Vogt (mvo) on 2010-09-22
Changed in software-center (Ubuntu Maverick):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

dismissing the error message gets me back to the package screen, clicking the install button just pops up the error again but never installs.

Michael Vogt (mvo) on 2010-09-22
Changed in software-center (Ubuntu Maverick):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.0

---------------
software-center (3.0) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/restfulclient.py:
    - setup cachedir to avoid unneeded wadl downloading (LP: #645837)
  * softwarecenter/utils.py:
    - fix crash if desktop_file_path does not contain "applications"
      (LP: #641071)
  * softwarecenter/backend/aptd.py:
    - add keyfile for whitelisted channel (LP: #645120)
  * softwarecenter/view/appdetailsview.py:
    - fix crash when reinstalling previous purchase
      (LP: #645843)
  * softwarecenter/backend/restfulclient.py, softwarecenter/db/update.py,
    - use gio instead of restfulclient to get the available purchase
      items and properly use the etag values provided to avoid uneeded
      bandwidth usage and load on the server (LP: #645837)
  * utils/update-software-center-agent:
    - trivial logging fix to make --debug fully work
  * debian/changelog:
    - its 3.0!

  [ Gary Lasker ]
  * softwarecenter/app.py,
    softwarecenter/backend/channel.py:
    - fix multiple instances of the "Previous Purchases"
      item in the left navigation pane (LP: #645439)
  * README:
    - fix typo
 -- Michael Vogt <email address hidden> Thu, 23 Sep 2010 11:16:44 +0200

Changed in software-center (Ubuntu Maverick):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers