Incorrect title and summary for non-application packages

Bug #636004 reported by Matthew Paul Thomas on 2010-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Ubuntu Software Center 2.1.18.1, Ubuntu Maverick

1. Navigate to "Get Software" > "System" > "A Better CD Encoder" (abcde), and choose "More Info".

What you see:
* The last item in the path button is "Abcde".
* The main heading is "abcde".
* The text immediately below the main heading is "A Better CD Encoder".
* The "Add-ons" checkboxes are labelled:
    - "Mkcue (mkcue)"
    - "Mp3gain (mp3gain)"
    - "Id3v2 (id3v2)"
    - "Eyed3 (eyed3)"
    etc.

What you should see:
* The last item in the path button is "A Better CD Encoder".
    <https://wiki.ubuntu.com/SoftwareCenter#get-software-item>
    <https://wiki.ubuntu.com/SoftwareCenter#software-title>
* The main heading is "A Better CD Encoder".
    <https://wiki.ubuntu.com/SoftwareCenter#software-item-screen>
* The text immediately below the main heading is "abcde".
    <https://wiki.ubuntu.com/SoftwareCenter#software-summary>
* The "Add-ons" checkboxes are labelled:
    - "Generates a CUE sheet from a CD (mkcue)"
    - "A GUI for mp3gain, vorbisgain and aacgain (mp3gain)"
    - "A command line id3v2 tag editor (id3v2)"
    - "Display and manipulate id3-tags on the command-line (eyed3)"
    etc.

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

(Reported bug 636014 on the bad synopsis for xul-ext-flashgot.)

Kiwinote (kiwinote) wrote :

Afaics this is a consequence of the 'fix' that was applied for bug 634678, the regression is also visible in the title/subtitles in normal app detail screens.

Matthew Paul Thomas (mpt) wrote :

Ah, I see, this is a general problem with the title generation for non-application packages. Ok, resummarizing.

description: updated
summary: - Package name inappropriately used for add-on checkbox labels
+ Incorrect title and summary for non-application packages
Changed in software-center (Ubuntu):
status: New → Triaged
Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

The linked branch should take care of the issues listed in this report (see attached screenshot below). Further details can be found in the merge proposal.

Gary Lasker (gary-lasker) wrote :
Kiwinote (kiwinote) wrote :

Hi. I see that on irc there was a slight discussion as to what was causing this. The specific issue that is causing the wrong title/subtitle in the appdetailsview and for the addons is the change to softwarecenter/db/database.py at http://bazaar.launchpad.net/~software-store-developers/software-center/trunk/revision/1154 . The revision caused get_appname() to return an appname even when there is no appname. The code in softwarecenter/db/application.py relies on get_appname returning None when there is no appname. I have fixed get_appname() to return None in my branch, which will restore the correct title/subtitle and addon names in the appdetails view.

The issue with the wrong name in the navigation bar was there before the revision mentioned above and is still present after the change I've just made. Cheers.

Gary Lasker (gary-lasker) wrote :

Hi kiwinote! Yes, thanks, I noticed that broken return of None and had fixed it in my branch linked above. Sorry, it appears we double-debugged it! :)

Indeed, it was part of my checkin as you referenced above where the regression crept in. Doh!

In any case, I've simplified and consolidated the code in the attached branch and wired all of the places in the UI that displays title and summary to use a single point of origin for this info. Hopefully this will take care of it for good (it appears to work well in my testing). If you have time, I'd certainly appreciate your taking a look at the proposed merge to see if there's anything I missed.

Thanks!

Kiwinote (kiwinote) wrote :

Hi Gary!
Eugh, sorry I didn't notice that you had already fixed that in the branch!
Anyway, I've tested the branch and made a few changes so it works well with apturls/deb files as well.
The rest all looks quite sweet :)
Thanks for your work on this!

Gary Lasker (gary-lasker) wrote :

Excellent, thank you kiwinote! I merged your fixes back into the linked branch and now it should be well-ready for review.

Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Changed in software-center (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers