Inconsistent package state error message is misleading

Bug #635101 reported by Matthew Paul Thomas on 2010-09-10
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Medium
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu Software Center 2.1.18, Ubuntu Maverick
Ubuntu Software Center 5.4.1.2, Ubuntu 12.10

Based on test case <https://wiki.ubuntu.com/SoftwarePackageOperations#broken>:

1. sudo apt-get install 4g8 && sudo dpkg --force-depends -r libnet1
2. Launch Ubuntu Software Center.

(When finished testing, reset if necessary with "sudo apt-get remove 4g8 libnet1".)

What happens: An alert appears, "Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?" "Once Update Manager has finished the repairs, you can close it and return to the store." (Or in later versions, "the Software Center" [sic]).

What should happen: "If software can’t be installed because existing software has broken or unsatisfied dependencies, a confirmation alert should appear. It should have primary text 'New software can’t be installed, because there is a problem with the software currently installed. Do you want to repair this problem now?'"

Related branches

Changed in software-center (Ubuntu):
milestone: none → later
importance: Undecided → Low
Sebastian Heinlein (glatzor) wrote :

Talking about rebuilding here is incorrect. Additional software need to be installed or removed. This is not just a rebuild. The resolver of apt isn't always perfect and people like to mix repositories - so this action could result in removing or installing a large amount of packages. In the end you would also need a dependency confirmation dialog here. Otherwise you risk breaking the system of the user silently.

Changed in aptdaemon:
status: New → Opinion
Matthew Paul Thomas (mpt) wrote :

Thanks for pointing that out, Sebastian -- I had the two states muddled. With help from Michael, I've now corrected the specification. "Some software is not installed correctly, and may not run properly. You need to authenticate to repair the installation." Is that reasonable?

description: updated
Changed in aptdaemon:
status: Opinion → New
description: updated
Changed in aptdaemon:
status: New → Confirmed
importance: Undecided → Medium
ricardisimo (ricardisimo) wrote :

It just happened to me, over and over again, while trying to install Mistelix (it installed properly, so far as I can tell). I'm on Maverick, fully updated.

Changed in software-center (Ubuntu):
importance: Low → Medium
milestone: later → none
status: New → Triaged
description: updated
description: updated
Sebastian Heinlein (glatzor) wrote :

I have got a bad feeling about using the authentication dialog as a confirmation dialog. If the system is configured to allow all package operations to an user automatically you won't get any confirmation at all. The operation would just start.

The broken cache is really a nasty problem that needs to be fixed before you can continue installing/removing any other software. So a small icon is not very discoverable. Why don't you show an in-app-notifcation below the toolbar with a small text and a button "Repair system".

Changed in software-center (Ubuntu):
status: Triaged → Confirmed
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in aptdaemon:
status: Confirmed → In Progress
Adolfo Jayme (fitojb) on 2012-06-19
Changed in aptdaemon:
status: In Progress → Confirmed
Matthew Paul Thomas (mpt) wrote :

Sebastian, fair enough, thanks. I've separated the confirmation alert from the PolicyKit alert in the design, and specified that it should block any software installation. Would you be able to move the confirmation alert out of USC into Aptdaemon and update the design?

description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
assignee: Matthew Paul Thomas (mpt) → nobody
description: updated
summary: - Broken apt cache error message is out of date
+ Inconsistent package state error message is misleading
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.5.1.1

---------------
software-center (5.5.1.1) raring; urgency=low

  * Fix FTBFS in the clean target by build-depending on python-dbus,
    python-aptdaemon, python-gi, python-xapian, and python-xdg.
 -- Adam Conrad <email address hidden> Wed, 28 Nov 2012 19:08:21 -0700

Changed in software-center (Ubuntu):
status: Triaged → Fix Released

This has been fixed a long time ago. To be sure, I checked it again in 14.04, and I get the following behavour:

a confirmation alert appears. It has the text 'New software can’t be installed, because there is a problem with the software currently installed. Do you want to repair this problem now?'"

Changed in aptdaemon:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers