software-center crashed with AttributeError in _update_action_bar_buttons()

Bug #635044 reported by Matthew Paul Thomas on 2010-09-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

1. From "Get Software", search for "gobby,gnome-orca,9base" (without quotes)
2. Leave it for a few minutes. The crash recurs every few minutes after that.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.18
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic i686
Architecture: i386
Date: Fri Sep 10 16:46:17 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100910)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with AttributeError in _update_action_bar_buttons()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Matthew Paul Thomas (mpt) wrote :
description: updated
visibility: private → public
Changed in software-center (Ubuntu):
status: New → Confirmed
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Low
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
tags: removed: need-duplicate-check
Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers