"Canonical Partners" is off by default

Bug #635003 reported by Matthew Paul Thomas on 2010-09-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker

Bug Description

Ubuntu Maverick daily 20100910

1. Install Ubuntu from scratch.
2. Launch Ubuntu Software Center and expand the "Get Software" item.

What you should see: "Provided by Ubuntu", followed by "Canonical Partners".
What you actually see: "Provided by Ubuntu" is there, but "Canonical Partners" is not.

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → High
Kiwinote (kiwinote) wrote :

Hi mpt! Do you mind checking if the canonical-partners channel is enabled (ie not commented out in a sources.list file), or if it is only whitelisted (ie commented out in a sources.list file) in a default install? Thanks

Matthew Paul Thomas (mpt) wrote :

/etc/apt/sources.list contains this section:
------------
## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu maverick partner
# deb-src http://archive.canonical.com/ubuntu maverick partner
------------

So I guess this is a bug in apt-setup, not software-center.

affects: software-center (Ubuntu) → apt-setup (Ubuntu)
description: updated
summary: - "Canonical Partners" is missing
+ "Canonical Partners" is off by default
description: updated
Colin Watson (cjwatson) wrote :

This is a deliberate change in policy, right? It was intentionally off by default originally, and you're going to have to cope in software-center since it'll be off on many upgraded systems.

Changed in apt-setup (Ubuntu):
status: New → Confirmed
assignee: nobody → Gary Lasker (gary-lasker)
Gary Lasker (gary-lasker) wrote :

Hey mpt and Colin. This is indeed a regression in Software Center. Software Center should *always* display the Canonical Partners item, even in the case where the repository source is disabled. This allows users to browse items in the repository and they are then given the opportunity to enable the repository from within the details view for a software item if they choose to.

I'm testing a fix now.

affects: apt-setup (Ubuntu) → software-center (Ubuntu)
Changed in software-center (Ubuntu):
milestone: none → ubuntu-10.10
description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
jimbo1qaz (jimbo1qaz) wrote :

WHAT??????????? This change only just happened to me, and I don't think I like it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers