Can't focus "Install"/"Remove" button with the keyboard in a software list view

Bug #634952 reported by Matthew Paul Thomas on 2010-09-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

Ubuntu Software Center 2.1.18, Ubuntu Maverick
Ubuntu Software Center 5.4.1.2, Ubuntu 12.10

This may be two or three separate bugs that can be fixed separately, but they are too intertwined to report separately.

Test case: (usc-005) <https://wiki.ubuntu.com/SoftwareCenter#software-list-view>
1. Navigate to “All Software” > “Universal Access”.
2. Select something that isn't installed, such as "Indic Onscreen Keyboard".
3. Press Ctrl F.
4. Press Tab twice.
5. Press Tab once more.
6. Press Enter.

What happens:
2. The selected row is colored.
3. The selected row remains colored while the search field is focused.
4. The search field is unfocused.
5. Apparently nothing.
6. USC returns to the home screen.

What should happen:
2. The selected row is colored, and the "More Info" button gets a focus ring.
3. The selected row is greyed out while the search field is focused.
4. The selected row resumes its color, and the "More Info" button.
5. The focus ring moves from the "More Info" button to the "Install" button.
6. Installation begins.

Low importance, because you can install or remove the item from either the software item screen or the "File" menu.

Changed in software-center (Ubuntu):
importance: Undecided → Low
Andrew Hayzen (ahayzen) wrote :

Hi

I have followed the steps provided by Matthew and I can reproduce this with software center 3.0.5 on maverick, therefore I have set the bug as confirmed.

Andy

Changed in software-center (Ubuntu):
status: New → Confirmed
description: updated
Gary Lasker (gary-lasker) wrote :

Hi mpt, with the new design the operation is a bit different, and possibly ok (though the spec will have to be updated if you deem this new behavior correct). So, after following your steps to reproduce, pressing tab once focuses the *sorting* options. A second press of the tab button correctly focuses the "More Info" button in the selected row.

If this behavior is ok, please set this as fix released and I guess we should make the spec update to match.

Thanks!

Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
status: Confirmed → Incomplete
description: updated
Changed in software-center (Ubuntu):
status: Incomplete → Confirmed
assignee: Matthew Paul Thomas (mpt) → nobody
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers