"Provided by Ubuntu" view shows non-apps when selected

Bug #630631 reported by Gary Lasker on 2010-09-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

Ubuntu Software Center 2.1.15, Ubuntu Maverick

Under certain conditions, selecting the "Provided by Ubuntu" item in the left navigation pane "Get Software" section will display non-apps by default when selected. The result is in unnecessarily long delay when generating the list for display.

To reproduce:

1. Open Software Center and expand the "Get Software" and "Installed Software" views in the left navigation pane.
2. Select the "Provided by Ubuntu" subitem of the "Get Software" item.
3. Note that the list appears relatively quickly, and that non-app packages are hidden by default as evidenced by the text "Show nnn technical items" in the status panel below.
4. Now select the "Provided by Ubuntu" subitem of the "Installed View" node and wait for the list to be displayed (this node currently has a long delay before displaying, see bug 556375).
5. Again, select the "Provided by Ubuntu" subitem of the "Get Software" node.

What happens:

This time, there is a long delay before the list is displayed, and non-apps are displayed by default as evidenced by the text "Hide nnn technical items" in the status panel below.

What should happen:

The list should appear quickly and non-apps should be hidden by default, as in step 2 above.

Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
description: updated
description: updated
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.1 KiB)

This bug was fixed in the package software-center - 2.1.16

---------------
software-center (2.1.16) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/purchasedialog.py:
    - make the "Terms of Service" popup display correctly in
      front of the purchase dialog (LP: #625398)
    - tweak the width of the purchase dialog window to
      accomodate the current Ubuntu SSO page width
  * softwarecenter/view/channelpane.py:
    - always default to hiding non-app packages when
      selecting a new channel item in the left navigation
      pane (LP: #630631)
  * softwarecenter/view/softwarepane.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/channelpane.py
    softwarecenter/view/installedpane.py:
    - display a spinner while loading an applist view
      (LP: #630641)

  [ Michael Vogt ]
  * remove debug output
  * merged lp:~mmcg069/software-center/small-fix (many thanks!)
    - prevents the exposure of the carousel icons before they have
      been allocated.
  * verify sortmode when building categories (LP: #618411) and
    ignore categories with unknown/unsupported ones
  * merged lp:~mmcg069/software-center/cleanup-software-section-code
    that fixes LP: #624786 (many thanks)
  * make sure there is always a toplevel transaction for a pending
    purchase even if s-c waits for the for-pay repository to become
    available (LP: #627608)
  * softwarecenter/view/purchasedialog.py:
    - support both "failure_reason" and "failures" as error strings
      from the agent
  * merged lp:~mmcg069/software-center/Bug617443 (LP: #617443)
  * merged lp:~mmcg069/software-center/bug628714 (LP: #628714)
  * merged lp:~mmcg069/software-center/hover-highlight-tweaks to
    use correct prelight color

  [ Kiwinote ]
  * data/featured.menu.in:
    - fretsonfire instead of fretsonfire-game, due to desktop file changes
  * data/software-center.menu.in:
    - use correct icon for system category, thanks vish!
  * softwarecenter/apt/aptcache.py:
    - don't crash on broken dependencies (LP: #630579)
      (testcase: acl2-books)
  * softwarecenter/db/application.py:
    - set pkgname for deb files correctly (LP: #628787)
      (testcase: replace _ with - in filename of an outdated deb file of s-c)
  * softwarecenter/view/appdetailsview_gtk.py:
    - never display the description of a different pkg
      (testcase: browse to any appdetails view and then to fluendo dvd player)
    - don't crash if icon for 'where is it' is None (LP: #629845)
    - don't crash if icon for addon can not be opened (LP: #629937)
    - don't display add-ons when we have an error
      (testcase: deb file of wrong architecture)
  * softwarecenter/view/appview.py:
    - fix startup crash (LP: #618411)
  * softwarecenter/view/availablepane.py:
    - set section for subcategory view (this means that we now have a bg)
  * softwarecenter/view/installedpane.py:
    - don't return to installed overview list on reopening db
  * softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - fix visual corruption on appending pathbar part
      (testcase: channelpane > details > different channelpane > details)
 -- Michael Vogt <email address hidden> Tue, 07 Sep ...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers