software-center doesn't handle authentication errors

Bug #629132 reported by n0a3n on 2010-09-02
106
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

after launching software center

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.14.1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic-pae 2.6.35.3
Uname: Linux 2.6.35-19-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Sep 3 00:16:53 2010
ExecutablePath: /usr/share/software-center/software-center
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100823)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center /home/username/Desktop/opera_10.61.6430_i386.deb
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center', '/home/username/Desktop/opera_10.61.6430_i386.deb']
SourcePackage: software-center
Title: software-center crashed with DBusException in call_blocking()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

n0a3n (pirrottetom) wrote :
tags: removed: need-duplicate-check
Omer Akram (om26er) on 2010-10-03
visibility: private → public
Omer Akram (om26er) on 2010-10-03
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Sebastian Heinlein (glatzor) wrote :

it seems that software-center doesn't check for an authentication error.

summary: - software-center crashed with DBusException in call_blocking()
+ software-center doesn't handle authentication errors
Changed in aptdaemon:
status: New → Invalid
Gary Lasker (gary-lasker) wrote :

The last reported duplicate of this bug was back in software-center 2.1.17.2, so I will close this one. If there are any new dupes (or "also affects me", please re-open. Thanks!

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers