share button should not be visible if gwibber has no accounts set up

Bug #628714 reported by Kiwinote on 2010-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Medium
Unassigned
software-center (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: software-center

s-c 2.1.15

In the maverick version of software-center a new 'share' button was introduced that links to a gwibber-poster window. This button is displayed whenever gwibber is installed. This probably works nicely for people with accounts set up in gwibber, but everyone else (probably by far the majority of users) gets a gwibber-poster dialog that has no accounts associated to it and hence does nothing.

To bring this feature up to scratch for maverick, one of the following needs to be done:
- either s-c needs to be able to check whether accounts are associated with gwibber and only then display the 'share' link,
- or gwibber-poster needs to deal nicely with no accounts being available, ie allow users to set up accounts instead of showing a send button which does nothing.

(As a sidenote: a quick twitter search reveals that this feature has been used by two people in the last 4 days on twitter.)

Kiwinote (kiwinote) on 2010-09-02
Changed in software-center (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.10
status: New → Triaged
Matthew McGowan (mmcg069) wrote :

Hi Kiwinote,

I have pushed a possible fix, let me know what you think:

lp:~mmcg069/software-center/#628714

Matthew McGowan (mmcg069) wrote :

Sorry that branch should be lp:~mmcg069/software-center/bug628714

Kiwinote (kiwinote) wrote :

Hi Matthew, thanks for your work on this! The first time I run the branch, s-c crashes on startup (see http://paste.ubuntu.com/489237/). Any subsequent startups work fine.

Matthew McGowan (mmcg069) wrote :

I found mention on that same error in Bug #521569.

The apparent fix is to locale.setlocale(locale.LC_ALL,'en_US.utf8'). I'll give it a try tonight.

Matthew McGowan (mmcg069) wrote :

So i've made that locale change, i dont seem to get the error regardless, so if you could test and let me know the outcome.

Cheers

Kiwinote (kiwinote) wrote :

Hi Matthew! That locale change doesn't seem to help, sadly. If it helps, I reproduce this issue by killing the gwibber-service process (to bring it back to the state at initial login). Adding try-except around "return len(json.loads(Gwibber.GetAccounts())) > 0" does at least mean that s-c starts up, it still prints out 10 lines of warnings though. Cheers.

Matthew McGowan (mmcg069) wrote :

Yer, i realise the same.

I have pushed another fix. It produces some spam if gwibber-service is not alive initially but it seems to work well.

Kiwinote (kiwinote) wrote :

Yep, those latest changes now work sweetly for hiding the share button. (Haven't tested with accounts associated.) Thanks!

Launchpad Janitor (janitor) wrote :
Download full text (3.1 KiB)

This bug was fixed in the package software-center - 2.1.16

---------------
software-center (2.1.16) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/purchasedialog.py:
    - make the "Terms of Service" popup display correctly in
      front of the purchase dialog (LP: #625398)
    - tweak the width of the purchase dialog window to
      accomodate the current Ubuntu SSO page width
  * softwarecenter/view/channelpane.py:
    - always default to hiding non-app packages when
      selecting a new channel item in the left navigation
      pane (LP: #630631)
  * softwarecenter/view/softwarepane.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/channelpane.py
    softwarecenter/view/installedpane.py:
    - display a spinner while loading an applist view
      (LP: #630641)

  [ Michael Vogt ]
  * remove debug output
  * merged lp:~mmcg069/software-center/small-fix (many thanks!)
    - prevents the exposure of the carousel icons before they have
      been allocated.
  * verify sortmode when building categories (LP: #618411) and
    ignore categories with unknown/unsupported ones
  * merged lp:~mmcg069/software-center/cleanup-software-section-code
    that fixes LP: #624786 (many thanks)
  * make sure there is always a toplevel transaction for a pending
    purchase even if s-c waits for the for-pay repository to become
    available (LP: #627608)
  * softwarecenter/view/purchasedialog.py:
    - support both "failure_reason" and "failures" as error strings
      from the agent
  * merged lp:~mmcg069/software-center/Bug617443 (LP: #617443)
  * merged lp:~mmcg069/software-center/bug628714 (LP: #628714)
  * merged lp:~mmcg069/software-center/hover-highlight-tweaks to
    use correct prelight color

  [ Kiwinote ]
  * data/featured.menu.in:
    - fretsonfire instead of fretsonfire-game, due to desktop file changes
  * data/software-center.menu.in:
    - use correct icon for system category, thanks vish!
  * softwarecenter/apt/aptcache.py:
    - don't crash on broken dependencies (LP: #630579)
      (testcase: acl2-books)
  * softwarecenter/db/application.py:
    - set pkgname for deb files correctly (LP: #628787)
      (testcase: replace _ with - in filename of an outdated deb file of s-c)
  * softwarecenter/view/appdetailsview_gtk.py:
    - never display the description of a different pkg
      (testcase: browse to any appdetails view and then to fluendo dvd player)
    - don't crash if icon for 'where is it' is None (LP: #629845)
    - don't crash if icon for addon can not be opened (LP: #629937)
    - don't display add-ons when we have an error
      (testcase: deb file of wrong architecture)
  * softwarecenter/view/appview.py:
    - fix startup crash (LP: #618411)
  * softwarecenter/view/availablepane.py:
    - set section for subcategory view (this means that we now have a bg)
  * softwarecenter/view/installedpane.py:
    - don't return to installed overview list on reopening db
  * softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - fix visual corruption on appending pathbar part
      (testcase: channelpane > details > different channelpane > details)
 -- Michael Vogt <email address hidden> Tue, 07 Sep ...

Read more...

Changed in software-center (Ubuntu):
status: Triaged → Fix Released
Victor Vargas (kamus) wrote :

Bug 654811 should fix this issue in gwibber.

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers