software-center requires authentication twice to install application

Bug #628350 reported by Charlie Kravetz on 2010-09-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Low
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

RELEASE: Maverick Meerkat Beta
CD/DVD VARIANT: 32bit and 64bit Xubuntu Desktop cd
ISO BUILD: 2010-09-01
SYMPTOMS:
When installing software in a fresh installation using the Desktop cd, I am required to enter my password two times to get the software installed.

STEPS TO REPRODUCE:
1. Install Xubuntu using the Beta Desktop image
2. click on 'Applications -> Ubuntu Software Center'
3. click on 'Accessories'
4. cursor down to 'Gedit'
5. click 'Gedit', the only button available is "More Info"
6. click "More Info"
7. Now the only thing I have is 'Available from the "main" source' and a button on the right 'Use this Source'
8. click "Use this source"
9. Authenticate window comes up, enter password to Authenticate
10. After several seconds to 5 minutes, a new page will show up
11. There will be a description of Gedit, and a new button "Install"
12. clicking on the "Install" button opens a new window, Authenticate
13. enter the password again, and gedit will install

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.14.1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Wed Sep 1 16:14:14 2010
InstallationMedia: Xubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Charlie Kravetz (charlie-tca) wrote :
tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Confirmed in maverick.
1. Disable the partner repository from /etc/apt/sources.list
2. Reload apt's cache
3. Go to Software-center/Partner and select an uninstalled application => Password prompt
4. Once the 'install' button appears (it doesn't always appears) click on it => Password prompt

The first prompt is from aptdaemon for the method org.debian.apt.change-repository
The second prompt is from aptdaemon for the method org.debian.apt.install-or-remove-packages

Setting to low because that happens only once but that's a usability issue anyway.

Changed in aptdaemon (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in software-center (Ubuntu):
status: New → Confirmed
Sebastian Heinlein (glatzor) wrote :

We now have got a high level privilege install-packages-from-new-repo. It should be used by software-center

Changed in aptdaemon (Ubuntu):
status: Triaged → Fix Released
Changed in software-center (Ubuntu):
importance: Undecided → Medium
dobey (dobey) on 2013-04-05
Changed in software-center (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers