software-center featured and new apps sections shows already installed softwares

Bug #627114 reported by lipstick on 2010-08-30
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Matthew McGowan

Bug Description

Binary package hint: software-center

software-center featured and new apps sections shows already installed softwares which are not so nice

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.14.1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
CheckboxSubmission: 09cdbd269b0dd3f2b0d2eb40cad6878d
CheckboxSystem: e3f7e64142c9de9cf92c77313821923d
Date: Tue Aug 31 01:10:04 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100829)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=tr_TR.utf8
 SHELL=/bin/bash
SourcePackage: software-center

lipstick (sinanaykut-gmail) wrote :
KEIII (cashagent) on 2010-10-05
Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Changed in software-center (Ubuntu):
assignee: nobody → Matthew McGowan (mmcg069)
Kiwinote (kiwinote) wrote :

Fixed this for what's new. Due to the nature of our featured apps section, we only have a finite list of possible featured apps. It's realistically quite possible that people have installed all but a few of these apps. This could leave us with a (near-)empty featured apps section, which is quite undesirable. Hence I haven't applied this change to the featured apps section.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.1.24

---------------
software-center (3.1.24) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/thumbnail.py:
    - add missing logger definition to fix name error on
      a thumbnail download error
  * softwarecenter/utils.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/softwarepane.py:
    - update Unity launcher integration implementation per
      revised approach (see LP: #670403)
  * test/test_unity_launcher_integration.py,
    test/data/<many>:
    - update unit tests per the revised approach

  [ Michael Vogt ]
  * merged lp:~mmcg069/software-center/rtl-work, many thanks
    to Matthew McGowan
  * merged lp:~mmcg069/software-center/desc-tweaks
  * merged lp:~weblive-dev/software-center/weblive-by-default, thanks
    to Stephane Graber (LP: #736227)
  * softwarecenter/view/widgets/thumbnail.py:
    - fix show/hide issue in download_and_display()
  * softwarecenter/db/reviews.py, softwarecenter/models/appstore.py:
    - deal with empty appname in the review-stats to follow the
      latest server changes
  * merged lp:~mmcg069/software-center/reviews-msg-tweaks, many thanks
    to to Matthew McGowan
  * show launcher like location for commandline only apps, thanks
    to Matthew McGowan
  * when scanning for commandline binaries take alterantives into
    account as well

  [ Kiwinote ]
  * data/new.menu.in,
    softwarecenter/view/appview.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/catview_gtk.py:
    - only display available items in what's new (LP: #739276)
    - don't display installed items in what's new (LP: #627114)
  * softwarecenter/db/database.py:
    - don't crash when we have no axi values (LP: #737870)
  * softwarecenter/gwibber_helper.py:
    - don't crash on startup due to anything sqlite related (LP: #737220)
  * softwarecenter/log.py:
    - don't crash on startup when logfile is not writeable (LP: #688682)
  * softwarecenter/view/appdetailsview_gtk.py:
    - correctly update statusbar after cancelling a dependency dialog
  * softwarecenter/view/catview_gtk:
    - don't crash when we have no what's new carousel (LP: #736046)
  * softwarecenter/view/softwarepane.py:
    - connect 'transaction-stopped' to on_transaction_stopped rather than o_t_f
  * softwarecenter/view/widgets/reviews.py:
    - fallback to package_name if review_data contains no app_name
 -- Michael Vogt <email address hidden> Tue, 22 Mar 2011 16:03:58 +0100

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers