Ubuntu

No progress shown when removing software

Reported by Matthew Paul Thomas on 2010-08-27
This bug report is a duplicate of:  Bug #642936: Doesn't monitor remove transactions. Edit Remove
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

software-center trunk r1082, Ubuntu Software Center 2.1.19, software-center trunk r1181

1. Navigate to the software item screen of something you have installed but don't want any more.
2. Click "Remove".

What should happen:
* The installation state text changes to "Removing...".
* The "Remove" button is replaced by a progress bar.
* The "In Progress" item appears in the navigation pane.

What actually happens:
* The installation state text changes to "Removing...".
* The "Remove" button becomes insensitive.
* No "In Progress" item appears in the navigation pane.
* Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/home/mpt/hacking/software-center/trunk/softwarecenter/view/pendingview.py", line 97, in on_transactions_changed
    trans = aptdaemon.client.get_transaction(tid)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/defer.py", line 510, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 149, in _convert_dbus_exception
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/client.py", line 1023, in get_transaction
    trans.sync()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/defer.py", line 510, in _deferable
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/errors.py", line 149, in _convert_dbus_exception
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/client.py", line 334, in sync
    sync_properties(properties)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/client.py", line 323, in sync_properties
    self._on_property_changed(property_name, value)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/client.py", line 291, in _on_property_changed
    self.emit("space-changed", value)
TypeError: could not convert type dbus.Double to (null) required for parameter 0
debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

description: updated
Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
description: updated
Matthew McGowan (mmcg069) wrote :

Hi,

fixed in the linked branch.

Changed in software-center (Ubuntu):
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Matthew Paul Thomas (mpt) wrote :

This isn't fixed for me either in 2.1.19 or in trunk r1181. The only difference now is that the instead of the "Remove" button disappearing, it becomes insensitive. There's still no progress bar, and still no "In Progress" item. There's also a traceback in the terminal.

Changed in software-center (Ubuntu):
status: Fix Released → Triaged
description: updated
Michael Vogt (mvo) on 2010-09-20
Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers