Too much space between "Cancel" and "Apply Changes"

Bug #625230 reported by Matthew Paul Thomas on 2010-08-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

Binary package hint: software-center

Ubuntu Software Center 2.1.14.1, Ubuntu Maverick

1. Navigate to an installed item that has add-ons, e.g. Firefox.
2. Check or uncheck at least one of the add-on checkboxes.

What you see: The gap between the "Cancel" button and the "Apply Changes" button is larger than the gap between either of those buttons and the edge of the add-ons state bar.

What you should see: They should be at least as close to each other as they are to the edge of the bar.

arky (arky) wrote :
Xhacker Liu (xhacker) on 2010-08-28
Changed in software-center (Ubuntu):
status: New → Confirmed
Kiwinote (kiwinote) on 2010-08-30
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Kiwinote (kiwinote)
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package software-center - 2.1.15

---------------
software-center (2.1.15) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/purchasedialog.py:
    - fix size and title for additional webkit windows (LP: #625385)
  * softwarecenter/db/update.py:
    - fix screenshot url and thumbnail url loading
  * softwarecenter/enums.py:
    - switch default to buy-host to software-center.ubuntu.com
    - allow override via the SOFTWARE_CENTER_BUY_HOST environment
      (useful for testing)
  * softwarecenter/backend/aptd.py:
    - make defaults for addons_{install,remove} empty lists instead
      of None to prevent crash when called with a empty argument
    - use AptClinet.install_packages() instead of commit_packages()
      for the install of commercial stuff to get the benefit of
      aptdaemons 03_auth_me_less patch
  * softwarecenter/backend/restfulclient.py:
    - point SERVICE_ROOT for the internal login service to production
  * softwarecenter/view/appdetailsview_gtk.py:
    - minor logging improvements
  * merged lp:~mmcg069/software-center/pathbar-clip-fix that ensures
    proper clipping for the pathbar, many thanks!
  * softwarecenter/view/channelpane.py:
    - fix flicker in channelspane on db-reopen and add regression
      test
  * merged lp:~mvo/software-center/less-flicker that fixes some
    UI flicker/ghost activity (LP: #626733)
  * softwarecenter/backend/aptd.py:
    - if reload() fails when adding a commercial PPA that may be
      because there is a 5 min delay between software-center-agent
      telling us its available and it becoming availalbe in launchpad.
      In this case, retry up to 5 minutes to get the repo
      (LP: #627608)
  * merged lp:~mmcg069/software-center/prelight-icon-onhover
    (many thanks!)
  * merged lp:~mmcg069/software-center/cat-flags to support
    internal flags in the menu files

  [ Gary Lasker ]
  * merge lp:~mmcg069/software-center/misbehaving-pathbar-fix, fixes
    pathbar no longer shrinking to available width (LP: #625210),
    many thanks Matthew McGowan!
  * softwarecenter/view/viewswitcher.py:
    - only update the channel list when a model is available
      (LP: #628394)

  [ Kiwinote ]
  * data/dialogs.ui:
    - only display vscrollbar if needed for dependency removal alert
    - tweak window properties for dependency removal alert
  * data/SoftwareCenter.ui:
    - tweak window properties for the rebuilding window
  * po/POTFILES.in:
    - mark data/ui/dialogs.ui for translation
  * software-center:
    - fix typo, thanks Jeremy Bicha! (LP: #625729)
  * softwarecenter/app.py:
    - always make s-c sensitive again after catalog is rebuilt (LP: #626513)
  * softwarecenter/apt/aptcache.py:
    - don't crash when no LANGPACK_PKGDEPENDS file exists (LP: #625562)
    - speed improvements for get_addons()
    - don't allow randompkg-something to list randompkg as an add-on
  * softwarecenter/db/application.py:
    - fail nicely if a deb file can't be opened
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't use capitalize() on add-on names, much thanks to Severin Heiniger!
      lp:~lantash/ubuntu/maverick/software-center/fixes-626067 (LP: #62...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Matthew Paul Thomas (mpt) wrote :

Problem still exists in Ubuntu Software Center 2.1.18; reopening.

Changed in software-center (Ubuntu):
importance: Undecided → Low
status: Fix Released → Triaged
Kiwinote (kiwinote) wrote :

Hi mpt! Thanks for noticing that this problem has been reintroduced (after the code to draw the pkg statusbar and addons statusbar was merged). Fixed again in my branch.

Changed in software-center (Ubuntu):
status: Triaged → Fix Committed
Gary Lasker (gary-lasker) wrote :

Fix merged to trunk. Thanks kiwinote!

Colin Watson (cjwatson) wrote :

software-center (2.1.19) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/widgets/mkit.py:
    - fix crash during action_bar refresh (LP: #635044)
  * softwarecenter/backend/channel.py:
    - always display the partner channel, even if its
      source is not enabled (LP: #635003)
  * softwarecenter/db/application.py,
    softwarecenter/db/database.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - make StoreDatabase.get_appname return None if the
      name is not defined in the xapian doc
    - consolidate code to generate application name and
      summary for display in the UI to a single place
    - wire applist, appdetails and the navigation bar
      to use it (LP: #636004)

  [ Kiwinote ]
  * data/software-center.menu.in:
    - fix typo to now use applications-ocaml icon, thanks mpt (LP: #635732)
  * softwarecenter/backend/channel.py:
    - allow 'for purchase' to have an icon in non-English locales (LP: #636242)
  * softwarecenter/db/application.py:
    - try to open deb file, except on any sort of error (LP: #633379)
    - simplify when we use which warnings for deb files (LP: #635015)
    - reload pkg cache object and xapian doc if it turns out that the pkgname
      of a deb file is different than what we guessed on basis of the file name
  * softwarecenter/utils.py:
    - fix crash when desktop_file is None (LP: #635596)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use the display name for app entry in 'where is it' (LP: #635464)
    - restore correct padding in addons status bar (LP: #625230)
  * minor tweaks to lp:~gary-lasker/software-center/title-summary-fixes
    - use installed state in status bar for reinstallable debs (LP: #635015)

  [ Matthew Paul Thomas ]
  * data/software-center.menu.in:
    - fix incorrect Category value in the xml for the Debugging
      subcategory of Developer Tools (LP: #538911)

  [ Colin Watson ]
  * Fix update-apt-xapian-index crashes when the Dir::Cache::pkgcache file
    doesn't exist (LP: #267330).

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix "reload()" in enable_channel() and only update the particular
      channel file
  * softwarecenter/distro/Ubuntu.py:
    - fix crash for icons loaded from extras.ubuntu.com
  * merged lp:~mmcg069/software-center/Bug635375 (LP: #635375)
  * merged lp:~mmcg069/software-center/tiny-pathbar-tweak
  * merged lp:~mmcg069/software-center/Bug625443 (LP: #625443)

 -- Michael Vogt <email address hidden> Tue, 14 Sep 2010 12:16:47 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers