Pathbutton no longer shrinks to available width

Bug #625210 reported by Matthew Paul Thomas on 2010-08-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Matthew McGowan

Bug Description

Binary package hint: software-center

software-center trunk r1078, Ubuntu Maverick

1. Resize the Ubuntu Software Center window to 800 pixels wide.
2. Navigate to "Get Software" > " Science & Engineering" > "Chemistry".

What happens: The search field partly disappears off the edge of the screen.
What should happen: The pathbutton ellipsizes to something like "Get S…" > "Science & Engineering" > "Chemistry".

This might be related to bug 620514.

Related branches

Changed in software-center (Ubuntu):
assignee: nobody → Matthew McGowan (mmcg069)

Hi,

I have provided a fix. The reason was the fact the main gtk.Notebook
widget was parented by a gtk.Viewport.

I have removed the Viewport and provided a alternative method for
painting a border around the Notebook (which was the sole purpose of
the Viewport).

the branch;
lp:~mmcg069/software-center/misbehaving-pathbar-fix

On Fri, Aug 27, 2010 at 9:58 PM, Launchpad Bug Tracker
<email address hidden> wrote:
> You have been assigned a bug task for a public bug by Matthew Paul Thomas (mpt):
>
> Binary package hint: software-center
>
> software-center trunk r1078, Ubuntu Maverick
>
> 1. Resize the Ubuntu Software Center window to 800 pixels wide.
> 2. Navigate to "Get Software" > " Science & Engineering" > "Chemistry".
>
> What happens: The search field partly disappears off the edge of the screen.
> What should happen: The pathbutton ellipsizes to something like "Get S…" > "Science & Engineering" > "Chemistry".
>
> This might be related to bug 620514.
>
> ** Affects: software-center (Ubuntu)
>     Importance: Undecided
>     Assignee: Matthew McGowan (mmcg069)
>         Status: New
>
> --
> Pathbutton no longer shrinks to available width
> https://bugs.edge.launchpad.net/bugs/625210
> You received this bug notification because you are a bug assignee.
>

--
From the mind of me!

Gary Lasker (gary-lasker) wrote :

Fix merged, thanks a lot, Matthew!

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package software-center - 2.1.15

---------------
software-center (2.1.15) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/purchasedialog.py:
    - fix size and title for additional webkit windows (LP: #625385)
  * softwarecenter/db/update.py:
    - fix screenshot url and thumbnail url loading
  * softwarecenter/enums.py:
    - switch default to buy-host to software-center.ubuntu.com
    - allow override via the SOFTWARE_CENTER_BUY_HOST environment
      (useful for testing)
  * softwarecenter/backend/aptd.py:
    - make defaults for addons_{install,remove} empty lists instead
      of None to prevent crash when called with a empty argument
    - use AptClinet.install_packages() instead of commit_packages()
      for the install of commercial stuff to get the benefit of
      aptdaemons 03_auth_me_less patch
  * softwarecenter/backend/restfulclient.py:
    - point SERVICE_ROOT for the internal login service to production
  * softwarecenter/view/appdetailsview_gtk.py:
    - minor logging improvements
  * merged lp:~mmcg069/software-center/pathbar-clip-fix that ensures
    proper clipping for the pathbar, many thanks!
  * softwarecenter/view/channelpane.py:
    - fix flicker in channelspane on db-reopen and add regression
      test
  * merged lp:~mvo/software-center/less-flicker that fixes some
    UI flicker/ghost activity (LP: #626733)
  * softwarecenter/backend/aptd.py:
    - if reload() fails when adding a commercial PPA that may be
      because there is a 5 min delay between software-center-agent
      telling us its available and it becoming availalbe in launchpad.
      In this case, retry up to 5 minutes to get the repo
      (LP: #627608)
  * merged lp:~mmcg069/software-center/prelight-icon-onhover
    (many thanks!)
  * merged lp:~mmcg069/software-center/cat-flags to support
    internal flags in the menu files

  [ Gary Lasker ]
  * merge lp:~mmcg069/software-center/misbehaving-pathbar-fix, fixes
    pathbar no longer shrinking to available width (LP: #625210),
    many thanks Matthew McGowan!
  * softwarecenter/view/viewswitcher.py:
    - only update the channel list when a model is available
      (LP: #628394)

  [ Kiwinote ]
  * data/dialogs.ui:
    - only display vscrollbar if needed for dependency removal alert
    - tweak window properties for dependency removal alert
  * data/SoftwareCenter.ui:
    - tweak window properties for the rebuilding window
  * po/POTFILES.in:
    - mark data/ui/dialogs.ui for translation
  * software-center:
    - fix typo, thanks Jeremy Bicha! (LP: #625729)
  * softwarecenter/app.py:
    - always make s-c sensitive again after catalog is rebuilt (LP: #626513)
  * softwarecenter/apt/aptcache.py:
    - don't crash when no LANGPACK_PKGDEPENDS file exists (LP: #625562)
    - speed improvements for get_addons()
    - don't allow randompkg-something to list randompkg as an add-on
  * softwarecenter/db/application.py:
    - fail nicely if a deb file can't be opened
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't use capitalize() on add-on names, much thanks to Severin Heiniger!
      lp:~lantash/ubuntu/maverick/software-center/fixes-626067 (LP: #62...

Read more...

Changed in software-center (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers