software-center crashed with TypeError in _set_cursor()

Bug #617004 reported by Vadim Rutkovsky on 2010-08-12
524
This bug affects 107 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

Binary package hint: software-center

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.9
ProcVersionSignature: Ubuntu 2.6.35-14.20-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Thu Aug 12 22:39:23 2010
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center']
SourcePackage: software-center
Title: software-center crashed with TypeError in _set_cursor()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Vadim Rutkovsky (roignac) wrote :
visibility: private → public
tags: removed: need-duplicate-check

afer installing stellarium - which doesn't works
see also : https://bugs.launchpad.net/ubuntu/+source/apt-xapian-index/+bug/590998 which happend just after.

Paul White (paulw2u) wrote :

Using version 2.1.20 of Software Center I installed build 9047 of Opera. As soon as SC confirmed that Opera had been upgraded I started Opera and SC crashed.

H2L29 (samsamh2l) wrote :

at close of software-center after any install

at close of sotfware-center after any install too

Crash after removal. To be precise, it was crash after pressing the close button.

Jonathan Windham (jon2kx) wrote :

@marek that when mine crashed as well, seems to be intermittent issue.

Andrey Kolchenko (komex) wrote :

at close of sotfware-center after any install/uninstall

Jamie Luckett (jamieluckett) wrote :

It crashes about 5 seconds after the close button has been pressed.

Changed in software-center (Ubuntu):
assignee: nobody → Wuilmer Bolívar (elwuilmer)
Changed in software-center (Ubuntu):
assignee: Wuilmer Bolívar (elwuilmer) → nobody
Changed in software-center (Ubuntu):
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Gary Lasker (gary-lasker)
tags: added: bugpattern-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 3.0.4

---------------
software-center (3.0.4) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/appview.py:
    - fix intermittent crash in _set_cursor (LP: #617004)

  [ Michael Vogt ]
  * Create the log directory not on the import paths.py. Otherwise
    if the user upgrades using a sudo based tool (like apt-get) he
    may end up with a root owned log (LP: #652151)
  * softwarecenter/paths.py
    - ensure we don't create directories in /home when running as
      root
    - When detecting a not writable cache dir, try to remove it
      so that it gets re-created later with the right permissions.
      That will undo the damage in bug LP: #652151
 -- Michael Vogt <email address hidden> Fri, 01 Oct 2010 10:40:08 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers