Install/Remove button is missing in app details view whenever another install/remove is in-progress

Bug #613928 reported by Mark Ericksen on 2010-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Kiwinote
Nominated for Maverick by Mark Ericksen

Bug Description

Binary package hint: software-center

Package: software-center 2.1.7.

In the Ubuntu Software Center, there is a section of "Featured" and "What's New". I was installing software and while that was going on in the background, I was clicking on featured applications and reading about them. When I found a new package I wanted to install, I found there was no way to install it. The "Install" button is hidden when a background download/install is underway. However, when I returned to the "Get Software" section and searched on the name of the software, I could install it there.

The problem is, since multiple software packages can be queued up to be installed, why can't we click "Install" when reviewing a package? At first, I was very confused thinking there was just no way to install the software from the "Featured" software screen. Only later (after trying to get screenshots) did I learn there was an Install button but it only shows up when nothing is happening in the background. I didn't even think about the downloads in the background at the time and was very, very confused.

I've attached three screenshots. 1) Install button shows when no installs, 2) Install button hidden when a download is underway, 3) Install underway but can search and install from the list.

Mark Ericksen (spamingfree) wrote :
Gary Lasker (gary-lasker) wrote :

(From my comment in the previous bug, but bears repeating here I think) :)

Hi Mark! Thanks for finding this one, I just checked this myself and it is indeed a new problem in Maverick Alpha 3. Thanks especially for the excellent details in your comment, and for taking the time to make the screenshots as they tell the story perfectly!

And please continue to report any other problems or issues you encounter with Software Center. Your help is much appreciated!

summary: - Software Center regression of "Install button" problem
+ Install/Remove button is missing in app details view whenever another
+ install/remove is in-progress
description: updated
Changed in software-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
Kiwinote (kiwinote) wrote :

Hi Mark! Thanks for your bug report. The bug you describe should be fixed in the latest development version of software-center (2.1.8). Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers