Partner repository now appears twice in navigation pane

Bug #604693 reported by Matthew Paul Thomas on 2010-07-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Michael Vogt
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: software-center

TEST CASE:
1. use lucid
2. add partner repository
3. start software-center, expand get software (maybe) wait some minutes
4. verify that in Get Software contains two partner channels
5 install the version from lucid-proposed
6. verify that there is only one partner channnel

Ubuntu Software Center 2.0.5, Ubuntu 10.04
software-center trunk r896, Ubuntu 10.04

Today, the Canonical partner repository appears as two separate items inside "Get Software" in the navigation pane: as "Canonical Partners" at the top, and as "Partner archive" at the bottom.

This is a recent regression in 10.04, even though the last software-center release in 10.04 was four weeks ago.

Therefore, I think it might be because bug 552560 has just been fixed, and the code in USC that was special-casing the partner archive was looking at Origin/Label when perhaps it shouldn't have been.

Matthew Paul Thomas (mpt) wrote :

I'm nominating this for fixing in 10.04 because it is a regression since 10.04 was released, and it may confuse people who are using software from the partner repository.

Steve Kowalik (stevenk) wrote :

I thought the whole point of fixing bug 552560 was so that Software Center could differentiate between software that came from partner versus software that came from the main archive.

I am happy to talk about changing the Origin/Label for partner to suit software-center better.

Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: New → In Progress
Michael Vogt (mvo) on 2010-07-14
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Changed in software-center (Ubuntu Lucid):
status: New → In Progress
description: updated

Accepted software-center into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.5

---------------
software-center (2.1.5) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix in channel adding code
  * merged lp:~mvo/software-center/lazr to support gobject
    based wrapper around lazr.restfulclient apps
  * merged lp:~mmcg069/software-center/pathbar-tweaks,
    many thanks
  * merged lp:~mvo/software-center/appdetails-in-db that
    improve the AppDetails abstraction
  * merged lp:~mvo/software-center/plugin-support (important
    for the oneconf integration)
  * merged lp:~osomon/software-center/close_in_progress
    that fixes LP:#431907, thanks to Olivier Tilloy
  * remove specal cases for partner now that soyuz
    LP: #552560 is fixed (LP: #604693)
  * software-center:
    - fixes in the logging code (thanks to Geliy Sokolov)
  * merged lp:~and471/software-center/dialog-work that improves
    the dialogs (many thanks!)

  [ Gary Lasker ]
  * data/icons/scalable/apps/category-show-all.svg,
    data/icons_unbranded/scalable/apps/category-show-all.svg,
    softwarecenter/view/catview_gtk.py:
    - add custom icon for single-pane dept view "All" button;
      icon created by Dani Planas Armangue, many thanks!
      (LP: #599644)
  * softwarecenter/view/pkgview.py:
    - replace svg icon with png version because the svg version
      has been removed from gnome-icon-theme (LP: #601987)
  * po/POTFILES.in:
    - update to latest set of modules
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, adds
    Matthew McGowan's new gtk-based appdetailsview, many thanks!
    Thanks also to kiwinote and mvo for refactoring for new
    AppDetails class and other changes. Also fixes LP: #578650.
  * softwarecenter/apt/aptcache.py:
    - tweak timeout value when opening the apt cache
      (LP: #602610)
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, fixes
    description parsing error for e.g. The Gimp. Many thanks!
  * softwarecenter/app.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/navhistory.py:
    - navigation history fixes
  * data/ui/dialogs.ui,
    softwarecenter/app.py,
    softwarecenter/enums.py,
    softwarecenter/view/appdetailsview.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - consolidate install/remove action handling to
      one place, now shows dep package removal dialog
      for all cases; fix response ids for dialogs
 -- Michael Vogt <email address hidden> Fri, 16 Jul 2010 09:14:22 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
rww (rww) wrote :

software-center in lucid-proposed crashes on startup with "UnboundLocalError: local variable 'partner_channel' referenced before assignment". See bug 606452. Setting verification-failed tag.

tags: added: verification-failed
removed: verification-needed
Colin Watson (cjwatson) wrote :

Thanks, Robert. software-center 2.0.7 fixes the regression reported in bug 606452; please retest.

tags: added: verification-needed
removed: verification-failed
rww (rww) wrote :

Works for me. The crash at startup is fixed, and the partner repository's appearing once.

Martin Pitt (pitti) on 2010-07-22
tags: added: verification-done
removed: verification-needed
Gary Lasker (gary-lasker) wrote :

This bug was fixed for lucid in the package software-center - 2.1.7:

-------------------

software-center (2.0.7) lucid-proposed; urgency=low

  * softwarecenter/view/viewswitcher.py:
    - fix crash if partner channel cannot be detected
      (LP: #606452)

 -- Gary Lasker <email address hidden> Sat, 17 Jul 2010 01:35:07 -0400

software-center (2.0.6) lucid-proposed; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/viewswitcher.py:
    - only reselect a channel node when a model is available
      (LP: #578497)

  [ Michael Vogt ]
  * softwarecenter/view/viewswitcher.py:
    - remove specal cases for partner now that soyuz
      LP: #552560 is fixed (LP: #604693)

 -- Michael Vogt <email address hidden> Wed, 14 Jul 2010 18:01:38 +0200

Changed in software-center (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers