Software Centre does not launch

Bug #591590 reported by Delan Azabani on 2010-06-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker

Bug Description

With software-center 2.1.1 (maverick) I can not launch the software center. This is the stdout that is shown:

delan@delan:~$ software-center
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  from gtk import _gtk
ImportError: No module named gi
/usr/share/software-center/softwarecenter/view/historypane.py:29: DeprecationWarning: please use 'debian' instead of 'debian_bundle'
  from debian_bundle import deb822
Traceback (most recent call last):
  File "/usr/bin/software-center", line 78, in <module>
    app = SoftwareCenterApp(datadir, xapian_base_path)
  File "/usr/share/software-center/softwarecenter/app.py", line 206, in __init__
    self.icons, datadir)
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 128, in __init__
    self.parse_history_log()
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 157, in parse_history_log
    fd = open(self.filename)
IOError: [Errno 2] No such file or directory: '/var/log/apt/history.log'

Monkey (monkey-libre) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in software-center.
(With many applications, you can report a future bug directly on the appropriate package by opening the application's "Help" menu and choosing "Report a Problem". https://wiki.ubuntu.com/ReportingBugs)

affects: ubuntu → software-center (Ubuntu)
tags: added: maverick
Changed in software-center (Ubuntu):
status: New → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
importance: Undecided → Low
Gary Lasker (gary-lasker) wrote :

Hi Delan, thanks for reporting this bug. The fix has been committed to trunk and will be included in the next development release of Software Center which will be version 2.1.2. It should be available in the next day or so.

Meanwhile, if you like you can work around this problem you can do it by simply installing or removing a package. You can do this using Synaptic or apt-get install on the command line. This will generate the missing /var/log/apt/history.log file that is causing Software Center to not start.

Thanks again!

Delan Azabani (azabani) wrote :

Unfortunately I've tried some package actions using apt-get, along with manually creating the log file. The particular error no longer shows, but software-center still crashes with a different output.

delan@delan:~$ software-center
/usr/lib/pymodules/python2.6/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  from gtk import _gtk
ImportError: No module named gi
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/apport_python_hook.py", line 105, in apport_excepthook
    os.O_WRONLY|os.O_CREAT|os.O_EXCL, 0600), 'w')
OSError: [Errno 2] No such file or directory: '/var/crash/_usr_share_software-center_software-center.1000.crash'

Original exception was:
ImportError: No module named gi
/usr/share/software-center/softwarecenter/view/historypane.py:29: DeprecationWarning: please use 'debian' instead of 'debian_bundle'
  from debian_bundle import deb822
Traceback (most recent call last):
  File "/usr/bin/software-center", line 78, in <module>
    app = SoftwareCenterApp(datadir, xapian_base_path)
  File "/usr/share/software-center/softwarecenter/app.py", line 206, in __init__
    self.icons, datadir)
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 128, in __init__
    self.parse_history_log()
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 163, in parse_history_log
    when = datetime.datetime.strptime(stanza['Start-Date'], '%Y-%m-%d %H:%M:%S')
  File "/usr/lib/pymodules/python2.6/debian/deb822.py", line 170, in __getitem__
    value = self.__dict[key]
KeyError: 'Start-Date'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/apport_python_hook.py", line 105, in apport_excepthook
    os.O_WRONLY|os.O_CREAT|os.O_EXCL, 0600), 'w')
OSError: [Errno 2] No such file or directory: '/var/crash/_usr_share_software-center_software-center.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/software-center", line 78, in <module>
    app = SoftwareCenterApp(datadir, xapian_base_path)
  File "/usr/share/software-center/softwarecenter/app.py", line 206, in __init__
    self.icons, datadir)
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 128, in __init__
    self.parse_history_log()
  File "/usr/share/software-center/softwarecenter/view/historypane.py", line 163, in parse_history_log
    when = datetime.datetime.strptime(stanza['Start-Date'], '%Y-%m-%d %H:%M:%S')
  File "/usr/lib/pymodules/python2.6/debian/deb822.py", line 170, in __getitem__
    value = self.__dict[key]
KeyError: 'Start-Date'

Changed in software-center (Ubuntu):
status: Fix Committed → New
Gary Lasker (gary-lasker) wrote :

Hi Delan. Thanks for reporting back. Actually, this second bug you mention is a separate one and has been reported already in bug 590281. Please be sure to follow that bug for further details and to track the status of the fix.

Since the original problem described for this bug has been fix committed, I'll set the status back to that.

Thanks again!

Changed in software-center (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.2

---------------
software-center (2.1.2) maverick; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/viewswitcher.py:
    - only reselect a channel node when a model is available
      (LP: #578497)
  * fix "List view forgets selected row" regression (LP: #584969)
  * softwarecenter/view/availablepane.py:
    - fix broken searches
  * data/ui/SoftwareCenter.ui,
    softwarecenter/app.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/navhistory.py:
    - bit of navhistory code housekeeping
    - add navhistory back/forward actions and corresponding
      menu items
    - integrate navhistory actions with custom back/forward
      buttons
    - add accelerator keys for navhistory actions
  * merged lp:~osomon/software-center/memory_leak, fixes
    memory leak regression (LP: #577540), thanks Olivier Tilloy!
  * softwarecenter/backend/aptd.py:
    - fix error when updating software sources (LP: #586623)
  * merged lp:~osomon/software-center/memory_leak, disconnect
    signals to allow appstore to be deleted, thanks Olivier Tilloy!
  * merged lp:~osomon/software-center/fix_appstore_update, remake
    pkgname_index_map correctly, many thanks Olivier!
  * softwarecenter/view/historypane.py:
    - fix UnboundLocalError if history.log is empty
  * merged lp:~hellium/software-center/installed-date, history
    pane log parsing merged to AptHistory, implement "Installed since"
    feature in the details view, many thanks Geliy Sokolov!
  * softwarecenter/apt/apthistory.py,
    softwarecenter/view/historypane.py:
    - fix launch error in the case where there is no
      history.log file (LP: #591590)

  [ Michael Vogt ]
  * merged lp:~glatzor/software-center/glatzor to get improved
    aptdaemon API
  * test/test_aptd.py:
    - update tests to work with new defered magic API
  * debian/control:
    - update dependencies on aptdaemon
  * merged lp:~mmcg069/software-center/improve-appview-persistence
    (many thanks!)
  * softwarecenter/view/installedpane.py:
    - do not crash if model is None (LP: #586306)
  * merged lp:~gary-lasker/software-center/hide_nonapps_pkgs_xapian
    many thanks to Jacob Johan Edwards and Gary
  * softwarecenter/apt/apthistory.py:
    - add test (and test data) for AptHistory class
    - be more async friendly and add test for async
  * merge lp:~mvo/software-center/launchpad-login branch that
    provides the infrastructure for LP login/API calls and supports
    displaying private PPAs
  * softwarecenter/apt/apthistory.py:
    - be more robust against invalid entries (LP: #590281), this
      also need a python-debian fix to be fully working
 -- Michael Vogt <email address hidden> Thu, 10 Jun 2010 12:04:34 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers