"install - free" button enabled while the installation is in progress.

Bug #578650 reported by Mikhail S. Pobolovets on 2010-05-11
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Matthew McGowan

Bug Description

Binary package hint: software-center

It is possible to:

1) select package for installation (large enough to have a time)
2) press 'Install' button
3) press 'More info' button
4) It is possible to press 'Install Free' what is wrong

Leo Arias (elopio) wrote :

I could reproduce it. Marking as confirmed...

elopio@tangamandapio-laptop:~$ aptitude show software-center
Package: software-center
State: installed
Automatically installed: no
Version: 2.0.3

Changed in software-center (Ubuntu):
status: New → Confirmed
Leo Arias (elopio) on 2010-05-11
summary: - install more info install free
+ "install - free" button enabled while the installation is in progress.
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
importance: Undecided → Low
Gary Lasker (gary-lasker) wrote :

I verified in the code and in testing that this bug has been fixed with the new gtk-based appdetailsview from Matthew McGowan. Many thanks Matthew!!

Changed in software-center (Ubuntu):
assignee: Gary Lasker (gary-lasker) → Matthew McGowan (mmcg069)
status: Triaged → Fix Committed
Leo Arias (elopio) wrote :

Thanks :)

Gary Lasker (gary-lasker) wrote :

Thanks a lot for your help, Leo, it's much appreciated! :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.5

---------------
software-center (2.1.5) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - fix in channel adding code
  * merged lp:~mvo/software-center/lazr to support gobject
    based wrapper around lazr.restfulclient apps
  * merged lp:~mmcg069/software-center/pathbar-tweaks,
    many thanks
  * merged lp:~mvo/software-center/appdetails-in-db that
    improve the AppDetails abstraction
  * merged lp:~mvo/software-center/plugin-support (important
    for the oneconf integration)
  * merged lp:~osomon/software-center/close_in_progress
    that fixes LP:#431907, thanks to Olivier Tilloy
  * remove specal cases for partner now that soyuz
    LP: #552560 is fixed (LP: #604693)
  * software-center:
    - fixes in the logging code (thanks to Geliy Sokolov)
  * merged lp:~and471/software-center/dialog-work that improves
    the dialogs (many thanks!)

  [ Gary Lasker ]
  * data/icons/scalable/apps/category-show-all.svg,
    data/icons_unbranded/scalable/apps/category-show-all.svg,
    softwarecenter/view/catview_gtk.py:
    - add custom icon for single-pane dept view "All" button;
      icon created by Dani Planas Armangue, many thanks!
      (LP: #599644)
  * softwarecenter/view/pkgview.py:
    - replace svg icon with png version because the svg version
      has been removed from gnome-icon-theme (LP: #601987)
  * po/POTFILES.in:
    - update to latest set of modules
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, adds
    Matthew McGowan's new gtk-based appdetailsview, many thanks!
    Thanks also to kiwinote and mvo for refactoring for new
    AppDetails class and other changes. Also fixes LP: #578650.
  * softwarecenter/apt/aptcache.py:
    - tweak timeout value when opening the apt cache
      (LP: #602610)
  * merge lp:~mmcg069/software-center/appdetailsview-gtk, fixes
    description parsing error for e.g. The Gimp. Many thanks!
  * softwarecenter/app.py,
    softwarecenter/view/availablepane.py,
    softwarecenter/view/navhistory.py:
    - navigation history fixes
  * data/ui/dialogs.ui,
    softwarecenter/app.py,
    softwarecenter/enums.py,
    softwarecenter/view/appdetailsview.py,
    softwarecenter/view/appdetailsview_gtk.py,
    softwarecenter/view/appdetailsview_webkit.py,
    softwarecenter/view/appview.py,
    softwarecenter/view/softwarepane.py:
    - consolidate install/remove action handling to
      one place, now shows dep package removal dialog
      for all cases; fix response ids for dialogs
 -- Michael Vogt <email address hidden> Fri, 16 Jul 2010 09:14:22 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers