Software-Center does not remove deactivated ppa's from the UI

Bug #574155 reported by Marcos Roriz on 2010-05-03
114
This bug affects 21 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Clean Lucid install =]

When you remove a ppa from Lucid it won't go away from Software-Center even after updating the apt cache.

Steps to reproduce.
1) Install a third party ppa.
2) Update apt db.
3) Start Software Center, ppa will be enabled.
4) Remove third party ppa.
5) Update Software Source.
6) Start Software Center, ppa is still enabled.

The equivalent for adding a PPA is bug 782953.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: software-center 2.0.3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon May 3 00:19:26 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Marcos Roriz (marcosrorizinf) wrote :
Fabián Rodríguez (magicfab) wrote :

In you step 4), when closing software sources, youshould have been asked to reload the repositories. Did you ? If not, USC can't know the PPA is gone.

Changed in software-center (Ubuntu):
status: New → Incomplete
Marcos Roriz (marcosrorizinf) wrote :

I did reload :)

Marcos Roriz (marcosrorizinf) wrote :

It's not incomplete.

Omer Akram (om26er) on 2010-05-10
Changed in software-center (Ubuntu):
status: Incomplete → New
David (david.regev) wrote :

I have the same issue, except that Software Center is showing two repositories that I have not just disabled but completely removed. These repositories appear no longer neither in the Software Sources list, nor in Synaptic’s origin list, nor in /etc/apt/sources.list.d/. The two removed repositories are ‘PPA for Telepathy’ (ppa:telepathy/ppa) and ‘yorba’ (ppa:yorba/ppa).

same issue here, disabled 3rd party repos in software-sources gui, then removed 3rd party sources in software-sources gui, then removed from /etc/apt/sources.list.d/ at CLI, had been refreshing software sources every time i made a change... no luck, old ppa's still showing up in Software Center... tried completely removing and purging Software Center, on reinstall, old sources are still present.

figured i'd follow up on this... not sure what changed, but after a few reboots, the software-center is no longer showing the removed ppa's.

David (david.regev) wrote :

Old repositories have finally disappeared for me as well, but only once I removed this package: app-install-data-medibuntu. That package is a recommended part of adding the Medibuntu repository, according to https://help.ubuntu.com/community/Medibuntu#Adding%20the%20Repository . Removing it seems to have made no noticeable difference other than fixing this bug. I’m not sure if the bug is caused by the package or merely exposed by it. Nathan, did you remove that package as well? Anyway, I hope this helps track down the issue.

nope, i didn't remove that package, they just randomly disappeared. sorry to take so long to update this, but once it quit being a problem, priority understandably dropped.

summary: - Software-Center don't remove unactivated ppa's
+ Software-Center does not remove deactivated ppa's

I think I know what´s causing this:

I used some PPA´s which I removed, but I kept using the ppa version of the app
The software center keeps the ppa because you still use the ppa version.

After forcing the program back to the lucid version with synaptic, the ppa disappears in the software center after updating the cache. :)

Andrew (and471) wrote :

Can someone confirm that this is not an issue thanks to Glennz nl's findings?

Changed in software-center (Ubuntu):
status: New → Incomplete
Daniel Gnoutcheff (gnoutchd) wrote :

>Can someone confirm that this is not an issue thanks to Glennz nl's findings?

NACK. I've got an entry for a GStreamer-related PPA that I purged out a long time ago (in all ways I can think of) but that won't go away from software-center. Furthermore, I've got other PPAs that *do* dissappear from software-center as soon as they are disabled, even if residual packages remain from them.

Currently investigating to figure out what the heck is up.

Daniel Gnoutcheff (gnoutchd) wrote :

Manually running
$ sudo /usr/share/software-center/update-software-center
seems to have made the problem go away. Looks like this may have something to do with software-center's xapian cache under /var/cache/software-center/.

BTW I did make a backup of /var/cache/software-center/ before running that command, in case that's useful for debugging.

Omer Akram (om26er) wrote :

is it happening in Ubuntu 10.10 for anyone?

Carl Simpson (cwd-simpson) wrote :

Yes. I got this problem in Ubuntu 10.10 just now, and it was mitigated by Daniel Gnoutcheff's suggested command.

Greg A (etulfetulf) wrote :

Reopening this. (I can confirm that this is still an issue.)

However Daniel's workaround did fix the issue.

Changed in software-center (Ubuntu):
status: Incomplete → New
description: updated
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Aaron Peachey (aaronp) wrote :

Yes, I think the issue with this one is that the application cache of software center is not updated until update-software-center runs. Installing or removing the medibuntu repos runs this command in order to fill Software Center with the new packages from those repos immediately. Also, some external apps changing the repos will also cause the Software Center cache to update (as far as I'm aware)

I'm not sure how Software Center would know when PPAs have been removed or deactivated to automatically update it's cache. And obviously, having the user run a terminal command that they probably don't know exists is not a viable solution either.

Should we put a new menu item in the Software Center GUI to allow the user to run update-software-center without typing a terminal command? (Note, this may also not be a perfect solution as most users wouldn't necessarily know that the cache used by Software Center needs updating independently of what they do in other package/repo management applications - which means they might still not run it even if it's in the GUI)

Other alternatives would be for us to connect to 'something' (not sure if it's possible) that would send Software Center a signal when a PPA has been removed or deactivated so update-software-center could then run without user action. I'm sure Software Center already detects when an external app has changed the packages but it doesn't seem to work in this particular situation?

Otherwise, perhaps a startup message like 'The Software Center application cache was last updated xxxx days ago. Some repositories or packages shown may no longer be available. Update Now?'

i think aaron's suggestion is a good one, possibly a hook into ppa-purge and software-properties-gtk to write a 'last-modified' file containing a timestamp that can be compared to a 'last-run-date' for update-software-center, triggering an automatic run of update-software-center by USC when the timestamps show it's needed... just throwing ideas at the wall, but the more transparent this is to users the better, your 'average joe' doesn't really want to think about software sources, my experience is that it's hard enough getting new users to realize that software can be installed from within an application as opposed to an internet download.

Matthew Paul Thomas (mpt) wrote :

All other things being equal, a solution that has zero user interface is better than one that has non-zero user interface.

Could USC (or something else) watch /etc/apt/sources.list, and trigger update-software-center whenever it changes?

Aaron Peachey (aaronp) wrote :

That's probably possible, there may also be some other solutions that are beyond my knowledge.
I'll have a chat to mvo and see if he has any better ideas on how to achieve this, but we can press forward under the assumption that if possible, we'd like to avoid any UI involvement at all.

description: updated
Marcos Roriz (marcosrorizinf) wrote :

Is this bug fixed on natty?

yes, USC 4.0.4 in natty appears to use software-properties-gtk for managing sources, so i would call this fixed.

description: updated
description: updated
Rui Pinho (rmtpinho) wrote :

I'm having this issue with Oneiric.

Tried the 'update-software-center' trick but didn't help at all.

Shannon Lucas (shannonlucas) wrote :

I was having this issue in Oneiric and discovered that some libraries in the deactivated PPA had been installed as dependencies for a package in another PPA. In my case, it was matthaeus123's GIMP PPA that wouldn't go away and Darktable from pmjdebruijn's PPA that had pulled in the dependencies from matthaeus123's PPA.

Try the following in Software Center:

1) Click the arrow next to "All Software" and choose the rogue PPA from the drop down.
2) If there are any packages listed with a green check mark, uninstall them. Note that this may require that Software Center remove software from another PPA be uninstalled.
3) Exit Software Center and reboot.
4) Re-install software from other PPAs that was removed in step 2.

After I rebooted, the rogue PPA was finally gone. It may be possible to avoid step 3 by using update-software-center.

Dave Morley (davmor2) on 2012-04-05
tags: added: top10bug
Dave Morley (davmor2) on 2012-04-10
tags: added: ca-escalated
removed: top10bug
Dave Morley (davmor2) on 2012-04-17
tags: added: ca-escalate
removed: ca-escalated
tags: added: ca-escalated
removed: ca-escalate
David Pitkin (dpitkin) on 2012-05-21
Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.10
Michael Vogt (mvo) on 2012-05-25
summary: - Software-Center does not remove deactivated ppa's
+ Software-Center does not remove deactivated ppa's from the UI
David Pitkin (dpitkin) on 2012-06-04
tags: removed: ca-escalated
James Hudon (jameshudon) wrote :

This is broken for me in 12.10, and none of the suggested workarounds helped. I removed the PPAs throught the GUI, and double-checked that they were gone from /etc/apt/sources.list and /etc/apt/sources.list.d. I also tried removing the cache in /var/cache/software-center/ and running "update-software-center". I also ensured that I had no packages installed from the problematic PPAs (I didn't).
Still no luck, the PPA items remain in Ubuntu Software Center under the "All Software" and "Installed" dropdown menus.

@James Hudon
Did you try the "sudo update-apt-xapian-index" command?

James Hudon (jameshudon) wrote :

@Michael Giacomoli
That worked! Thank you :)
off-topic: Where can I find out more about the different software center-related commands for future problems?

@James Hudon
I'm glad that it helped you :)
Unfortunately i neither know update-software-center existed before today.
What I know is that apt-get update updates dpkg & co database, while xapian etc etc updates the software-center one.
I think that about version 10.10 and 11.04 update-software-center has been replaced with update-apt-xapian-index.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers